none
TS Win2008 no detecta impresoras de red RRS feed

  • Pregunta

  • Saludos, les explico nuestro problema.

    Tenemos una red local con varios equipos con XP e impresoras, algunas impresoras son de red (llamémoslas A) y otras conectadas a  equipos directamente (llamémoslas B).

    Por otro lado tenemos un servidor Windows 2008 externo a la red local con el que nos conectamos mediante Terminal Services desde diversos equipos y usuarios distintos.

    Queremos que cualquier usuario de la red que se conecte al servidor pueda imprimir documentos en las impresoras locales, por lo que cuando iniciamos el 'Escritorio Remoto' compartimos discos e impresoras.

    Cuando nos conectamos al servidor con cualquier usuario o equipo de la red local, las impresoras conectadas directamente a equipos de la oficina (B) aparecen automáticamente y funcionan pero las que están en red no son detectadas (A).

    Hemos agregado los drivers específicos para estas impresoras de red al servidor y aunque sigue sin detectarlas automáticamente cuando conectamos, hemos conseguido agregarlas manualmente (desde la sesión del root) especificando el driver y puerto PRN que usan para comunicarse con el equipo local y transferir los trabajos de impresión.

    El problema que cada vez que conectamos desde un equipo distinto del que configuramos las impresoras (o reiniciamos este), las PRN se ve que cambian o son diferentes en cada equipo y las impresoras dejan de funcionar pues pasan a estar a un puerto llamado "Inactive TS port" y al enviar un documento a imprimir da error, pues no es capaz de transmitir la orden a la impresora local.

    Creemos que la solución es que las detecte automáticamente y no asignarlas manualmente.

    ¿Cómo podemos hacer para que detecte automáticamente las impresoras y las asigne correctamente al puerto que corresponda para que funcionen siempre?

    Espero sus respuestas y gracias de ante mano.

    PD: añado un par de capturas:

    Visor de eventos dónde muestra error 1111 que no encuentra el driver y ventana con los drivers instalados dónde se aprecia que sí esta.

    http://img44.imageshack.us/i/cap1.png/

    Ventana de puertos dónde se ven algunos PRN de la impresora que si funciona

    http://img197.imageshack.us/i/cap2.png/

    Actualización:

    He usado la herramienta "Terminal Server Printer Driver Redirection Wizard" pero me sale este error:

    http://img189.imageshack.us/i/cap3f.png/
    • Editado David Bonet viernes, 12 de junio de 2009 16:53
    viernes, 12 de junio de 2009 15:22

Respuestas

Todas las respuestas

  • Solucionado.

    Al instalar el .NET framework 3.0 SP 1 en los equipos cliente con XP ya detecta correctamente todas las impresoras.

    Así de simple.
    martes, 16 de junio de 2009 9:12
  • Hola David Bonet:

    Realizando las configuraciones segun lo indicado en los equipos xp clientes del terminal server:Service Pack 3 y Net frame 3.5, las impresoras locales de mi red son detectadas y se imprime sin problemas.
    Pero se me esta presentando un inconveniente al momento de querer imprimir codigo de barras desde Office y desde un Software ERP que manejamos en la empresa.
    Para la generacion del codigo de barras usamos una fuente llamada Bar Code 128 (Tru Type).  Pero sin embargo desde una sesion terminal imprimimos parte del documento pero lo que esta generado como codigo de barras solo sale como simbolos.
    Tengo la fuente instalada tanto en el terminal como en el cliente xp.

    He realizado pruebas locales haciendo combinaciones de configuraciones de Service Pack  y Net frame, pudiendo imprimir localmente desde el enlace de red donde se encuentra el terminal server logrando imprimir y reconocer impresoras con esta configuracion:
    - Service Pack 2.0, Service Pack 2.0 RDC 6.1/ Service Pack 3.0
    - Net frame 2.0 Service Pack 2

    Estas combinaciones remotamente no me sirven por que se reconocen las impresoras.

    Cual podria ser el problema?
    ¿Como puedo hacer para que la impresion de codigo de barras se efectue remotamente?

    Es espera de tu valioso aporte.

    Atte.
    Carlos Rojas
    Soporte Tecnico Infomatico




    martes, 30 de junio de 2009 16:44
  • Deberías cargar el driver de la impresora si es una impresora extraña a ver si así ya imprime lo que quieras
    martes, 22 de septiembre de 2009 17:29
  • como solucionaron este problema q yo tambien tengo
    miércoles, 22 de diciembre de 2010 17:13
  • A mi me pasa exactamente lo mismo y con una fuente de código de barras desde Ms Dynamics NAV 2009 R2.

    He instalado el Framework 3.5 y lo he actualizado con todos los parches que me propone el MS Update y el problema no es de una impresora, porque me sale el error tanto si lo imprimo como si genero un PDF (PDF Creator).

    Y la fuente la tengo tanto en el servidor de terminal server como en el cliente. (c:\windows\fonts)

    Un saludo y gracias por adelantado.

    NOTA:

    Servidor: W2008 Server R2 - Actualizado  y haciendo de Servidor de Terminal Server

    Cliente: windows XP SP3 Totalmente actualizado con Framework 3.5 SP1 y sus parches (además del 1.1 y del 2.0)

    martes, 28 de agosto de 2012 8:47