none
Error en Exchange 2010 (Event 8194 VSS) RRS feed

  • Pregunta

  • Buenos días, tengo un problema con un servidor Exchange 2010, al intentar realizar backups con Symantec NetBackup 7.6

    aparentemente se genera el error inestabilidad del Servicio de Replica de Exchange

    Writer name: 'Microsoft Exchange Replica Writer'
       Writer Id: {76fe1ac4-15f7-4bcd-987e-8e1acb462fb7}
       Writer Instance Id: {e8593323-94b3-4e12-8586-41123de87bc3}
       State: [7] Failed
       Last error: Retryable error

    y esto genera un error en Netbackup y al ser un Job Failed genera logs que no se borran.. en pocas palabras no me deja realizar copias de seguridad y se me llena el servidor de logs :(

    En Event Viewer figura esto:

    Volume Shadow Copy Service error: Unexpected error querying for the IVssWriterCallback interface.  hr = 0x80070005, Access is denied.
    . This is often caused by incorrect security settings in either the writer or requestor process. 

    Operation:
       Gathering Writer Data

    Context:
       Writer Class Id: {e8132975-6f93-4464-a53e-1050253ae220}
       Writer Name: System Writer
       Writer Instance ID: {db4d210f-eb99-458a-83dc-451c00c745bd}

    Buscando en Foros encuentro que hay que revisar el servicio de Shadow copy, cosa que ya hice y reiniciando el servicio de Microsoft Exchange Replication o el equipo se resuelve, si temporalmente hasta que se vuelve a caer en horas o al dia siguiente..

    Agradeceria cualquier informacion o ayuda.

    Saludos!

    Aclaro ya reinicie equipo y servicios en el momento se soluciona pero a las horas o al otro día se vuelve a caer.. en todo foro que busque solamente dice que hay que reiniciar.. pero es una complicación cuando tenes muchas bases de mailbox en mas de un nodo.. por lo que no puedo reiniciar a cada rato.. desde ya muchas gracias!

    jueves, 14 de abril de 2016 18:09

Respuestas

  • Hola Danielmpf,

    Esto es un detalle común con herramientas de respaldo, tenemos dos formas de atacar esto...,

    La primera que te voy a proponer es que instales el feature de Backups de Windows Server y realices un  Full backups de tus bases de datos con la aplicación nativa de Windows Server.

    Si este se realiza de manera efectiva, entonces la falla se debe a alguna configuración con NetBackup y sería oportuno que revisaras la configuración del mismo.

    La segunda es usando un Script de Microsoft que justamente hace un tanto un troblueshooting de los VSS y nos permite conocer más detalles; sin embargo pensaría que con la primera opción todo debería estar ok; aún así te anexo el artículo para tu revisión:

    Troubleshoot your Exchange 2010 database backup functionality with VSSTester script

    Quedo atento, saludos

    • Propuesto como respuesta Moderador M martes, 19 de abril de 2016 14:52
    • Marcado como respuesta Moderador M jueves, 21 de abril de 2016 17:11
    jueves, 14 de abril de 2016 18:47

Todas las respuestas

  • Hola Danielmpf,

    Esto es un detalle común con herramientas de respaldo, tenemos dos formas de atacar esto...,

    La primera que te voy a proponer es que instales el feature de Backups de Windows Server y realices un  Full backups de tus bases de datos con la aplicación nativa de Windows Server.

    Si este se realiza de manera efectiva, entonces la falla se debe a alguna configuración con NetBackup y sería oportuno que revisaras la configuración del mismo.

    La segunda es usando un Script de Microsoft que justamente hace un tanto un troblueshooting de los VSS y nos permite conocer más detalles; sin embargo pensaría que con la primera opción todo debería estar ok; aún así te anexo el artículo para tu revisión:

    Troubleshoot your Exchange 2010 database backup functionality with VSSTester script

    Quedo atento, saludos

    • Propuesto como respuesta Moderador M martes, 19 de abril de 2016 14:52
    • Marcado como respuesta Moderador M jueves, 21 de abril de 2016 17:11
    jueves, 14 de abril de 2016 18:47
  • Hola Daniel, consulta, este problema recien se presenta? o desde el primer intento muestra este error?, tienes las credenciales suficientes para este proceso?

    Saludos,


    Peter Chirinos | IT Consultant, MCP, MCSA, Microsoft Office Master, Software Developer, Microsoft Certified Professional, MAP , Microsoft Small Business Specialist, Veeam Technical Sales Professional (VMTSP), Veeam Sales Professional (VMSP), VMware Technical Solutions Professional (VTSP) | @peter_chirinos

    domingo, 17 de abril de 2016 16:11
  • Muchas Gracias por las respuestas, hicimos la prueba que nos recomendaste y si funciono por lo que levantamos un caso a Veritas, y chequeando a fondo la configuración y luego realizando un full backup, este se hizo sin problemas, Se agradece la ayuda y estamos en contacto,

    Saludos!

    jueves, 28 de abril de 2016 12:42