none
Chrome navega con HTTPS salteando Proxy TMG 2010 RRS feed

  • Pregunta

  • Buenas tardes a todos,

    Tengo instalado TMG 2010 sobre un Windows Server 2008 R2.

    He creado todas las reglas correspondientes para el control del tráfico de los usuarios, pero hay algo que no está funcionando. 

    He bloqueado Facebook en todos los usuarios de la red y en Internet Explorer se bloquea perfectamente, tanto para http como para https; pero cuando la gente abre Google Chrome, por http se encuentra bloqueado por el Proxy, pero si escriben por ejemplo "httpS://www.facebook.com" o la página que sea.. por medio de HTTPS pueden ingresar a TODO tipo de página, por más de que se encuentre bloqueada en el Proxy.

    Si bien este es un error del cual no encuentro solución en internet, me propuse borrar todas las reglas de acceso web, y crear una sola bloqueando TODO tipo de tráfico, y en google chrome sigue pasando lo mismo.

    Desactive todo tipo de comprobación de HTTPS y de certificados, pero no hay caso.


    Existe acaso alguna forma de bloquear la navegación por HTTPS en Google Chrome? 

    Espero su respuesta, gracias!!

    viernes, 9 de agosto de 2013 19:07

Todas las respuestas

  • Amigo, estamos en la misma situación.

    Creamos las reglas del TMG y por casualidad no dimos cuenta que algunos usuarios ingresan a paginas que se supone están bloqueadas y luego de varios golpes y arrebatos nos percatamos que ingresaban con Chrome. Pues resulta que este navegador si tiene activado "detección de la red automática" en la "Configuración de la red de área local" de configuración avanzada (que lo trae por defecto) no le para a nada...

    Encontré esto pero solo falta que actulice automaticamente...

    Option Explicit
    Dim WSHShell, strSetting
    Set WSHShell = WScript.CreateObject("WScript.Shell")

    'Determine current proxy setting and toggle to oppisite setting
    strSetting = wshshell.regread("HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyEnable")
    If strSetting = 1 Then
    NoProxy
    'MsgBox "Sin proxy",vbCritical,"Activa/Desactiva Proxy"
    Else Proxy
    'MsgBox "Proxy habilitado",vbInformation,"Activa/Desactiva Proxy"
    End If

    'Subroutine to Toggle Proxy Setting to ON
    Sub Proxy
    WSHShell.regwrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyEnable", 1, "REG_DWORD"
    End Sub

    'Subroutine to Toggle Proxy Setting to OFF
    Sub NoProxy
    WSHShell.regwrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyEnable", 0, "REG_DWORD"
    End Sub

    'Subroutine to Toggle Proxy Setting to ON
    Sub Proxy
    WSHShell.regwrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyEnable", 1, "REG_DWORD"
    End Sub

    'Subroutine to Toggle Proxy Setting to OFF
    Sub NoProxy
    WSHShell.regwrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyEnable", 0, "REG_DWORD"
    End Sub

    Revisalo


    • Propuesto como respuesta Uriel Almendra martes, 1 de octubre de 2013 17:28
    viernes, 27 de septiembre de 2013 21:42
  • Disculpame, me sucede igual. sabrias como solventar este problema. Anda genial en IE.

    el descurimiento WPAD para mi es una de las falencias.

    jueves, 8 de enero de 2015 15:12
  • Buenas Tardes; yo he solucionado el acceso a las paginas Web con cifrado Seguro HTTPS creando un URL SET donde incluyo el dominio *.example.com y example.com, esto permite bloquear el dominio sin importar si la solicitud es en http o https

    jueves, 9 de abril de 2015 16:29
  • Mira, para Chrome, no me funciona tampoco de esa forma.

    Algo mas se te ocurre?

    Gracias!

    miércoles, 24 de junio de 2015 19:37