none
Como implementar bien WSS 3.0 modo activacion de cuenta con Active Directory RRS feed

  • Pregunta

  • Hola amigos, que sugerencias me dan para implementar bien el modo de cuenta active directory. Soy novato en el tema, les cuento lo que hice hasta ahora, tengo una maq host WS2008 y otra virtualizada tambien WS2008, en esta ultima esta el controlador de dominio de active directory, tengo creado una unidad organizativa para sharepoint con los permisos delegados de creacion y modificacion para un usuario del dominio (el que uso para administrar luego sharepoint).

    Bueno en el host ya estoy asociado al dominio, y entro en una secion del usuario de dominio que tiene permisos en la unidad organizativa, instalo sharepoint y aqui mi pregunta.

    Probe usar el asistente para configurar sharepoint y en la parte de configuracuion avanzada relleno los campos relativos al modo de creacion de cuentas active directory. Pero despues

    en el administrador de sharepoint no puedo crear sitios y demas, esto por el modo activacion de cuentas active directory, y es donde tengo que usar stsadm.

    Pero la verdad no me sale nada, no puedo salir del sitio de administracion central que crea el asistente de configuracion de sharepoint, me gustaria poder crear una nueva aplicacion web para usar otra base de datos y en ella tener un sitio de nivel superior y que quede listo para empezar a usar el administrador de este ultimo sitio desde el explorador.

     

    miércoles, 21 de abril de 2010 12:20

Todas las respuestas

  • Hola Manu Mantis

    A lo que entiendo de tu correo tienes dos maquinas una virtual y una fisica ambas con ws 2008 correcto? y lo que no te deja es crear sitios o demas una vez que instalaste SharePoint? te da algun error? te dice que no tienes permisos? Puedes crear web applications nuevas? has intentado crear un usuario fuera del ou de SharePoint e instalar con ese?

     

    Saludos

    miércoles, 21 de abril de 2010 15:23
  • Haber si entendi bien... tu ya instalaste WSS 3.0 sin problemas con el usuario de dominio que tienes en tu OU, correcto?... ese usuario tiene permisos de administrador de dominio?

    Despues comentas que al entrar a la configuración de SharePoint, en la parte de configuración avanzada estas configurando algo sobre el modo de creación de cuentas de AD... a que sección avanzada te refieres?, algo dentro de la Administración Central o del Asistente de Configuración de Tecnologías y Productos SharePoint?

    Ahora bien, con el usuario con el que instalaste SharePoint me imagino que tambien corriste el asistente de configuración y con ese mismo se creo la Administración Central, por lo tanto ese usuario tiene acceso a la Administración Central, correcto?... usaste SQL Server en tu configuración o instalaste todo con Next, Next, Finish?... lo pregunto porque cuando instalas SharePoint, puedes definirle que use una base de datos recortada propia que trae el instalador o que use SQL Server, en cada caso la configuración es diferente y requieres de algunas cosas adicionales en SQL Server.

    Finalmente dices que no puedes crear sitios ni aplicaciones web, lo intentas hacer con el usuario de dominio con el que instalaste SharePoint?... que error te manda al ejecutarlo?... me imagino que lo haces esto desde la Administración Central correcto?, porque comentas algo de stsadm, pero no se que es lo que estas intentando hacer a través de la línea de comandos, nos puedes comentar...

     

    Saludos;

    Vlad


    Vlad Blogs: http://sharepointblogs.com.mx/blogs/medinav/default.aspx & http://vladpoint.wordpress.com/
    miércoles, 21 de abril de 2010 15:28
    Moderador
  • Gracias por contestar. El tema es asi, necesito sharepoint con el modo de cracion de cuentas active directory, y si tengo un dominio active directory y en la maquina host donde insatale el sharepoint es un usuario administrador del dominio active directory. También ese usuario tiene los permisos de dbcreator y dbadmin del SQL server. Bien como entendes tengo todo armado para insatalar sharepoint, lo instalo y luego uso el asistente, le digo que es un conjunto de servidores, especifico el servidor SQL, le doy nombre a la BD, luego el puerto para la pagina de adm central, y en la ultmima pantalla del asistente un boton dice configuracion avanzada, ahi me pregunta si quiero usar modo de creacion de cuenta active directory, y asi es como quiero por ende ingreso el dominio y la unidad organizativa para sharepoint. Bien corre todo en orden y al final me muestra el sitio de administracion central.

    Y de aca que me deja hacer: Me deja hacer todo lo normal, incluso puedo crear nuevas aplicaciones web.

    Que no me deja: no puedo desde el sitio de administracion central crear sitios de nivel superior, por ejemplo para la nueva aplicacion web que acabo de crear, y me dice que no lo puedo hacer por la configuracion actual:


    "No se puede mostrar esta página porque no es compatible con la configuración
    actual del servidor. Para realizar esta tarea, utilice las operaciones de la
    línea de comandos de Stsadm.exe. ''

     

    Entonces uso el stsadm e intento crear un sitio para una aplicacion web que acabo de crear

    el comando es

    stsadm -o createsite -url http://wsss:3540  -ownerlogin CONDOR\Administrador -owneremail:mimail@hotmail.com

    y eso me da un error:

    el dominio especificado no existe o no se puede poner en contacto con el

    <Excepcion de HRESULT 0x8007054B >

     

     

    la verdad que no se como continuar, si el error es por parte del dominio de la cuenta CONDOR\Administrador no puede ser porque es la que ocupo  como administrador del sharepoint y me la reconoce bien. 

    ?????????

    De ultima que otra alternativa tengo para poder crear un sitio en la nueva aplicacion web que cree!!!!

    necesito empezar a configurar la informacion de los sitios y no puedo salir de aca, jeje,

    gracias por tu atencion!!

     

     

     

    jueves, 22 de abril de 2010 18:00
  • Alguien de ustedes alguna vez pudo implementar el modo de activacion de cuentas active directory??

    Me imagino que si, yo intenté y todavia no puedo. Mi problema se relata en preguntas anteriores.

    Si algien me cuenta como lo implemento alguna vez puede que me de cuenta que hice mal y si

    es que se puede. Estoy haciendo una practica para la facu de esto y no puedo avanzar, gracias!
    viernes, 23 de abril de 2010 18:41
  • Un favor Manu, no crees nuevos temas con las mismas preguntas, si alguien te puede contestar tu duda, lo hará en el tema que ya tienes abierto, no es necesario que estes llenando de temas repetidos el foro para que la gente te conteste, voy a combinar este tema con el que ya tienes abierto y por favor toma estos consejos de ahora en adelante...

     

    Saludos;

    Vlad


    Vlad Blogs: http://sharepointblogs.com.mx/blogs/medinav/default.aspx & http://vladpoint.wordpress.com/
    viernes, 23 de abril de 2010 20:21
    Moderador
  • Colegas les comento que resolvi parcialmente el problema, pude solucionar el  error

    el dominio especificado no existe o no se puede poner en contacto con el<Excepcion de HRESULT 0x8007054B >

    Cuando estan usando el asistente de configuración y en la última pantalla presionan el boton CONFIGURACION AVANZADA, este boton nos lleva a una pantalla para poner datos referentes al modo de activacion de cuentas Active Directory. Bien esa pantalla nos pide dos datos para crear cuentas de  AD.

    1. Dominio del controlador Active Directory

    2. Unidad organizativa para sharepoint

    El punto 1 como el nombre lo indica pense que era el nombre de dominio que configuramos como raiz del bosque del controlador AD (Este controlador se instala en un equipo diferente al que corre sharepoin,  o bien virtualizado como mi caso). Ahi estaba mi error!!!!!

    Para iniciar cesion con una cuenta de usuario del dominio de AD uso el nombre netbios, es decir si mi dominio es:

    empresa.local           

    el nombre netbios que nos ofrece windows por ejemplo es 

    EMPRESA (esto se puede cambiar, es solo una sugerencia)

    supongamos que nuestro nobre netbios es entonces EMPRESA, y en una maquina que este asociada al dominio iniciamos cesion como EMPRESA\Manuel

    Entonces amigos, en la configuración de modo creacion de cuantas active directoy en el asistente de configuración, en el campo dominio  pongan el nombre netbios, tal cual como usan para loguearse e iniciar cesion.

    para mi ejemplo pongo EMPRESA

    no poner empresa.local porque genera el error de dominio desconocido al querer crear un sitioweb.

    Espero que a alguien le sirva, muchos tienen este problema y realmente es muy tonto.

    Un saludo!!

     

    domingo, 25 de abril de 2010 6:11
  • Disculpen señores.

    Yo tengo el mismo problema o Error, pero la solucion que tuvo Manu Mantis, no es la misma solucion que la mia, porque yo lo hice igual como la solucion que el da y siempre me sigue apareciendo el error.

    Mi error se origina cuando yo quiero crear o eliminar colecciones de sitios y tambien cuando quiero ejecutar el asistente de configuracion del conjunto de servidores que se encuentra en la administración central.

    Me pueden ayudar por favor?

    Gracias!.

    Saludos.


    Ing. Mario Hernández Ing. Soporte Técnico Division de Informatica y Sistemas Ministerio de Energía y Minas
    martes, 28 de junio de 2011 22:04