none
Quitar icono "subir nivel" de la ventana guardar como... RRS feed

  • Pregunta

  • Hola,

    estoy configurando unos perfiles restringidos de terminal server en windows 2003 R2 y me encuentro con el problema que al exportar excel, desde la aplicacion a usar, me lleva a rutas en las cuales si tenemos la opcion "subir nivel" ven carpetas que no deberian ver

    Sabeis si hay alguna forma sea por directivas u otra manera de quitar "subir nivel"

    Gracias

    miércoles, 17 de noviembre de 2010 11:22

Todas las respuestas

  • En este tipo de entonro lo normal es tener redirigida la carpeta de Mis Documentos a un sitio en red, y tner configurado en las propiedade del usaurio que su Default Path apunte también a otra ubicación (en las propiedades del user, en la pestaña de Terminal Server, le puedes asignar además una letra); luego por GPO, configuras para que en el TS el usuario no vea el resto de unidades que no necesite del servidor, y así sólo vea su Home Folfer y no pueda subir más niveles siquiera
    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    miércoles, 17 de noviembre de 2010 11:42
  • Gracias,

    los usuarios son externos a la empresa, asi que la primera idea es que no accedan a ningun recurso compartido del servidor y conectarles mediante recursos locales de escritorio remoto su disco para que sea ahi donde exporten los excel necesarios y posteriormente puedan trabajar con ellos

    Se podria poner que directamente apunte al disco duro de las maquinas externas?

     

     

    miércoles, 17 de noviembre de 2010 14:20
  • Independientemente de que sean externos o no, van a usar una cuenta de usaurio en tu dominio; si es un TS, la GPO para restringir el acceso y la visivilidad de las unidades del server la tienes que poner sí o sí.

    Tras ello revisa de nuevo y nos comentas


    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    miércoles, 17 de noviembre de 2010 14:23
  • Si eso ya lo tengo puesto y sin problema

    El tema es que hay dos escenarios distintos...

    Uno, la aplicacion me exporta a excel, me abre excel y desde excel voy a guardar como...eso entiendo que lo soluciono con las indicaciones de antes. Y aun teniendo la opcion de subir nivel, voy al escritorio y no accedo a nada. Si voy a Mi Pc solo veo mi disco duro local a traves de escritorio remoto

    Dos, la aplicacion en vez de abrirme excel genera el excel y directamente lo guarda en una ruta que el usuario no debe tener acceso. Con lo cual, si voy a guardar como y pincho en subir nivel, ya estoy viendo datos que no deberia ver, a pesar que tengo todas las unidades quitadas por directiva

    Si no doy permisos a esa carpeta en concreto, la aplicacion directamente al generar excel me da erro

    Eso se puede solucionar a traves de windows o es solo tema de la aplicacion? esto se me escapa

    Muchas gracias

     

    miércoles, 17 de noviembre de 2010 17:24
  • Es problema de la aplicación; entiendo que la aplicación al fin y al cabo lo que ahce es genrar un simple report que luego pasará a Excel; eso con las GPO que te comento no es problema, ya que la aplicación debería generar, en teoría, el ficehro en una ubicación temporal del perfil o de su homePath en el peor de los casos, para luego tú ya poder "guardar como" te de la gana en donde quieras.

    Si la aplicación no va así, dónde lo intenta guardar entonces que da error si no hay permisos?? En C:\ diretamente, en su directorio de instalación?


    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    jueves, 18 de noviembre de 2010 6:53
  • Lo guarda directamente en un directorio de su aplicacion y lo abre. Al ir a guardar como es cuando se puede acceder a los datos. Y si, si no le doy permisos a la carpeta donde lo guarda, directamente la aplicacion da error al generar el excel

     

    Gracias

    jueves, 18 de noviembre de 2010 9:56
  • En ese caso, deja la GPO para oculte todo, y al usaurio sólo dale permisos NTFS en la carpeta para Modificar
    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    jueves, 18 de noviembre de 2010 10:16
  • Ok,

    es mas, donde me guarda el excel es en otro server que es donde esta la aplicacion, ni siquiera en el perfil del servidor TS. En este caso, no conseguire nada con cambiar el perfil TS o el default Path, no? (nunca he cambiado estas configuraciones)

    Gracias

    jueves, 18 de noviembre de 2010 11:46
  • OK, en ese caso, prueba a dejar ocultas las unidades de todo, y da los permisos NTFS a ver qué tal resulta sin cambiar las otras configuraciones
    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    jueves, 18 de noviembre de 2010 11:56
  • Asi es como lo tengo y nada
    jueves, 18 de noviembre de 2010 12:01
  • Entonces el problema lo tenemos con la aplicación; no es posible configurarla para que guarde en otra ruta?

    Si no, la aplicación se ejecuta en local en el Terminal Server y guarda en remoto? (es decir, la aplicación está isntalada en el TS como tal), O la aplicación se ejecuta también en remoto y guarda en remoto? (es decir, que el usuario ejecuta el .exe de la aplicación desde un \\ruta\carpeta\programa\programa.exe)


    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    jueves, 18 de noviembre de 2010 12:11
  • El usuario se conecta al serverTS y desde ese se ejecuta la aplicacion directamente por directiva que esta instalada en local en otro serveraplicacion. Cuando el usuario abandona la aplicacion la sesion se cierra

    Cuando guardo, segun la operacion que se realize suceden dos cosas...,

    lo guarda en \\serverapliacion\xxxx\xxxxxxxx.xls o en \\serverTS\C\documentsandsett..\mis docu (esto ultimo tal vez lo solucione con tus indicaciones, pero el primer caso es el problema)

    jueves, 18 de noviembre de 2010 12:34
  • En ese caso, en el server que comparte el acceso, establece en el Share los permisos, y usa el Enabled Based Enumeration paa que aunque suba niveles, no vea las carpetas a las que no tenga acceso

     

    http://www.windowsnetworking.com/articles_tutorials/Implementing-Access-Based-Enumeration-Windows-Server-2003.html


    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    jueves, 18 de noviembre de 2010 12:56
  • Eso tiene buena pinta, no conocia esta herramienta

    Aunque la instalacion la haga,  "Enable Access-based Enumeration on all existind shared folders" 

    una vez instalada lo podre cambiar al modo manual?

    jueves, 18 de noviembre de 2010 13:46
  • Sí, es reversible el cambio; pero esto como siempre, anbtes de poner en producción, testéala en pruebas por si acaso siempre antes


    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    jueves, 18 de noviembre de 2010 15:02
  • Muchas gracias por todo, tengo que mirarlo bien
    jueves, 18 de noviembre de 2010 17:33