none
Contar registros repetidos una vez RRS feed

  • Pregunta

  • Hola, me habia alejado un poco de estos foros debido al trabajo. Bueno, tengo la funcion que me permite contar los registros repetidos una vez y sumarlos:

    =SUMAPRODUCTO(1/CONTAR.SI(C21:C489;C21:C489))

    Bien, el problema es si le pongo que cuente desde la celda c21 hasta la ultima fila de la hoja, como lo nuestro aqui:

    =SUMAPRODUCTO(1/CONTAR.SI(C21:C489;C21:C65000))

    la formula no funciona.

    La duda es, ¿Como hago para contar los registros repetidos una vez y cada vez que ingrese un registro nuevo no tenga que volver a realizar la formula?

    Gracias
    domingo, 2 de marzo de 2008 22:51

Respuestas

  •  

    Hola,

     

    Tu formula esta bien mientras en el rango no existan celdas vacías, y el error que me dices me asegura que tienes celdas vacias por lo tanto excel trata de dividir entre 0 y es por eso el error, asi que tu formula deberá ser esta:

     

     =SUMAPRODUCTO((C21:C65000<>"")/CONTAR.SI(C21:C489;C21:C65000&""))

     

    Listo asi deberá funcionar.

     

    Saludos

    miércoles, 5 de marzo de 2008 4:59

Todas las respuestas

  •  

    Hola,

     

    Tu formula esta bien mientras en el rango no existan celdas vacías, y el error que me dices me asegura que tienes celdas vacias por lo tanto excel trata de dividir entre 0 y es por eso el error, asi que tu formula deberá ser esta:

     

     =SUMAPRODUCTO((C21:C65000<>"")/CONTAR.SI(C21:C489;C21:C65000&""))

     

    Listo asi deberá funcionar.

     

    Saludos

    miércoles, 5 de marzo de 2008 4:59
  •  Ruben Salgado Escribió:

     

    Hola,

     

    Tu formula esta bien mientras en el rango no existan celdas vacías, y el error que me dices me asegura que tienes celdas vacias por lo tanto excel trata de dividir entre 0 y es por eso el error, asi que tu formula deberá ser esta:

     

     =SUMAPRODUCTO((C21:C65000<>"")/CONTAR.SI(C21:C489;C21:C65000&""))

     

    Listo asi deberá funcionar.

     

    Saludos

     

     

    Estimado Sr Salgado, seria mucho pedir que por favor me explique la sintaxis de su formula??, es que en los años que he usado excel (que no son muchos en realidad) no habia visto que utilizaran la combinacion de los operadores <>"" y &"" justo despues de indicar un rango, cuando escribimos esto que le estamos indicando a Excel??

    jueves, 8 de mayo de 2008 0:23
  •  

    Que tal, bueno te explico que, cuando veas <> sigifica diferente y "" es nulo, así pues le dije a excel que buscara en el rango marcado pero siempre y cuando sean celdas diferentes de nulo, es decir vacias.

     

    Saludos

    jueves, 8 de mayo de 2008 7:31
  • Y cuando ocupamos &"", le estamos indicando a Excel que concatene nulo??

    jueves, 8 de mayo de 2008 13:49
  • Muy buena solución

    Tengo otra consulta para Ruben si ademas de esto quisiera agregar otra condicion por ejemplo

      a    pedro

      a    gaston

      a     gaston

      b     maria

      b    german

      b    

      b    Jose

    Por ejemplo en este caso que cuente en a cuantos valores no repetidos hay serian para a =2  y para b = 3

    No se si me explique

    SDs

    Germán

    lunes, 7 de febrero de 2011 12:13
  • Excelente respuesta!! Gracias me funciono!!!
    • Editado Riqnex lunes, 25 de junio de 2012 22:24
    lunes, 25 de junio de 2012 22:24
  • buenas tardes.

    necesito ayuda con la siguiente interrogante:

    en la columna A tengo el nombre de la actividad y en la columna B tengo el numero de casa productora y quiero que el resultado sea por ejemplo: Actividad 1 se repite en dos Casas productoras.

    Actividad                                               Casa productora

    A1 CAMBIO DE CORTINA                           B1 PRODUCTORA 1

    A2 CAMBIO DE HILO ACRILICO                 B2 PRODUCTORA 2

    A3 CAMBIO DE CORTINA                           B3 PRODUCTORA 2

    A4 CAMBIO DE POLEA                               B4 PRODUCTORA 1

    AL FINAL QUE ME DIGA

    ACTIVIDAD                                           PRODUCTORAS

    CAMBIO DE CORTINA                                     2

    CAMBIO DE HILO ACRILICO                           1

    CAMBIO DE POLEA                                         1

    QUE FORMULA PUEDO EMPLEAR? PORQUE YA INTENTE MUCHAS Y NADA.

    DE ANTEMANO GRACIAS.

    jueves, 5 de julio de 2012 21:36
  • ESTA FORMULA LA ENTIENDO: =SUMAPRODUCTO((C21:C65000<>""), PERO QUE EXPLICACION TIENE LA SIGUIENTE: CONTAR.SI(C21:C489;C21:C65000&""))? PORQUE LA EMPLEE DE ESTA MANERA, CLARO SOLO CAMBIO EL RANGO, Y ME SIRVIO DEL TODO BIEN, PERO NO ENCUENTRO UNA EXPLICACION A LA MISMA.

    SUMAPRODUCTO((Registro_Inversion!$L$2:$L$100000<>"")/CONTAR.SI(Registro_Inversion!$L$2:$L$100000,Registro_Inversion!$L$2:$L$100000&""))


    • Editado Riqnex jueves, 5 de julio de 2012 21:44
    jueves, 5 de julio de 2012 21:43
  • Hola Riqnex,

    =SUMAPRODUCTO((C21:C65000<>"")

    Esta parte de la fórmula da "VERDADERO" cuando la celda está ocupada y "FALSO" cuando está vacía. Los VERDADEROS valen 1 y los FALSOS 0. La parte  <>""  sirve para evitar que las celdas vacías cuenten como valor CERO y creen el error de dar este valor.

    De hecho si no tienes celdas vacías puedes sustituir esta parte de la fórmula por el número 1

    CONTAR.SI(C21:C489;C21:C65000&""))

    esta parte está mal porque los dos rangos han de coincidir, supongo que es un error de transcripción.

    Si damos por hecho que los dos rangos son idénticos CONTAR.SI cuenta las veces que hay determinado valor en el rango. Supongamos que hay 2 de un determinado valor, cada división de ese valor dará 0,5 (divide 1 -si está ocupada- por 2).La suma final de este valor será 1 (0,5+0,5) o sea que ha "eliminado" el repetido, y así sucesivamente.

    La parte  &""  evita las celdas vacías que provocarían ERROR (división por 0)

    Saludos,

    Xavier

    viernes, 6 de julio de 2012 17:52
  •  

    Hola,

     

    Tu formula esta bien mientras en el rango no existan celdas vacías, y el error que me dices me asegura que tienes celdas vacias por lo tanto excel trata de dividir entre 0 y es por eso el error, asi que tu formula deberá ser esta:

     

     =SUMAPRODUCTO((C21:C65000<>"")/CONTAR.SI(C21:C489;C21:C65000&""))

     

    Listo asi deberá funcionar.

     

    Saludos

    Hola

    Se podria usar esa forlmula con SUBTOTAL? o necesito aplicar un criterio adicional para visualizar cuando aplico filtro?

    lunes, 12 de junio de 2017 16:03
  • Hola Michael:

    Prueba con esta matricial (llos datos están en la primera columna).

    =SUMA(SI(FRECUENCIA(SI(SUBTOTALES(3;DESREF(A1;FILA(A1:A10000)-FILA(A1);;1));A1:A10000);A1:A10000);1))

    Ya sabes que para que te funcione correctamente debes pegarla en la celda y a continuación pulsar Control + Mayusc + Enter.

    Por si acaso de dejo el enlace: https://support.office.com/es-es/article/Crear-una-f%C3%B3rmula-de-matriz-e43e12e0-afc6-4a12-bc7f-48361075954d

    Saludos.

    martes, 13 de junio de 2017 20:24