none
Implementación de Webpart.! RRS feed

  • Pregunta

  • Hola Que tal.!!

    En visual studio 2012 se genero un proyecto de webparts, el cual pues se agregaron varias Visual Webparts, en visual studio se ve bien la webpart al momento de realizar un Build no me marca ningun error, realizo una implementación del proyecto y lo hace de manera correcta.

    El detalle viene cuando trato de poner la webpart en una zona y me marca el siguiente error:

    El método Execute del contenedor de código de espacio aislado generó una excepción no controlada en el dominio de aplicación de confianza parcial: Error inesperado.

    El proyecto de webparts se creo en sandbox Solution.

    De antemano muchas gracias.!!

    Saludos.!!


    Daniel Medina

    miércoles, 30 de enero de 2013 15:23

Respuestas

  • Hola Luis

    los WebPart en modo Sandbox tienes límites en el conjunto de APIs que puede utilizar. ¿No puedes crear el proyecto sin Sandbox? Si no puedes, tendrás que revisar el código porque esta lanzando una excepción de este tipo.


    Alberto Diaz Martin twitter://@adiazcan | http://geeks.ms/blogs/adiazmartin | MVP SharePoint Server

    miércoles, 30 de enero de 2013 16:51
  • Hola Que tal.!!

    Muchas gracias a los dos.!!

    Ya se solución, el detalle era que la propiedad de sadnbox del proyecto estaba en True, lo unico que hicieron los encargados del proyecto fue poner el false y listo ya se visualiza correctamente.!!

    Muchas Gracias.!!

    Saludos..!!


    Daniel Medina

    miércoles, 30 de enero de 2013 18:37

Todas las respuestas

  • Hola Luis

    los WebPart en modo Sandbox tienes límites en el conjunto de APIs que puede utilizar. ¿No puedes crear el proyecto sin Sandbox? Si no puedes, tendrás que revisar el código porque esta lanzando una excepción de este tipo.


    Alberto Diaz Martin twitter://@adiazcan | http://geeks.ms/blogs/adiazmartin | MVP SharePoint Server

    miércoles, 30 de enero de 2013 16:51
  • Hola,

    Varias preguntas:

    • ¿Te fallan todas las WebParts?
    • ¿Qué tipo de controles tienes en las mismas?
    • ¿Con qué versión de SharePoint estás trabajando? Si es SharePoint 2010, y estás siguiendo correctamente las restricciones de las soluciones Sandbox no debería haber problema. En cambio, para SharePoint 2013 puede ser que encuentres algún problema al usar las WebParts...lo comento por experiencia propia.

    Un saludo


    ------------------------------------------------------------
    Juan Carlos González Martín MVP de SharePoint Server
    Director revista CompartiMOSS: http://www.gavd.net/servers/compartimoss/compartimoss_main.aspx
    Blog: http://geeks.ms/blogs/ciin
    Twitter: @jcgm1978
    ------------------------------------------------------------

    miércoles, 30 de enero de 2013 18:33
  • Hola Que tal.!!

    Muchas gracias a los dos.!!

    Ya se solución, el detalle era que la propiedad de sadnbox del proyecto estaba en True, lo unico que hicieron los encargados del proyecto fue poner el false y listo ya se visualiza correctamente.!!

    Muchas Gracias.!!

    Saludos..!!


    Daniel Medina

    miércoles, 30 de enero de 2013 18:37
  • Hola,

    Si, pero ten en cuenta que ahora es una solución de tipo granja lo que se genera...¿es eso lo que queréis?

    Saludos


    ------------------------------------------------------------
    Juan Carlos González Martín MVP de SharePoint Server
    Director revista CompartiMOSS: http://www.gavd.net/servers/compartimoss/compartimoss_main.aspx
    Blog: http://geeks.ms/blogs/ciin
    Twitter: @jcgm1978
    ------------------------------------------------------------

    miércoles, 30 de enero de 2013 18:40