none
Classic ASP AppPool Crash and session lost RRS feed

  • Pregunta

  • Hello:

    I have an AppPool for a classic ASP application and sometimes it crashes without reason. The ssesion variables are lost and the users of the application have to log in again in order to continue with their work.

    It runs on a windows server 2008 R2.

    When the crash ocurs, the event viewer show this message :

    • A process serving application pool 'ILION' suffered a fatal communication error with the Windows Process Activation Service. The process id was '17284'. The data field contains the error number.

    I have installed the Debug Diagnostic Tool and I have a memory dump of the AppPool (1,2Gb) but I can not understand the mht report that the tool offers. I can supplied it if necesary

    Please, can anyone help me figure out the cause of the error?

    Thnaks in advance

    • The XML of the event viewer error is :

    <Event  xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

    - <System>
    <Provider Name="Microsoft-Windows-WAS"Guid="{524B5D04-133C-4A62-8362-64E8EDB9CE40}"EventSourceName="WAS" />
    <EventID  Qualifiers="32768">5011</EventID>
    <Version>0</Version>
    <Level>3</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2012-10-19T17:08:35.000000000Z" />
    <EventRecordID>160322</EventRecordID>
    <Correlation />
    <Execution ProcessID="0"ThreadID="0" />
    <Channel>System</Channel>
    <Computer>evw1900531.ILIONSISTEMAS.COM</Computer>
    <Security />
    </System>
    - <EventData>
    <Data Name="AppPoolID">ILION</Data>
    <Data Name="ProcessID">17284</Data>
    <Binary>6D000780</Binary>
    </EventData>
    </Event>
    miércoles, 31 de octubre de 2012 15:30

Todas las respuestas

  • Hi j_corbi!

    In some cases, the application needs 32 bits support. Please, check it and check if into the Application Pool -> advance settings, the option selected for "Enable 32 bit applications".

    We will wait your feedback!

    Regards,


    Pablo Ariel Di Loreto
    IT Consultant

    This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    jueves, 1 de noviembre de 2012 13:07
  • Hello Pablo:

    This feature is now set to "FALSE"

    Are you meaning that this feature should be set to "TRUE"

    Thanks in advance

    Jesús


    Jesús Corbí Ibáñez

    viernes, 2 de noviembre de 2012 8:18
  • Hi j_corbi!

    If you can test it in a "lab" environment, you could try to set it to "true".

    If not, you can review the software's documentation and check it!

    In my case, some applications needed set to "true" the "32 bit" compatibility.

    Regards,


    Pablo Ariel Di Loreto
    IT Consultant

    This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    jueves, 8 de noviembre de 2012 2:19