none
Problemas Correo eliminado RRS feed

  • Pregunta

  • Estimados,

    Hace mas de un mes que se elimino un Buzon de Exchange 2010 y cuando se envía un mail, no rebota enviando información de que mail no existe. Solo lo recibe.

    Que pudo verificar.

    Gracias,


    Edwin Duran Ospina

    lunes, 4 de agosto de 2014 15:33

Respuestas

  • Hola Edwin,

    Vi el desarrollo de tu post y me gustaria comentarte de algunas ideas que me vienen a la mente.

    1.- Habilitar un registro avanzado de eventos para el servicio de transporte.

    Desde la consola grafica es mas amigable, lo haces desde Sever Configuration>Hub Transport>Servidor X (click derecho sobre ese server)>Manage diagnostic logging properties)

    Desde el Shell, utiliza Get-EventLogLevel y Set-EventLogLevel para modificar el nivel de registro de los eventos que tienen como "Identity" este servicio de Transporte.

    2.- Saca mas detalles del evento con fuente: "Routing", utiliza el mismo comando, pero al final utiliza el FL (Format list) algo asi como: get-messagetrackinglog -messagesubject "prueba x x x" | fl

    Utliza esta liga para identificar en donde esta cayendo la comunicacion

    http://technet.microsoft.com/en-us/library/aa996349%28v=exchg.141%29.aspx

    Por el detalle mostrado arriba, esta comunicacion se queda en la etapa de "Categorizacion". Del sitio arriba mencionado, observamos este extracto:

    On the Hub Transport server, the categorizer completes the following steps:

    • Recipient resolution, which includes top-level addressing, expansion, and bifurcation

    • Routing resolution

    • Content conversion

    Additionally, mail flow rules that are defined by the organization are applied. After messages have been categorized, they're put into a delivery queue. A mailbox delivery queue delivers the message to a local mailbox by using the store driver. A remote delivery queue delivers the message to a remote recipient through a Send connector.

    Por lo que comentas y por la informacion mostrada arriba, el "categorizador" no esta logrando determinar las propiedades de este buzon, sin embargo, el uso de los eventos con nivel de registro avanzado, te ayudaran a determinar errores y posibles objetos (que esta comunicacion esta buscando) y su ubicacion.

    Espero ayude un poco.

    Saludos!

    lunes, 3 de noviembre de 2014 20:36

Todas las respuestas

  • Hola Edwin, consulta, has verificado si se a creado una regla con respecto a ese buzón?, sabés si llega a otra persona?

    Saludos,


    Peter Chirinos | Microsoft Office Specialist, Software Developer, Microsoft Certified Professional, MAP , Microsoft Small Business Specialist| @peter_chirinos

    lunes, 4 de agosto de 2014 18:38
  • Como lo puedo hacer?

    Solo tengo consola Power Shell.

    me puedes indicar como puedo verificar si tiene algún alias o si ese correo se va a otra cuenta?

    Yo ya vi en el ECP cada una delas cuentas del dominio y ninguna esta redireccionada hacia la cuenta eliminada.

    Y pues la cuenta eliminada como puedo saber si esta redirecionada hacia otra cuenta?? con que comando??

    Gracias,


    Edwin Duran Ospina

    lunes, 4 de agosto de 2014 18:50
  • Hola Edwin, suponiendo que solo estas trabajando con un solo MailboxDatabase, puede ejecutar el siguiente script para confirmar que no existe:

    Primero verifiquemos esto, si no existe, vemos las reglas.

    Saludos,


    Peter Chirinos | Microsoft Office Specialist, Software Developer, Microsoft Certified Professional, MAP , Microsoft Small Business Specialist| @peter_chirinos

    lunes, 4 de agosto de 2014 19:30
  • Estimado,

    Esa fue la primera que utilice y me informa que el usuario no existe en el DC.

    Alguna otra mas?

    Gracias,


    Edwin Duran Ospina

    lunes, 4 de agosto de 2014 21:29
  • Edwin,

    Si envías un correo con un nombre de buzón mal formado, el usuario que originó el correo recibe un rebote (NDR)? por ejemplo, si tu dominio es Edwin.com y yo envío un correo a holahola@edwin.com, recibo un rebote? te pregunto esto porque podría pasar que la política de envío de los NDR este causando esto.

    Para probar si el NDR está habilitado o no, podrías usar:

    Get-RemoteDomain "Default" | FT Name,NdrEnabled -Autosize
    Si el NdrEnabled tiene el valor $False, entonces es el problema.

    Revísalo y nos cuentas!

    Saludos,


    Jesús Peñaranda| MCP,MCT,MCTS,MCITP,MCSA,MCSE


    martes, 5 de agosto de 2014 2:25
  • Estimado,

    Ese efectivamente es el problema. me aparece en False. Como puedo activarlo.

    Gracias,


    Edwin Duran Ospina

    miércoles, 6 de agosto de 2014 14:36
  • Hola Edwin,

    Para habilitarlo:

    Set-RemoteDomain "Default" -NdrEnabled:$true

    No olvides marcar la respuesta como propuesta si te ayude a solucionar el problema!

    Saludos,


    Jesús Peñaranda| MCP,MCT,MCTS,MCITP,MCSA,MCSE

    miércoles, 6 de agosto de 2014 15:30
  • Estimado,

    Estaba deshabilitado. se ejecuta comando pero aun asi no me llega rebote de correo que no existe.

    Que puede pasar???


    Edwin Duran Ospina

    miércoles, 6 de agosto de 2014 15:38
  • Edwin,

    No lo pruebes inmediatamente, estas configuraciones pueden tomar algunos minutos en ejecutarse, en el interin podrías revisar si tienes otros dominios remotos especificados y ver en que estado está el NDR, esto lo haces reemplazando el "Default" por *, de esta manera:

    Get-RemoteDomain "Default" | FT Name,NdrEnabled -Autosize

    Con esto podrías ver si se crearon distintas reglas para distintos dominios remotos.

    Saludos,

     


    Jesús Peñaranda| MCP,MCT,MCTS,MCITP,MCSA,MCSE

    miércoles, 6 de agosto de 2014 15:53
  • Estimado,

    Ejecuto el comando enviado:

    Y me aparece Activado. lo volví a intentar ahora y tampoco me arroja el error de que el usuario no existe. O no me rebota correo.

    como puedo ver si el buzón que existía se esta enviando a otra cuenta de correo?

    En espera de una pronta respuesta.

    Gracias,


    Edwin Duran Ospina

    miércoles, 6 de agosto de 2014 16:10
  • Edwin,

    No tendrás algún otro dispositivo (Anti-spam, firewall) que esté bloqueando también el envío de NDRs? ayer te preguntaba si probaste enviar un correo a una cuenta desconocida de tu empresa xxxx@tuempresa.com para ver si se envía un rebote, es importante ir disminuyendo el alcance del problema, si funcionan los rebotes para otras cuentas, entonces el problema es con ese usuario específicamente.

    Desde Exchange 2010 puedes usar el Message Tracking que se encuentra en los Toolbox, desde el EMC.

    Saludos,


    Jesús Peñaranda| MCP,MCT,MCTS,MCITP,MCSA,MCSE

    miércoles, 6 de agosto de 2014 17:04
  • Estimado,

    Envié un correo a una cuenta que no existe y me llego el mensaje:

    De igual manera yo no tengo consola EMC solo algo gráfico tengo el OWA y el ECP. Ya que mi exchange esta instalado en "Hosting" donde hay varios dominios. Y cuando se instalo en la literatura nos informaba que no aceptaba consola gráfica. Por eso puse que solo lo puedo hacer por comando.

    Por comando se hace el message Tracking y me arroja lo siguiente: 

    Como que no entrega a nadie pero no me llega el mensaje del rebote.

    Que mas puede ser???


    Edwin Duran Ospina

    miércoles, 6 de agosto de 2014 18:41
  • Pues todo lleva a pensar que está definido así en el lado del proveedor, por temas de seguridad no se envían respuestas para evitar el guessing a las cuentas de correo y que no hagan spam, el primer mensaje que muestras hace referencia a una denegación de Relay (la prueba la hiciste internamente). En este punto te recomiendo hacer la consulta al proveedor y también revisar el Antispam, ya que ha sido él quien ha generado el mensaje de error y no el Exchange.

    Saludos,


    Jesús Peñaranda| MCP,MCT,MCTS,MCITP,MCSA,MCSE

    miércoles, 6 de agosto de 2014 18:45
  • No entendería.

    Mira:

    Tenemos un solo exchange 2010 para cinco empresas; diferentes dominios.

    111.com

    222.com

    333.com

    444.com

    555.com

    Las Cinco empresas están con el mismo AntiSpam: "Microsoft ForeFront Proteccion for Exchange 2010".

    Nosotros manejamos toda la plata forma para esta empresas; y a las cuatro les llega el rebote de que alguna cuenta no existe(ESTO PORQUE EN LAS OTRAS CREE UNA CUENTA QUE SE LLAMA PREUBADEMO@XX.COM ,LUEGO LA ELIMINE Y LUEGO ENVIÉ A ESA CUENTA DESDE MI GMAIL Y ME INFORMA CON MENSAJE QUE LA CUENTA NO EXISTE). Solo a una empresa de las cinco le pasa esto.

    Que mas puede ser????


    Edwin Duran Ospina

    miércoles, 6 de agosto de 2014 18:52
  • Hola Edwin,

    Ejecuta el comando: Clean-MailboxDatabase "la base donde estaba el buzon originalmente"

    De igual manera valida mediante comandos: get-mailbox | get-casmailbox que ya no exista el buzon y desde la consola grafica, valida que no exista el buzon en disconnected mailbox

    Saludos


    Saludos cordiales | Systems Integration Advisor | MCITP-MCSA-MCT

    sábado, 27 de septiembre de 2014 1:52
  • Estimado,

    Se procede hacer lo indicado, pero aun asi sigue el NDR sin llegar sobre el correo.

    Los demás correos que envió a cuentas que no existen llegan.

    hago un Get-MessageTrackingLog y me sale lo siguiente: solo me dice FAIL en ROUTING pero no me llega los NDR para ese correo.

    =============================================================================

    RECEIVE  STORE... edwin.duran@aaaa.com        {nereo.sanchez@bbbb.com}         Alguien recibe este mensaje      
    TRANSFER ROUTING  edwin.duran@aaaa.com        {nereo.sanchez@bbbb.com}         Alguien recibe este mensaje      
    RECEIVE  SMTP     edwin.duran@aaaa.com        {nereo.sanchez@bbbb.com}         Alguien recibe este mensaje      
    FAIL     ROUTING  edwin.duran@aaaa.com        {nereo.sanchez@bbbb.com}         Alguien recibe este mensaje      
    SEND     SMTP     edwin.duran@aaaa.com        {nereo.sanchez@bbbb.com}         Alguien recibe este mensaje 

    ======================================================================

    Algún otro aporte?

    Gracias,


    Edwin Duran Ospina

    lunes, 29 de septiembre de 2014 15:58
  • Hola Edwin,

    Vi el desarrollo de tu post y me gustaria comentarte de algunas ideas que me vienen a la mente.

    1.- Habilitar un registro avanzado de eventos para el servicio de transporte.

    Desde la consola grafica es mas amigable, lo haces desde Sever Configuration>Hub Transport>Servidor X (click derecho sobre ese server)>Manage diagnostic logging properties)

    Desde el Shell, utiliza Get-EventLogLevel y Set-EventLogLevel para modificar el nivel de registro de los eventos que tienen como "Identity" este servicio de Transporte.

    2.- Saca mas detalles del evento con fuente: "Routing", utiliza el mismo comando, pero al final utiliza el FL (Format list) algo asi como: get-messagetrackinglog -messagesubject "prueba x x x" | fl

    Utliza esta liga para identificar en donde esta cayendo la comunicacion

    http://technet.microsoft.com/en-us/library/aa996349%28v=exchg.141%29.aspx

    Por el detalle mostrado arriba, esta comunicacion se queda en la etapa de "Categorizacion". Del sitio arriba mencionado, observamos este extracto:

    On the Hub Transport server, the categorizer completes the following steps:

    • Recipient resolution, which includes top-level addressing, expansion, and bifurcation

    • Routing resolution

    • Content conversion

    Additionally, mail flow rules that are defined by the organization are applied. After messages have been categorized, they're put into a delivery queue. A mailbox delivery queue delivers the message to a local mailbox by using the store driver. A remote delivery queue delivers the message to a remote recipient through a Send connector.

    Por lo que comentas y por la informacion mostrada arriba, el "categorizador" no esta logrando determinar las propiedades de este buzon, sin embargo, el uso de los eventos con nivel de registro avanzado, te ayudaran a determinar errores y posibles objetos (que esta comunicacion esta buscando) y su ubicacion.

    Espero ayude un poco.

    Saludos!

    lunes, 3 de noviembre de 2014 20:36