none
Autenticación en Exchange 2007 desde Outlook 2007 RRS feed

  • Pregunta

  • Buenos días,

    Tengo un servidor exchange 2007 sin Edge role, solo Hub Transport y he configurado una cuenta pop3 en Outlook 2007. En un comienzo sólo podía enviar y recibir correos desde mi red interna, pero una vez habiendo agregado un conector de recepción adicional y especificado la ip pública de mi sitio remoto esto quedó solucionado, pero...¿que pasa si quiero trabajar con esa cuenta pop3 desde internet (desconociendo cada ip desde la cual el usuario podría trabajar con su correo)?, la "solución" que encontré fue agregar, en vez de una ip, el rango de todas las ip's (0.0.0.0 - 255.255.255.255) al conector pero de esta manera mi servidor quedaría haciendo relay. Durante unos días he estado intentando que esta cuenta pop3 (obviamente configurada con un usuario exchange) se valide contra el servidor pero no hay caso, definitvamente no he podido, he probado casi todo tanto en la configuración del cliente como en el servidor pero cuando outlook intenta enviar aparece: SU SERVIDOR NO ADMITE NINGUNO DE LOS METODOS DE AUTENTICACION ADMITIDOS POR ESTE CLIENTE. Supongo que es posible hacer lo q quiero...o no??? he leído que una buena opción sería trabajar derechamente con Outlook anywhere y seguro que lo voy a intentar pero me gustaría salir de la duda y entender si es posible hacerlo de la forma que estoy tratando. Gracias!

     


    Patricio
    miércoles, 6 de julio de 2011 14:20

Respuestas

Todas las respuestas

  • Empieza leyendo este tutorial: http://www.msexchange.org/articles_tutorials/exchange-server-2007/mobility-client-access/using-pop3-imap4-access-exchange-2007-part1.html
    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    miércoles, 6 de julio de 2011 14:25
    Moderador
  •  Hola Marc, gracias por responder. Leí cuidadosamente el tutorial que me enviaste (incluída la segunda parte (http://www.msexchange.org/articles_tutorials/exchange-server-2007/mobility-client-access/using-pop3-imap4-access-exchange-2007-part2.html)) pero aún no logro resolver el problema. Estoy intentando la configuración para autenticación más básica y habiendo hecho algunos cambios el mensaje de error es el siguiente: 530 5.7.1 Client wan not authenticated , no entiendo porque el servidor no es capaz de validar al usuario. La infraestructura consta de 2 DC , donde cada uno posee DNS, DHCP, WINS, AD y por supuesto uno de ellos Exchange 2007 SP3 (v 8.3). Los servicios POP3 e IMAP4 estan arriba (automatico) y los dos conectores de recepción por defecto, Default y Client poseen la misma configuración en los siguientes tabs:

    Authentication tab:

    - Transport Layer Security

    - Basic authentication

    - Exchange server authentication

    -Integrated windows authentication

    Permission groups tab:

    - Exchange users

    Por otro lado, la configuración del cliente Outlook 2007 SP2:

    Tab Servidor de Salida:

    - Mi servidor de salida (SMTP) requiere autenticación

       -- Usar la misma configuración que mi servidor de correo de entrada >>> Genera error: SU SERVIDOR NO ADMITE NINGUNO DE LOS METODOS DE AUTENTICACION ADMITIDOS POR ESTE CLIENTE

       -- Iniciar sesión en el servidor de correo de entrada antes de enviar correo >>> Genera error: 530 5.7.1 Client wan not authenticated

    Gracias!


    Patricio
    miércoles, 6 de julio de 2011 18:10
  • Seguramente sea porque no esté habilitado un certificado válido para POP. Dentro de tu propia organización ese servicio lleva un certificado autofirmado, pero para manejar correos fuera de tu organización necesitas que el certificado este creado en una CA interna o externa, pero no autofirmado.

    Mira aqui para más información sobre certificados:

    http://technet.microsoft.com/es-es/library/bb851505%28EXCHG.80%29.aspx#WhenCAWhenSelf

    Saludos

    jueves, 7 de julio de 2011 11:48
  •  Hola, les cuento que el problema está resuelto, es decir, siempre lo estuvo así que mis dusculpas... Estas pruebas las estoy realizando desde la LAN de mi trabajo, lugar donde reside el servidor Exchange y todos los clientes que salen a internet a través de un enlace dedicado (puerta de enlace 192.168.122.1, pero además en mi red existe otra conexión hacia internet de tipo ADLS para otros fines que va a parar a un pc que hace de cortafuegos habilitado con dos tarjetas de red, la tarjeta de red que mira hacia adentro tiene la puerta 192.168.122.2 (todo esto dentro de la misma dirección de red 192.168.122.x (es una larga historia)) entonces algunas veces suelo hacer pruebas simulando una ubicación externa tan solo cambiando la puerta de enlace (de la 122.1 a la 122.2) ya que efectivamente las ip's públicas asociadas a cada uno de estos enlaces son distintas. Justamente esto estaba haciendo para realizar pruebas de correo 'supuestamente' desde internet, pero al parecer el hecho de cambiar la puerta de enlace no garantiza una conexión externa y totalmente independiente a la red donde se encuentra Exchange. Anoche hice pruebas desde conexiones realmente remotas y el usuario exchange de prueba se pudo autenticar correctamente haciendo uso de distintos clientes de correo. El enlace que me envió Marc es suficiente para poder realizar lo que necesitaba (http://www.msexchange.org/articles_tutorials/exchange-server-2007/mobility-client-access/using-pop3-imap4-access-exchange-2007-part1.html). Por último, el comentario de Victor vendría a complementar la seguridad de la conexión.

    Gracias a ambos!

     


    Patricio


    jueves, 7 de julio de 2011 17:35
  • Gracias por el feed-back :)
    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    viernes, 8 de julio de 2011 8:28
    Moderador
  •  Hola, les cuento que el problema está resuelto, es decir, siempre lo estuvo así que mis dusculpas... Estas pruebas las estoy realizando desde la LAN de mi trabajo, lugar donde reside el servidor Exchange y todos los clientes que salen a internet a través de un enlace dedicado (puerta de enlace 192.168.122.1, pero además en mi red existe otra conexión hacia internet de tipo ADLS para otros fines que va a parar a un pc que hace de cortafuegos habilitado con dos tarjetas de red, la tarjeta de red que mira hacia adentro tiene la puerta 192.168.122.2 (todo esto dentro de la misma dirección de red 192.168.122.x (es una larga historia)) entonces algunas veces suelo hacer pruebas simulando una ubicación externa tan solo cambiando la puerta de enlace (de la 122.1 a la 122.2) ya que efectivamente las ip's públicas asociadas a cada uno de estos enlaces son distintas. Justamente esto estaba haciendo para realizar pruebas de correo 'supuestamente' desde internet, pero al parecer el hecho de cambiar la puerta de enlace no garantiza una conexión externa y totalmente independiente a la red donde se encuentra Exchange. Anoche hice pruebas desde conexiones realmente remotas y el usuario exchange de prueba se pudo autenticar correctamente haciendo uso de distintos clientes de correo. El enlace que me envió Marc es suficiente para poder realizar lo que necesitaba (http://www.msexchange.org/articles_tutorials/exchange-server-2007/mobility-client-access/using-pop3-imap4-access-exchange-2007-part1.html). Por último, el comentario de Victor vendría a complementar la seguridad de la conexión.

    Gracias a ambos!

     


    Patricio


    Hola a todos, yo intento realizar la configuración que planteó Patricio, pero utilizando Outlook 2010, logro validarme en el servidor de correo entrante pero en el saliente me muestra: 530 5.7.1 Client was not authenticated. En las propiedades del conector de recepción en la pestaña autenticación tengo marcadas  Seguridad de la capa de transporte (TLS) y Autenticación básica; en la pestaña Grupos de Permisos solo he marcado Usuarios de Exchange.

    Tienen idea de como debo configurar el cliente (Outlook 2010) ya que he intentado tods las combinaciones posibles y sigue sin funcionar o si hace falta agregar algo en el servidor.

    Gracias anticipadas.

    sábado, 12 de mayo de 2012 18:21