none
formula calcular dia habil anterior a dia de hoy RRS feed

  • Pregunta

  • Buenos días compañeros.

    Necesito una función Excel que me de la fecha del día hábil inmediatamente anterior al día de hoy teniendo en cuenta sabados, domingos, fiestas locales y nacionales.

    He realizado la siguiente formula que busca los festivos en otra hoja del mismo libro, pero falla cuando tengo dos días de fiesta seguidos.

    La formula es

    =SI(ESERROR(BUSCARV(SI(DIASEM(HOY())=2;HOY()-3;HOY()-1);fiestas!$B$1:$B$14;1;FALSO));SI(DIASEM(HOY())=2;HOY()-3;HOY()-1);SI(DIASEM(HOY())=2;SI(ESERROR(BUSCARV(HOY()-4;fiestas!$B$1:$B$14;1;FALSO));HOY()-4;HOY()-5);SI(ESERROR(BUSCARV(HOY()-2;fiestas!$B$1:$B$14;1;FALSO));HOY()-2;HOY()-3)))

    Saludos y gracias por vuestra ayuda

    jueves, 25 de julio de 2013 9:26

Respuestas

  • Hola Rafa, es mucho más sencillo. Si tienes la fecha en A2 y los festivos en un rango con nombre "festivos", la fórmula sería:

    =DIA.LAB(A2;-1;festivos)

    y si se trata del día anterior a hoy:

    =DIA.LAB(HOY();-1;festivos)

    Saludos,

    Xavier

    • Marcado como respuesta rafa_c jueves, 25 de julio de 2013 18:17
    jueves, 25 de julio de 2013 13:22

Todas las respuestas