none
localhost en construccion IIS 2003 y problemas para correr paginas asp.net sobre el server RRS feed

  • Pregunta

  • Hola tengo un problema con la configuracion de IIS 6.0 sobre windows server 2003 R2

    Lo primero que me pasa es que cuando intento ingresar a http://localhost, internet explorer muestra un error, diciendo que la pagina esta en construccion, que verifique la opcion de habilitar o deshabilitar contenido dinamico, yo estuve revisando algunos comentarios y hasta donde vi, el problema es que tengo que habiliar algun .dll o servicio para que me pueda mostrar el iisstart pero no dicen cual, y por lo que he visto no se aconseja habilitar todas las funciones desconocidas.

    Por otro lado, estoy trantando de correr mi pagina web asp pero apenas hago el ingreso de usuario y contraseña, la pagina se cierra automaticamente,  cuando estaba haciendo mi aplicacion y sus pruebas, lo hice sobre windows xp y monte el iss, y todo funcionaba bien, ahora que trato de instalarlo en server 2003 R2 me causa estos dos problemas, la verdad yo soy programador de escritorio y apenas estoy probando con ambiente web, por eso no se mucho sobre opciones y configuracion de IIS

    Les agradezco mucho su ayuda.

    miércoles, 31 de marzo de 2010 13:48

Todas las respuestas

  • Si tu página es sólo asp:

    Dentro del site, pulsa en Propiedades y accede a la pestaña Home Directory-> Configuration y aquí accedes a la pestaña Mappings.

    Comprueba que tienes la extensión asp con estos valores:

    Para el ASP

    C:\WINDOWS\system32\inetsrv\asp.dll  GET,HEAD,POST,TRACE

    También comprueba que exista el fichero asp.dll en el servidor.

    Con esto habilitas el uso de código asp en tu página, si no lo tienes.

    lunes, 12 de abril de 2010 16:45
  • Si men, ya comprobe lo que dices pero sigue igual, no conoces alguna forma de hacer un trace para saber en que punto estalla la aplicacion y se cierra?? obviamente por medio del server, porque como decia, estas pruebas ya las hice sobre mi maquina XP y no presenta ningun problema.
    lunes, 12 de abril de 2010 21:42
  • Revisa el visor de eventos cuando te logas en la página y te da el error. También revisa el log del IIS por si te da algo más de información. La verdad que hace falta algo más de información para ver dónde está el problema concreto.

    Windows Brown Resolver Soluciones diarias a los problemas que nos plantea Microsoft http://www.eltate.net
    lunes, 12 de abril de 2010 23:57