none
Problemas inicio de sesion en dominio RRS feed

  • Pregunta

  • Buenos dias

    Tengo un problema que empieza a dar quebraderos de cabeza, os cuento:

    He heredado en un cliente una infraestructura de dominio 2003. Consta de 2 sites interconectados, en el primero (Site A) de ellos tengo dos dcs 2003 de los cuales unos de ellos posee los 5 roles FSMO (dc1). Ambos dcs son catalogo global. Por otro lado en el otro site (Site B) unicamente hay instalado un dc 2003 que a su vez es GC. Bueno la cuestion es la siguiente: Cuando el dc 1 del site A se cae por cualquier razon el inicio de sesion lo intenta dar el dc del site B. Teniendo en cuenta que en el site 1 los dos dc son catalogos globales deberia de dar el inicio de sesion el dc2 del site A, no?

    EL dns, funciona correctamente. he comprobado que el DHCP en el site A del dc 1 tiene diferentes ambitos creados funcionando correctamente pero en cambio el dc 2 posee la misma configuracion de ambitos en el DHCP pero no esta autorizada. No se si esto puede ser un problema en cuanto al inicio de sesion. La configuracion de la concesion de las direcciones ip es de una semana.

    Bueno este es mi pequeño problema, confio en que alguien pueda arrojarme luz al final del tunel.

    Gracias por adelantado, un saludo.

    Javi.

     

     

    jueves, 18 de noviembre de 2010 8:27

Respuestas

  • antes de nada, verifica que las subredes de cada sitio estén bien asociadas asu site; después, verifica que clientes y servidores reconocen el Site al que pertenecen (con nltest /dsgetsite)

    En los DCs, verificar con un nltest /dcgetsitecov que reconozcan también bien su cobertura de sites

    después, en el DNS, debes revisar los registros SRV de los DCs que estén bien publicados en donde corresponda:

    How DNS Support for Active Directory Works

    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    • Propuesto como respuesta Ismael Borche lunes, 29 de noviembre de 2010 14:01
    • Marcado como respuesta Ismael Borche miércoles, 1 de diciembre de 2010 14:50
    jueves, 18 de noviembre de 2010 9:13

Todas las respuestas

  • antes de nada, verifica que las subredes de cada sitio estén bien asociadas asu site; después, verifica que clientes y servidores reconocen el Site al que pertenecen (con nltest /dsgetsite)

    En los DCs, verificar con un nltest /dcgetsitecov que reconozcan también bien su cobertura de sites

    después, en el DNS, debes revisar los registros SRV de los DCs que estén bien publicados en donde corresponda:

    How DNS Support for Active Directory Works

    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    • Propuesto como respuesta Ismael Borche lunes, 29 de noviembre de 2010 14:01
    • Marcado como respuesta Ismael Borche miércoles, 1 de diciembre de 2010 14:50
    jueves, 18 de noviembre de 2010 9:13
  • Gracias por tu respuesta.

    No puedo esjecutar el comando nltest /dsgetsitecov en el dc del sitio B me dice que el comando nltest no esta reconocido.

    El resultado del comando nltest /dsgetsitecov en el site A es el siguiente Site B y debajo Site A, importa el orden para el inicio de sesion?

    En cuanto al dns en el site A esta correcto pero en el site B no hay ninguna entrada que referencie al site A.

     

    jueves, 18 de noviembre de 2010 10:08
  • Instala lassupport Tools en el DC que o lo reconoce.

    el DC que pertenece a un Site sólo debe responder con su Site por defecto.

    Revisa el resto de cosas que te he comentado y ponnos el resultado


    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    jueves, 18 de noviembre de 2010 10:21
  • A parte, aunque antiguo, buen documento también:

    Finding a Domain Controller in the Closest Site

    http://technet.microsoft.com/en-us/library/cc978016.aspx


    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    jueves, 18 de noviembre de 2010 10:37
  • Javier, disculpa que me entrometa :-)
    Me parece que Javi2 seguramente no tiene creados los Sites y Subnets, y el problema puede venir por ese lado

     

     


    Guillermo Delprato - Buenos Aires, Argentina
    MVP-MCT-MCSE-MCSA MCITP: Enterprise/Server Administrator MCTS: Active Directory/Network/Applications Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.
    jueves, 18 de noviembre de 2010 11:13
    Moderador
  • Coñas, sorry, no había entendido eso! En ese caso, está claro que es lo primero que hay que hacer, ejejejeje
    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    jueves, 18 de noviembre de 2010 11:51
  • Si, tengo creados los dos sites (A y B) y las subredes (10.X.X.X para Site A y 172.X.X.X para Site B) estan configuradas en ambos. Pero en la DefaulIpSiteLink estan incluidos los dos Sites (A y B).
    jueves, 18 de noviembre de 2010 12:14
  • En ese caso, sigue mirando los enlaces que te puse y las pruebas que te pedí; los DCs sólo deben tener sus SRV registrados en el DNS en los sites a los que pertenezcan
    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    jueves, 18 de noviembre de 2010 12:57
  • Es correcto entonces, sólo falta un par de detalles para verificar, ya que no veo la pantalla

    ¿Cada DC está "colgando" de su correspondiente Site?

    ¿Los clientes tienen configurado para usar como DNS preferido a uno de su Site?

     


    Guillermo Delprato - Buenos Aires, Argentina
    MVP-MCT-MCSE-MCSA MCITP: Enterprise/Server Administrator MCTS: Active Directory/Network/Applications Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.
    jueves, 18 de noviembre de 2010 13:17
    Moderador
  •  

    Cada dc esta colgando de su correspondiente Site. La configuracion del dns en el puesto cliente ahora mismo no te la puedo dercir porque ahora mismo no tengo acceso a ninguna maquina.

    El hecho que el DHCP del DC2 del Site 1 la zona no esta autoriza, puede afectar de alguna forma?

    jueves, 18 de noviembre de 2010 15:13
  • No, eso parece una mala "ñapa" para intentar hacer un DHCP en alta disponibilidad o que se haya migrado de uno a otro; hasta que no revises los datos que te he comentado y que mires en el DNS las entradas SRV no podremos avanzar
    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    jueves, 18 de noviembre de 2010 16:41
  • Javi2, si el DHCP no está autorizado no otorga configuración IP a los que se lo soliciten.

    Te dejo para que sigas con Javier, porque sinó vamos a mezclar todo :-)

     


    Guillermo Delprato - Buenos Aires, Argentina
    MVP-MCT-MCSE-MCSA MCITP: Enterprise/Server Administrator MCTS: Active Directory/Network/Applications Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.
    jueves, 18 de noviembre de 2010 17:11
    Moderador
  • Perdonar por la espera. He estado revisando los registros SRV en el dns de los servidores y estan registrados de manera correcta. Por otro lado los equipos del site A apuntan a las ips correspondientes de dicho Site.

    He encontrado que no puedo ejecutar el comando nltest /dsgetsite en ninguno de los pcs clientes.

    viernes, 19 de noviembre de 2010 10:55
  • Instálales las support tools en ellos para poder ejecutarlo
    -------- Salu2!! Javier Inglés - Microsoft Active Professional 2010
    viernes, 19 de noviembre de 2010 11:03
  • Hola Javi2

    Como están los procedimientos que dice Javier?

    Saludos 


    Ismael Borche
    martes, 23 de noviembre de 2010 14:25
  • Buenas tardes

    Me mantengo a la espera que me faciliten la informacion de un pc win xp. Intuyo que el resultado sea igual que en el dc que el comando nltest /dsgetsite de como resultado los dos sites en lugar de uno solo.

    martes, 23 de noviembre de 2010 15:07
  • Hola Javi2

    No te olvides de poner los resultados acá.

    Saludos


    Ismael Borche
    viernes, 26 de noviembre de 2010 18:36