none
SharePoint 2010 + RBS.msi no crea las tablas "mssqlrbs" en la BD Contenidos RRS feed

  • Pregunta

  • Instalación sobre W2K8 SP2 + SQL 2K8 R2 CTP Noviembre + SPS2010 Beta.

    Instancia SQL por defecto MSSQLSERVER y base de datos de contenido por defecto WSS_Content.

    Siguiendo paso a paso las indicaciones para la habilitación, instalación y uso de la capacidad de Remote Blob Storage, que vienen en la documentación:

    http://technet.microsoft.com/es-es/library/ee748631(office.14).aspx

    Una vez terminada la instalación del componente RBS.msi, en el fichero de resultados, dice que la instalación es correcta, aunque muestra la línea de error:



    En la base de datos de contenido no se han creado las tablas necesarias "mssqlrbs" y al ejecutar en la Shell de SharePoint el comando:

    $rbss.Installed()

    Devuelve "False"

    No he encontrado un "walkarround" o algo que me permita implementar las tablas y simular la instalación que lleva a cabo el .msi facilitado en el Feature Pack de Microsoft® SQL Server® 2008 R2 de Community Technology Preview (CTP) de noviembre

    ¿Alguien se ha encontrado con ésta incidencia?
    Muchas gracias por la ayuda.

    Eva
    sábado, 27 de febrero de 2010 13:05

Respuestas

Todas las respuestas

  • Perdón, la única línea de error que encuentro dice:

    ... Executing op: ActionStart(Name=FixFilestreamStoreConfig,,)
    Información 2769. El instalador ha encontrado un error inesperado. El código de error es 2769. La acción personalizada CreateFilesNoUI no ha cerrado 21 identificadores MSIHANDLE.
    ... Executing op: CustomActionSchedule(Action=FixFilestreamStoreConfig, ActionType=3070, Source=BinaryData, Target=RepairProvider, CustomActionData=filestream;C:\Program Files\Microsoft SQL Remote Blob Storage10.50\Provider Libraries\Filestream Provider\FilestreamProviderConfiguration.xml)
    ...

    sábado, 27 de febrero de 2010 13:18
  • Hola Eva,

    Como va la vida?

    A mi tb me pasó lo mismo. Encontré este post en el que te dice que has de utilizar otro descargable

    http://social.technet.microsoft.com/Forums/en/sharepoint2010setup/thread/f93a677b-9434-4334-9d08-359127bdf1fe

    con eso consigo que  el $rbss.Installed()  de true;

    pero la siguiente linea me falla $rbss.Enable()

    Sea como sea, yo estoy con la versión RC de SharePoint 2010.

    RECTIFICO: Ya lo consegui! el fichero de log debe ser de mas de un MB en todos los servidores.

    Si ves que falla.. desinstalalo y vuelvelo a instalar, eso en cada server.

    Saludos

    Ramon Torras
    Blog: http://www.ibetania.es

     


    RTP
    • Propuesto como respuesta Ramon Torras lunes, 12 de abril de 2010 15:54
    • Marcado como respuesta Uriel Almendra miércoles, 3 de abril de 2013 22:08
    lunes, 12 de abril de 2010 12:05