none
Migrar Server 2008 R2 a otro 2008 R2 RRS feed

  • Pregunta

  • Hola.

    Me gustaría saber si existe la posibilidad de migrar todas las configuraciones, datos y programas de un server 2008 R2 a otro Server 2008 R2.

    Resulta que he montado una máquina virtual y por casualidades de la vida se ha fastidiado el disco duro donde estaba almacenado el VHD de dicha máquina. Después de hacer virguerías he conseguido recuperar el fichero VHD, pero al restaurarlo en otra máquina virtual, tengo errores de sistema operativo, entre los cuales figuran problemas con la tarjeta de red virtual, la cual no me deja instalar. El servidor físico tiene varias máquinas virtuales corriendo sin problemas, así que he llegado a la conclusión de que se trata del sistema operativo de esa máquina en concreto. Si pudiera migrar los datos (sobre todo programas instalados, usuarios (no tenía instalado Active Directory ni se trataba de un DC) a otro server 2008 limpio...

    También he leído que puedo reparar el sistema operativo con DaRT (MDOP) pero no encuentro como descargarlo. Y ya veis, aparentemente solo tiene un "ligero" problema con la tarjeta de red virtual...

    Gracias.

    miércoles, 27 de julio de 2011 23:24

Respuestas

Todas las respuestas

  • Es muy típico que la tarjeta de red virtual no funcione cuando movemos una máquina virtual de un servidor a otro. Lo que tienes que hacer es eliminarla completamente desde la configuración de la máquina virtual, añades una nueva y la asocias a una conexión de red física del servidor.

    Verás que puedes añadir dos tipos de tarjeta de red virtual: una que te dice que es Legacy (o heredada) y otra normal. La Legacy es muy simple, y sirve normalmente para instalaciones desde cero a través de la red, pues la tarjeta de red normal solo funciona una vez se le instalan los drivers que proporcionan los servicios de integración. También usarás la Legacy si por alguna razón necesitas acceder a la red antes de poder instalar estos servicios de integración de Hyper-V, o si, como es tu caso, parece ser que no te reconoce correctamente el dispositivo.

    Lo primero que yo haría es actualizar en la VM los servicios de integración, y tras reiniciar, comprobar si ahora te reconoce bien la tarjeta de red virtual. En caso contrario, apaga la VM, edita su configuración y añade un adaptador de red heredado (Legacy). Arranca la máquina y la debería reconocer sin problemas.

    Por cierto, el MDOP no se puede descargar de forma gratuita, ya que es un software de pago, que puedes adquirir por separado o bien como parte de una subscripción MSDN o Technet.

     


    Saludos
    José Antonio Quílez
    Mi Blog
    • Propuesto como respuesta Ismael Borche viernes, 29 de julio de 2011 15:00
    • Votado como útil Ismael Borche martes, 2 de agosto de 2011 15:57
    jueves, 28 de julio de 2011 19:10
    Moderador
  • Hola José Antonio.

    Gracias por responder.

    Eso ya lo he probado. Fue lo primero que probé. Y el error persiste tanto con la normal como con la Legacy. Ambas me salen con admiración en el administrador de dispositivos. Y da igual que actualices los servicios de integración. Por eso creo que se trata de un fallo del sistema operativo y se me había ocurrido el tema de la migración, ya que tampoco se me ocurre como reparar el sistema operatavo (igual que en xp o W7).

     

    Un saludo.

    viernes, 29 de julio de 2011 19:46
  • Para migrar un servidor a otro tienes que instalar las herramientas de migración de Server 2008 R2. En el siguiente enlace tienes el procedimiento (al estar implicados solo servidores 2008 R2 es más sencillo, ya que solo tienes que agregar la característica)

    http://technet.microsoft.com/es-es/library/dd379545(WS.10).aspx

     

    Guía de migración de usuarios locales

    http://technet.microsoft.com/es-es/library/dd379531(WS.10).aspx

     


    Saludos
    José Antonio Quílez
    Mi Blog
    • Propuesto como respuesta Pep lopezModerator miércoles, 3 de agosto de 2011 4:06
    • Marcado como respuesta MurrayLCD miércoles, 3 de agosto de 2011 8:30
    lunes, 1 de agosto de 2011 19:17
    Moderador
  • Hola.

    Gracias, José Antonio por la respuesta.

    Probaré el asunto en cuanto vuelva de vacaciones.

    Al final, como no tenía tiempo, ya que el cliente necesitaba trabajar, he traspasado datos de la máquina virtual rescatada a otra nueva y ya está operativo.

    Muchas gracias.

    miércoles, 3 de agosto de 2011 8:30