none
Como utilizar RemoteApp desde internet RRS feed

  • Pregunta

  • Buenas,

    Tengo la siguiente infraestructura con un dominio privado dominio.local y un dominio publico dominio.com:

    Servidor Servicios.dominio.local: TS, Ts web, exchange.

    Servidor Dc.dominio.local: AD,dhcp, dns privado y CA privada

    Servidor Externo.dominio.local: RRAs, CA publica, Puerta de enlace de TS y dns publico

     

    El terminal y la puerta de enlace funciona perfectamente en la red interna e incluso funciona bien desde fuera.

    Registro mi dominio.com, configuro todo perfecto y lo único que no funciona es remoteApp.

    Cuando he cambiado los nombres de los servidores en la configuración de terminal y ts gateway. Accedo a ts web via http://ts.dominio.com/ts pero cuando intento ejecutar una aplicación me pide usuario y contraseña. Hay es cuando no funciona ya que ni poniendo usuario@dominio.com y pass me dice que no es correcto.

    Parece que no es capaz de distiguir entre el dominio publico y privado o que no lo asocia todo al privado.

    Ah porsupuesto tengo el certificado raiz instalado tanto de la ca-raiz privada como la publica

    ¿Alguien pueda aportar ideas de como hacerlo?

    martes, 14 de diciembre de 2010 15:14

Respuestas

  • Ante la falta de ideas me puse a cacharrear y lo he echo funcionar aunque no del todo a mi gusto.

     

    En el servidor de puerta de enlace pongo el certificado ssl del ts gateway a nombre de externo.dominio.com y por supuesto su respectivo registro A en el dns publico.

     

    En el servidor de terminal services pongo como nombre servicios.domino.local

     

    Asi a la hora de autenticarse ya detecta que estamos dentro del dominio .local y solo tenemos que meter el nombre de usuario y contraseña.

    Lo que no me gusta es que en la pantalla de login se muestre el nombre de puerta de enlace xxx.dominio.com y el nombre de terminal interno xxx.dominio.local.

    Pero bueno......

    miércoles, 22 de diciembre de 2010 16:09

Todas las respuestas

  • ¿usuario@dominio.COM? ¿Has probado con usuario@dominio.LOCAL?

    Un saludo

    Fernando Reyes [MS MVP]
    MCSA 2000/2003
    MCSE 2000/2003
    MCITP EnterpriseAdministrator
    Web: http://freyes.svetlian.com
    Blog: http://urpiano.wordpress.com
    RSS: http://urpiano.wordpress.com/feed/
    freyes.champú@champú.mvps.org
    (Aclárate la cabeza si quieres escribirme)
    miércoles, 15 de diciembre de 2010 8:07
    Moderador
  • Esa solución no valdría porque no es viable ya que el dominio .local no tiene por que existir para el usuario remoto.

    El tema sería poder igual que el ftp o en el owa de exchange que se le fijase el dominio predeterminado en la config del Terminal y que ellos solo tuviesen que poner el nombre de usuario, sin @ ni nada.

     

     

    miércoles, 15 de diciembre de 2010 22:10
  • El usuario pertenece al dominio local, por más que para resolución de internet utilices dominio.com; por tanto su UPN es usuario@dominio.com, por más que para acceder a la página en cuestión ponga servidor.dominio.com. Puedes, no obstante, hacer que el usuario tenga por UPN usuario@dominio.com, si creas el sufijo de dominio dominio.com y le asignas este sufijo al usuario en la pestaña Cuenta de sus propiedades:


    Un saludo

    Fernando Reyes [MS MVP]
    MCSA 2000/2003
    MCSE 2000/2003
    MCITP EnterpriseAdministrator
    Web: http://freyes.svetlian.com
    Blog: http://urpiano.wordpress.com
    RSS: http://urpiano.wordpress.com/feed/
    freyes.champú@champú.mvps.org
    (Aclárate la cabeza si quieres escribirme)
    jueves, 16 de diciembre de 2010 7:44
    Moderador
  • Lo del sufijo es una gran idea pero no funciona.

     

    El problema creo que viene por el tema de los dominios externo e interno. El equipo donde esta el remoteapp es servicios.dom.local y el que tiene el ts gateway es externo.dom.local.

    En el dns externo quiero que se llamen ts.dom.com y externo.dom.com y cuando intento conectar me dice que no puede localizar el servidor de puerta de enlace y si que esta funcionando porque dentro de la Lan si que funciona el Ts Gateway.

    La verdad que con lo del dominio externo e interno no se como hacerlo para que funcione.

    lunes, 20 de diciembre de 2010 15:27
  • Ante la falta de ideas me puse a cacharrear y lo he echo funcionar aunque no del todo a mi gusto.

     

    En el servidor de puerta de enlace pongo el certificado ssl del ts gateway a nombre de externo.dominio.com y por supuesto su respectivo registro A en el dns publico.

     

    En el servidor de terminal services pongo como nombre servicios.domino.local

     

    Asi a la hora de autenticarse ya detecta que estamos dentro del dominio .local y solo tenemos que meter el nombre de usuario y contraseña.

    Lo que no me gusta es que en la pantalla de login se muestre el nombre de puerta de enlace xxx.dominio.com y el nombre de terminal interno xxx.dominio.local.

    Pero bueno......

    miércoles, 22 de diciembre de 2010 16:09
  • Hola Albernieto.

     

    Creo que tenemos el mismo problema que tu pero no entiendo cómo lo has solucionado.

     

    ¿A qué te refieres con "En el servidor de terminal services pongo como nombre servicios.domino.local"?

     

    Nosotros necesitamos pedir un certificado a nuestra CA (2003 server) para autenticar nuestro ts.dominio.com, aunque después el dominio interno es dominio.local.

     

    Muchas gracias.

    jueves, 7 de abril de 2011 16:22