none
Pantalla negra y cursor del ratón RRS feed

  • Pregunta

  • Tengo un Windows Server 2008 R2. Se estropeó el disco duro donde estaba instalado el Windows. Para sustituirlo realizé una copia de seguridad de Windows usando la opción "Imagen del sistema". Compré un disco nuevo, lo instalé en el ordenador y restauré la copia de seguridad de Windows que había hecho anteriormente. El problema es que ahora inicio el Windows restaurado y se queda en una pantalla en negro con el cursor del ratón y nada más. No responde de ninguna manera ni muestra otro mensaje. Si lo dejo en ese estado durante un largo tiempo (horas) termina mostrando una pantalla azul con el mensaje "Directory Services could not start...". El modo seguro no funciona ni la última configuración buena conocida ni reparar el inicio de Windows. Lo único que consigue iniciar Windows es entrar en "Modo de restauración de servicios de directorio" con F8. Espero que no sea un tema de activación de Windows.
    martes, 12 de junio de 2012 15:58

Respuestas

  • Gracias a todos por vuestra ayuda. Ya he encontrado el problema. Lo expongo aquí por si a alguien más le ocurre lo mismo:

    El problema estaba en el disco duro que compré nuevo. Al parecer es demasiado moderno y guarda la información en sectores de 4KB o algo así (Microsoft les llama "discos de formato avanzado"). Afectaba a la imagen del sistema que estaba recuperando en que el Active Directory no se podía cargar correctamente (de ahí la pantalla negra con el cursor) porque el motor Jet provocaba un error al leer la base de datos ntds.dit del Active Directory según dice porque con ese tamaño del cluster del disco Jet no podía trabajar (error 583 - SectorSizeNotSupported). Al no poder leer la base de datos de Active Directory, el servidor sólo podía arrancar con el Modo de recuperación de Active Directory precisamente porque en este modo el Active Directory está deshabilitado. Gracias al comando esentutl lo pude averiguar.

    Solución: buscar un disco duro mas antiguo y recuperar la imagen del sistema en ese disco duro.

    miércoles, 13 de junio de 2012 17:10

Todas las respuestas

  • ¿Primero el problema con el disco y luego la imagen del sistema?

    ¿O primero la imagen del sistema y luego el problema con el disco?

    ¿Qué antigüedad tiene esa imagen del sistema?

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP - MCT - MCSE - MCSA
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    martes, 12 de junio de 2012 18:31
    Moderador
  • Todo surgió porque los usuarios del servidor comenzaron a decirme que el ordenador se "colgaba" mucho e iba muy lento. Entonces me puse a mirar y en la información SMART del disco se veía que habían errores. Las copias de seguridad que tengo que son desde el 02/06/2012 hasta el 07/06/2012 la mas reciente. Eran incrementales y se ejecutaban todos los días dos veces. En el registro de eventos de la copia de seguridad se veía que unos días finalizaban bien y otros días no finalizaban bien por un error de E/S en el disco. Desde que observé todos estos síntomas compré el disco nuevo para hacer la sustitución que hice. Las imágenes del sistema que tengo son recientes y ya el disco contenía errores, pero aún con ellos los usuarios podían trabajar con el ordenador. Ahora es que el Windows si ni quiera arranca. Pantalla negra con cursor.
    martes, 12 de junio de 2012 18:40
  • Las imágenes de sistema nunca son incrementales, siempre son "full", y además no están disponibles en sistemas servidor

    ¿Te referirás a "Estado del sistema"? que es otra cosa totalmente diferente, y a partir de la cual no es posible normalmente recuperar un servidor, salvo que además se marcara la opción "Reconstrucción completa"

    Pero de todas formas, por lo que dices, es evidente que esa copia de seguridad está hecha de un sistema ya dañando, y que puede tener errores adicionales durante la copia de seguridad, por lo que no creo que puedas recuperarlo desde esa copia

    Las copias de seguridad hay que hacerlas *antes* que el sistema muestre problemas, y además es fundamental que periódicamente se prueben para ver que todo funcione como se espera

    Si no tienes una copia "Reconstrucción completa" de antes de los daños entiendo que no lo podrás recuperar :(

    Salvo por supuesto que si existiera un segundo controlador de dominio, por lo menos salvarías a usuarios, grupos y máquinas

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP - MCT - MCSE - MCSA
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    martes, 12 de junio de 2012 19:17
    Moderador
  • Creo que era una imagen del sistema con reconstrucción completa como dices. De hecho, cuando compré el disco duro y lo instalé, el programa de instalación de Windows me particionó el disco nuevo tal y como estaba el viejo, incluso con las particiones para un Linux que tenía por allí instalado y demás. La única cuestión que me tiene realmente desorientado es por qué si la imagen del sistema es "idéntica" al disco duro del cual se hace, cuando la vuelco en el disco duro nuevo no funciona el Windows exactamente igual que el anterior y muestra la pantalla negra... ¿Acaso estas imágenes del sistema no se creen correctamente aunque Windows diga que sí? Yo este método de recuperar el servidor con una imagen del sistema ya lo había usado un vez anterior y funcionó a la perfección. Claro que aquella vez no había errores en el disco. Se me ocurre una cosa. ¿Podría ser que la copia de seguridad se ejecutara y terminara como correcta pero algunos archivos que se encontraban en los sectores defectuosos del disco los copiara corruptos? ¿Y que justo esos archivos sean del funcionamiento del Active Directory? (lo digo porque si inicio en Modo de restauración de servicios de directorio inicia bien...)
    martes, 12 de junio de 2012 20:01
  • Es una gran diferencia si está o no marcada la opción "reconstrucción completa", ya que eso es lo que permite recuperar en un disco nuevo

    Además para recuperar de un Backup no hace falta instalar. Se arranca el equipo con el DVD y se elige la opción "reparar" que permite hacer el Restore

    Además un Backup, no es una imagen. Si no se incluye "reconstrucción completa" hay drivers que no están, y otros archivos, por lo tanto no es *idéntica*

    Y menos si había algún GRUB o lo que sea de Linux

    Y respecto a lo último que comentas, es muy probable que si levanta en "modo de restauración de AD" sean esos archivos justamente los corruptos

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP - MCT - MCSE - MCSA
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    miércoles, 13 de junio de 2012 16:37
    Moderador
  • Gracias a todos por vuestra ayuda. Ya he encontrado el problema. Lo expongo aquí por si a alguien más le ocurre lo mismo:

    El problema estaba en el disco duro que compré nuevo. Al parecer es demasiado moderno y guarda la información en sectores de 4KB o algo así (Microsoft les llama "discos de formato avanzado"). Afectaba a la imagen del sistema que estaba recuperando en que el Active Directory no se podía cargar correctamente (de ahí la pantalla negra con el cursor) porque el motor Jet provocaba un error al leer la base de datos ntds.dit del Active Directory según dice porque con ese tamaño del cluster del disco Jet no podía trabajar (error 583 - SectorSizeNotSupported). Al no poder leer la base de datos de Active Directory, el servidor sólo podía arrancar con el Modo de recuperación de Active Directory precisamente porque en este modo el Active Directory está deshabilitado. Gracias al comando esentutl lo pude averiguar.

    Solución: buscar un disco duro mas antiguo y recuperar la imagen del sistema en ese disco duro.

    miércoles, 13 de junio de 2012 17:10