none
Corporate 802.1x wont auto-connect, says "Action Needed"

    Pregunta

  • Hi all,

    I have a corporate wifi that I've setup for my company that utilizes RADIUS 802.1x "Computer based" authentication.  I have also pushed out a GPO that adds this wireless network to all endpoints and sets it as the preferred network and to automatically connect when the network is available.

    The endpoints are able to connect to the network just fine (and endpoints that are *not* part of our enterprise domain cannot, which is the correct behavior).  However, I have multiple endpoints, all Windows 10 machines, that are not connecting automatically.  When I open the list of wireless networks, it says "Action Needed" underneath the SSID for the enterprise network.  When I click on the network and hit "Connect" - a web browser opens and it connects just fine without any other prompts.

    I thought it might be that we have a web proxy that users must authenticate to, but this doesn't happen on all machines and doesn't appear to happen to any of my Windows 8.1 devices (at least not yet).

    Any idea what might be going on here?

    lunes, 4 de diciembre de 2017 16:44

Respuestas

  • For anyone curious, the 2nd reply in this post was my fix (actually fixes*):

    https://answers.microsoft.com/en-us/windows/forum/windows_7-networking/need-to-remove-notification-no-internet-access/ceffc187-4214-4624-a683-591df89921dc?auth=1

    • Marcado como respuesta adanooope jueves, 14 de diciembre de 2017 19:57
    jueves, 14 de diciembre de 2017 19:57

Todas las respuestas

  • make sure the AP's don't have an inbuilt splash screen for further auth after connection.
    lunes, 4 de diciembre de 2017 16:49
  • We've got the option to use a splash screen, but it is disabled for this SSID.
    lunes, 4 de diciembre de 2017 17:20
  • For anyone curious, the 2nd reply in this post was my fix (actually fixes*):

    https://answers.microsoft.com/en-us/windows/forum/windows_7-networking/need-to-remove-notification-no-internet-access/ceffc187-4214-4624-a683-591df89921dc?auth=1

    • Marcado como respuesta adanooope jueves, 14 de diciembre de 2017 19:57
    jueves, 14 de diciembre de 2017 19:57
  • Here's  the registry edit from the link that worked for me on Win10 1709

    1) Set the following key in the registry (as the OP did):

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet > EnableActiveProbing

     

    set to: 0

     

    • Propuesto como respuesta leo.grego martes, 14 de agosto de 2018 10:10
    jueves, 26 de abril de 2018 19:06
  • Hy anyone resolve this? i have this problem on some machines with windows 10, i really don't know what i need to change!


    leo.gregorio@hotmail.com

    miércoles, 23 de mayo de 2018 18:47
  • Hi Did you resolve yout issue?

    leo.gregorio@hotmail.com

    viernes, 10 de agosto de 2018 1:52