none
Problema certificados y nombre de host RRS feed

  • Pregunta

  • Hola buenas tardes :

    Tengo dos host que tienen instalados los siguientes roles ( los dos estan iguales) y mis clientes solo se conectan externamente  nunca interno. Los servidores estan igual configurados con los mismos roles.

    - Connection broker

    - Gateway 

    - App Web 

    - Sesion host

    Tengo configurado para que se conecten mediante un gateway ( terminal.externaldomain.com ) y configurado un una granja de servidores (rdfarm.external domain.com) . Tengo un certificado emitido por thawthe para el dominio *.externaldomain.com. os adjunto la url para que veais una captura , no me deja ponerla en el foro .

    http://www.atm2.es/soporte/captura1.png

    Todo va bien ( de hecho los clientes conectan) lo pero a veces y sin ningun patron evidente, se me intenta conectar al nombre interno del servidor rdsh1.internaldomain o rdsh2.internaldomain.com. He intentado pasar el script para renombrar el nombre del servidor pero lo que me hace es renombrarme el nombre de la granja , no del servidor. De hecho no entiendo porque como veis en la primera captura ( os pongo la url no me deja poner imagenes, ver url mas abajo) el equipo remoto es rdfarm.externaldomain.com y en la segunda ya es madprdts01.localdomain.com

    http://www.atm2.es/soporte/captura2.png

    Ademas y a relacion de esto tengo un error 0x607 de autenticacion de vez en cuando que se soluciona solo entrando desde el cliente una segunda vez ya se arregla solo. 


    Yo creo que todo esta relacionado con el problema de los certificados, pero estoy un poco perdido y ya no se que hacer .

    Agradezco vuestra colaboración

    Saludos


    lunes, 5 de noviembre de 2018 15:21

Todas las respuestas

  • Hola Lamaswsss

    Gracias por levantar tu consulta en los foros de TechNet. Con respecto a la misma, te recomiendo ingresar al siguiente enlace donde puedes encontrar una posible solución para tu problema.

    https://docs.microsoft.com/es-es/azure/app-service/app-service-web-troubleshoot-domain-ssl-certificates

    Gracias por usar los foros de TechNet.

    Juan Mondragón
     ____

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde. 

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft.  

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    lunes, 5 de noviembre de 2018 17:23
    Moderador
  • Ya habia visto ese enlace , pero no funciona

    Por cierto en el domain controller que tengo estan creados los registro dns internos a rdfarm.eadministracion.es

    martes, 6 de noviembre de 2018 7:51
  • Hola Jose Manuel Lamas

    Dando seguimiento a tu pregunta, te comparto algunos procedimientos que puedes intentar.

    1.Adquiera SSL de su preferencia.

    2.El CSR debe crearse en su servidor IIS LOCAL, como se detalla a continuación

    3.En su Administrador local de IIS 7, vaya a Certificados del servidor y elija Crear solicitud de certificado a la derecha. Aquí es donde especifica el nombre y los detalles de su dominio, incluida la intensidad del cifrado. Elija 2048 bits o más. Y RSA como el proveedor criptográfico

    4.Una vez que se crea el archivo CSR, la creación del certificado tardará de 5 a 10 minutos en completarse.

    5.Descargue el certificado como archivo .zip y guárdelo en su computadora

    6.Vuelva al Administrador de IIS 7 y seleccione Solicitud de certificado completa. Le pedirá que busque un archivo * .cer. En realidad, debes usar el . filtre y busque el archivo * .crt que estaba en su archivo .zip. Déle un nombre descriptivo como MyDomainSSL2015

    7.Ahora que se ha creado el certificado, resáltelo y elija Exportar para exportarlo a un archivo .pfx. En este punto, también le dará una contraseña al archivo exportado.

    8.Iniciar sesión en Windows Azure, vaya a Administrar el servicio en el que desea instalar el certificado, y eligen Certificados pestaña

    9.Haga clic en "Subir " en el fondo. Le pedirá que busque su archivo .pfx e ingrese la contraseña que creó

    10.Ahora que su certificado se ha cargado en Azure, debe especificar que desea que su Rol lo use. Esto se puede hacer en Visual Studio. Así que abra su proyecto de Visual Studio

    11.Haga clic derecho en su función y elija Propiedades. Vaya a la pestaña Certificados

    12.Haga clic en Agregar certificado. Se creará una nueva línea en la grilla. Asegúrese de que LocalMachine esté seleccionada para la ubicación de la tienda y CA para el nombre de la tienda.

    13.Haga clic en las elipsis en la columna Huella digital. Esto le mostrará una lista de todos sus certificados locales. Elija el que tenga el nombre descriptivo que creó anteriormente

    14.Vaya a la pestaña Puntos finales. Para su punto final HTTPS, elija el nombre del certificado SSL que acaba de agregar.

    15.Publique su papel

    Espero que te sean de utilidad.

    Gracias por usar los foros de TechNet.

    Juan Mondragón
     ____

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde. 

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft.  

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    martes, 6 de noviembre de 2018 16:15
    Moderador
  • Investingando el tema el problema lo tengo en gateway ...

    Mi problema es que los servidores tienen 2 tarjetas de red y cuando accedo a la consola de administracion del gateway veo clientes que se estan conectado al equipo destino rdfarm.externaldomain.com y otros se estan conectando a la ip de la segunda tarjeta de red del servidor

    Como puedo hacer para que solo usen una de las tarjetas de red

    miércoles, 7 de noviembre de 2018 7:49
  • Hola Jose Manuel Lamas

    Dando seguimiento a tu pregunta, para deshabilitar una tarjeta de red debes de ir a Inicio>Panel de Control> Redes e Internet>Centro de Redes y Recursos compartidos>Cambiar configuración del adaptador>Seleccionar la tarjeta de red a desactivar> Dar click derecho y pulsar "Deshabilitar".

    Espero que te sea de utilidad.

    Gracias por usar los foros de TechNet.

    Pablo Rubio
     ____

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde. 

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft.  

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.
    miércoles, 7 de noviembre de 2018 21:55
    Moderador
  • No vamos a cer si me explico , tengo dos tarjetas de red porque las necesito, una es para la lan y otra para la iscsi.

    Voy a intentar explicar algunas veces cuando me conecto los clientes se conectan a la url rdfarm.externaldomain.com y otras veces a madprdts01.local.com ... Cuando se conectan por el nombre de la granja ( rdfarm) todo va perfecto , pero cuando lo hace al madprdts01.local.com ( adjunto captura en esta url http://www.atm2.es/soporte/captura3.png) da un error de certificado ya que yo uso un certificado de wildcard para *.externaldomain.com...

    Yo quiero que todos los clientes se conecte por el nombre de la granja y no por el nombre del servidor ... El problema es que si fuerzo en el gateway la politica del RAP para que solo se conecte al nombre de la granja rdfarm (, me tira un error diciendo que el usuario no tiene permiso para la puerta de enlace y no se arregla hasta que no pongo los nombres de los servidores internos ( podeis verlo en http://www.atm2.es/soporte/captura3.png).

    Saludos 

    jueves, 8 de noviembre de 2018 7:48