none
Como hago para que mi ISA 2006 de IPs?? RRS feed

  • Pregunta

  • Acabo de montyar mi ISA server 2006 sobre un windows 2003 R2 en un equipo con 2 tarjetas de red, cuando instale el ISA me bloqueo la salida a internet y segun vi en otro post aqui mismo por dafault el ISA niega toda salida asi que vi que habia que crear una nueva regla de acceso y me funciono ala perfeccion, salgo a internet desde mi server, ahora lo que necesito mi otra tarjeta de red de la INTERNA es la que reparte el internet a todas las demas maquinas si no me equivoco, pero cuando conecto un equipo atravez de un Switch y mis equipos cliente no agarran IP y me dice q tienen conexion limitada o nula, aparte en la FICHA ESCRITORIO DIGITAL, SUPERVICION, del ISA me dice que el DHCP, ACTIVE DIRECTORY, DNS Y WEB , NO ESTAN CONFIGURADOS, como hago para configurar cada uno de ellos?? les agradeceria mucho que me ayudaran ya que no encuentro por ningun lado una solucion, de ante mano gracias
    PD si necesitan mas datos o algun screenshot lo publico
    jueves, 15 de noviembre de 2007 23:00

Respuestas

  • Que tal Cristian

    No hay que disculpar nada al contrario gracias por tomarte la molestia de responderme, pues mira ya puse en parctica lo que me comentas ahora con el ipconfig aparece esto

    Nombre del host:....kim-server
    subfijo DNS principal.....uni.kim
    tipo de nodo......hibrido
    enrutamiento IP habilitado....SI
    Proxy wins habilitado....NO
    Lista de busqueda subfijo DNS ...kim-server
                                                     El nombre de mi ISP

    Adaptador de red Externo

    DHCP habilitado...........NO
    Autoconfiguracion habilitada.......No
    Direccion IP.....192.168.1.154
    Mascara............255.255.255.0
    Puerta de enlace.....192.168.1.254
    servidor DHCP           La misma de arriba
    Servidores DNS          LA misma

    Adaptador de Red Interno

    Direccion_ IP 10.10.10.1
    DHCP HABILITADO.....NO
    Mascara.......255.255.255.0
    Puerta de enlace.....NADA



    ya con eso con eso mi server sale a internet ahora voy a checar mis maquinas
    sábado, 24 de noviembre de 2007 0:31

Todas las respuestas

  • Hola Victor:

     

    Primero que nada, no es recomendable, por temas de seguridad tener un servidor DHCP junto con ISA server. Hecha la aclaración seguimos, acá esta la serie de paso a seguir:

    1. Para comenzar tenes que instalar el DHCP en el servidor, el DHCP es parte de Windows Server 2003 y no de ISA, entonces para eso te vas a "Agregar o Quitar Programas" en el "Panel de Control", luego seleccionas "Agregar o Quitar Componentes de Windows" y en la lista que te aparece buscas "Servicios de Red" y en los detalles podes seleccionar "Servidor DHCP". Lo seleccionas y seguis los pasos, te va a pedir el disco de instalación de Windows 2003 para completar el proceso y el DHCP va a quedar instalado.

    2. Ahora tenes que configurarlo, o sea, tenes que crear un ambito (conocido como rango de direcciones) y opciones, para eso te paso la siguiente nota:

    Instalar un servidor DHCP

    http://www.microsoft.com/technet/prodtechnol/windowsserver2003/es/library/ServerHelp/9aacf547-784a-4aa4-ba32-4e795a3352c7.mspx?mfr=true

     

    Si tenes ganas de leer un poco más de DHCP te paso este link:

    http://www.microsoft.com/spain/windowsserver2003/technologies/dhcp/default.aspx

     

    3. Finalmente viene la configuración del ISA para permitir que funcione el DHCP en el mismo ISA. Esto es así porque ISA no se ve a si mismo ni como parte de la red externa ni de la interna, el esta en una red que se llama localhost a la cual pertenece el solo y cuando pones algo en el mismo ISA tenes que generar una regla de firewall que permita a la red interna acceder al ISA, o sea al localhost, para eso seguí esta nota paso a paso que es muy precisa y es lo que vos necesitas puntualmente:

    Configurar el equipo servidor ISA como un servidor DHCP

    http://www.microsoft.com/spain/technet/recursos/articulos/isaondhcpserver.mspx

     

     

    Espero te sirva de algo la respuesta y recuerda marcarla si te fue satisfactoria.

     

    Saludos,

    Cristian.

    viernes, 16 de noviembre de 2007 6:23
  • Gracias Cristian por tu pronta resúesta pero sigo sin DHCP, por otra parte me fije en el Registro en tiempo real, que vi como monitorear las reglas y todo eso en otro post, veo que la maquina que le pide IP a mi server le aparece lo siguente

    Hora de registro XXXXXX IP Destino 255.255.255.255 Puerto De destino 68 y 67 Protocolo DHCP peticion DHCP Respuesta

    Accion: Conexion Denegada    Regla:  Regla Predeterminada IP cliente 192.168.1.254   Red origen Externa

    Red destino: Host Local

    y tengo las sigueintes reglas en el siguiente orden

    1.- Regla INTERNA..... Accion;: PERMITIR   Protocolos:: DHCP Peticion y respuesta DNS SESION NETBIOS  


    De/escucha::Host local, interna    A:::: Host Local, Interna TODOS LOS USUARIOS

    2.-trafico local-Permitir-Todo el trafico saliente-Host Local, Interna-----Host Local Interna----Todos los US

    3.-Acceso ainternet-PERMITIR----HTTP, HTTPS----HOST LOCAL, INTERNA-----EXTERNA------ TODOS LOS US

    Ultimo.- REGLA PREDETERMINADA----DENEGAR---TODO EL TRAFICO----TODAS LAS REDES Y HOST LOCAL----TODAS LAS REDES Y HOT LOCAL---- TODOS LOS USUARIOS

    Y esta ultima regla no la puedo modificar se aceptan sugerencias
    sábado, 17 de noviembre de 2007 0:08
  • Hola Victor:

     

    Lo que muestra tu log es que no estas recibiendo IP en la interface externa, para eso tenes que habilitar que tu servidor ISA pueda tomar IP en la interface externa usando DHCP, para eso:

    1. Te vas a la consola del isa, te vas a Firewall Policy y le das botón derecho y seleccionas "Editar Politica del sistema" (no se muy bien como es en epañol pero es eso). Se te va a abrir una ventana donde podes configurar si tu ISA va a obtener dirección por DHCP, si vas a usar LDAP (Active Direcotry) si lo vas adminsitrar desde otras PCs, etc.

    2. Ni bien se abre la ventana para editar las politicas del sistema, lo primero que te aparece en Servicios de Red, es DHCP. Del lado derecho marca la opción habilitar y en la solapa "De:" agrega la red externa, eso va a permitir que tu ISA tome en la placa externa una dirección por DHCP. Ahora, todo esto no tiene nada que ver con tener un DHCP instalado en ISA, son dos cosas distintas.

     

    Fijate de hacer esto y el ISA va a tomar IP correctamente. Y fijate por otro lado que pasa con el DHCP que instalaste en el ISA, la idea es ir por pasos.

     

    Contame como te fue.

     

    Saludos,

    Cristian.

    sábado, 17 de noviembre de 2007 0:27
  • Hola Cristian

    pues hice lo que me dijiste y por arte de magia agarro IP mi server que hora dice proporcionado por DHCP pero ya no sale a internet, y como bien dices hay q ir por pasos asi que mejor te cuento que es lo que pretendo hacer con el ISA
    en primeer lugar lo necesito para restringir el uso del internet asi como prohibir el acceso a ciertas paginas, msn,etc etc
    te comento realmente lo del DHCP por que aqui hay un isa 2004 que dejo de funcionar y me puse el proposito de levantar el 2006 ahora este ISA 2004 lo tenian conectado con 2 tarjetas de red la cual 1 tenia si no mal recuerdo 192.168.X.X
    y la otra tenia la 10.10.10.X
    y las demas maquinas clientes agarraban un rango de direcciones entre 10.10.10.5 A 10.10.10.250 o algo asi
    entonces yo necesito hacer lo mismo para aplicar esta reglas o que me recomiendas que haga de acuerdo a tu experiencia?

    sábado, 17 de noviembre de 2007 1:36
  • Hola Victor:

     

    Bueno, hagamos una cosa, en este post vemos lo del DHCP, después, lo de las reglas lo podes ver en el foro, hay muchisimos post con ejemplos de como bloquear o permitir distintos tipos de traficos, messenger, etc.

     

    Primero, en ISA server, verifica tu configuración de red haciendo un IPCONFIG /all y postea el resultado. Indica cual es tu red interna y cual es tu red externa. Después, en ISA server, en la parte de redes asegurate que en la red interna tenes configurado el rango que el isa va a considerar interna (10.10.10.0 - 10.10.10.255) y todos los rangos que no esten definidos ahí van a ser externos. También podes correr el ISABPA (ISA Best Practices Analyzer) que te va a indicar que esta mal configurado a nivel de redes en ISA, porque acá primero tenemos que determinar que tu red este bien configurada antes de seguir configurando cosas.

     

    Aguardo los resultados así seguimos.

     

    Saludos,

    Cristian.

     

     

     

    lunes, 19 de noviembre de 2007 17:46
  • Hola Cristian

    pues bien he aqui los resultados

    Red Externa

    DHCP Habilitado.......No
    IP .............192.168.1.28
    Mascara de subred......255.255.255.0
    Pueta de enlace Predet.......192.168.1.255
    Servidores DNS 192.168.1.255
                            192.168.1.1


    Red Interna

    DHCP Habilitado.......No
    IP .............10.10.10.1
    Mascara de subred......255.255.255.0
    Pueta de enlace Predet.......10.10.10.255
    Servidores DNS 10.10.10.255
                            10.10.10.1

    Y bien paso lo siguiente en tu respuesta anterior me comentabas del Rango 10.10.10.0 al 255 en mi ISA en la parte de redes tenia yo del segmento 10.10.10.-1 al 254 cambie el 1 por un cero quedando 10.10.10.0-10..10.10.255 y por arte de magia empesaron a agarrar IP, ahora el detalle es que mi server ya no sale a internet ni mis maquinas al principio si sala pero muy muy lento hasta q de plano dejo de salir ha y me mando el server un error de conflictop de ip 10.10.10.1 hasta q lo reinicie
    que le quito , que le pongo??? agradesco tu respuesta
    martes, 20 de noviembre de 2007 22:25
  • Hola Victor:

     

    Perdona que me demore en responderte. Te comento que es lo que esta mal y después como configurarlo:

    1. Tenes gateway en tu red interna, removelo, dejalo en blanco. Además tenes la IP 10.10.10.255, que es una dirección de broadcast y no es una dirección válida.

    2. El gateway (puerta de enlace) de tu placa externa también esta mal configurado, tenes que poner como gateway la IP del router que tenes delante de ISA, ahora tenes configurada una dirección de broadcast y es imposible que puedas tener acceso a internet con esa configuración.

    3. Tus servidores DNS también estan mal configurados, en el caso de la externa pusiste 192.168.1.255 y 192.168.1.1 cuando ahí van los DNS de tu ISP o de tu router (por lo general la misma IP que tu router, que hace de proxy DNS) y en el caso de la red interna pusiste también algo similar, 10.10.10.255, que es una dirección de broadcast, también inválida y 10.10.10.1, que es tu mismo ISA, lo cual es muy raro a menos que tengas un servidor DNS en el ISA.

     

    La configuración de tus tarjetas de red sería más o menos así:

    Red Externa:

    IP: 192.168.1.28

    Mascara: 255.255.255.0

    Gateway: es la IP del router, normalmente 192.168.1.1 ó algunas veces 192.168.1.254

    DNS: los de ISP o el mismo router, o sea, si el router es 192.168.1.1 va esa entonces.

     

    Red interna:

    IP: 10.10.10.1

    Mascar: 255.255.255.0

    Gateway: queda en blanco

    DNS: tus DNS internos, si es que los hay, si no dejala en blanco.

     

    Ya con esto no tendrías que tener problemas. Cuando lo hagas, fijate si te queda funcionando, si no, volve a correr IPCONFIG /ALL, selecciona todo lo que salio en la pantalla y pegalo acá que lo vemos.

     

    A modo de ejmplo te muestro como tengo mi placa externa, en negrita lo que sale en pantalla, en rojo mis comentarios:

    ===================================================

    C:\Documents and Settings\User>ipconfig /all

    Windows IP Configuration

            Host Name . . . . . . . . . . . . : tyui
            Primary Dns Suffix  . . . . . . . :
            Node Type . . . . . . . . . . . . : Unknown
            IP Routing Enabled. . . . . . . . : No
            WINS Proxy Enabled. . . . . . . . : Yes

    Ethernet adapter Internet:

            Connection-specific DNS Suffix  . :
            Description . . . . . . . . . . . : NVIDIA nForce Networking Controller
            Physical Address. . . . . . . . . : 00-11-D2-B4-45-14
            Dhcp Enabled. . . . . . . . . . . : Yes    <---- la configuración de la red externa me la entrega mi router, que tiene un DHCP configurado, no configuro nada manual, pero si lo hago hay que respetar lo que te comente arriba.
            Autoconfiguration Enabled . . . . : Yes
            IP Address. . . . . . . . . . . . : 192.168.75.3
            Subnet Mask . . . . . . . . . . . : 255.255.255.240
            Default Gateway . . . . . . . . . : 192.168.75.1   <---- en mi caso el router tiene esta IP
            DHCP Server . . . . . . . . . . . : 192.168.75.1 <---- el que asigna la configuración IP es el DHCP y es mi router
            DNS Servers . . . . . . . . . . . : 200.49.156.12    <--- estos son los DNS de mi proveedor de internet
                                                200.49.156.6
                                                200.49.156.4
            Lease Obtained. . . . . . . . . . : Jueves, 22 de Noviembre de 2007 03:0
    8:02 p.m.
            Lease Expires . . . . . . . . . . : Viernes, 23 de Noviembre de 2007 03:
    08:02 p.m.

    ===================================================

     

    Espero te pueda servir de ayuda. Recuerda que si esto es la respuesta a tu pregunta de marcarla como tal.

     

    Saludos,

    Cristian

    viernes, 23 de noviembre de 2007 5:07
  • Que tal Cristian

    No hay que disculpar nada al contrario gracias por tomarte la molestia de responderme, pues mira ya puse en parctica lo que me comentas ahora con el ipconfig aparece esto

    Nombre del host:....kim-server
    subfijo DNS principal.....uni.kim
    tipo de nodo......hibrido
    enrutamiento IP habilitado....SI
    Proxy wins habilitado....NO
    Lista de busqueda subfijo DNS ...kim-server
                                                     El nombre de mi ISP

    Adaptador de red Externo

    DHCP habilitado...........NO
    Autoconfiguracion habilitada.......No
    Direccion IP.....192.168.1.154
    Mascara............255.255.255.0
    Puerta de enlace.....192.168.1.254
    servidor DHCP           La misma de arriba
    Servidores DNS          LA misma

    Adaptador de Red Interno

    Direccion_ IP 10.10.10.1
    DHCP HABILITADO.....NO
    Mascara.......255.255.255.0
    Puerta de enlace.....NADA



    ya con eso con eso mi server sale a internet ahora voy a checar mis maquinas
    sábado, 24 de noviembre de 2007 0:31
  • Hola de nuevo Cristian

    Acabo de marcar el tema como resuelto,y te quiero agradecer por tu apoyo todas mis maquinas salen a internet sin problemas, y puse un blocklist que me funciona a la perfeccion enserio muchas gracias y si algun dia necesitas algo (que no sea de ISA, claro, jejjejejejeje) no dudes en pedirlo

    Sos un capo mi hermano

    martes, 27 de noviembre de 2007 5:16
  • Hola Victor:

     

    Me alegro que lo hayas podido resolver y te agradezco tu respuesta. Este tipo de cosas son las que te dan las ganas para responder en el foro.

     

    Exitos!!!!

    martes, 27 de noviembre de 2007 14:25