locked
No puedo Ejecutar archivos con extención .cmd en Windows 7..? RRS feed

  • Pregunta

  • Hola a todos.

    Yo e diseñado algunos archivos tipo (bat y cmd) para facilitar funciones para Windows pero o mi sorpresa es que ahora que termine de

    actualizar mi Windows 7 con el nuevo Servic Pach1 no me permite ejecutar ningun archivo con extención (cmd)


    Para crear un archivo .cmd simplemente crearemos un nuevo bloc de notas e ingresaremos algo así:

    *********************************************************************************************************************************

    @Echo off
    Color 0A
    CLS
    Echo.
    Echo                              HOLA A TODOS...!!
    Echo.
    pause > nul
    Exit

    ******************************************************************************************************************************

    Lo guardamos con cualquier nombre pero cambiaremos la extención de (.txt) a (.cmd) y listo...


    Al correr el archivo normalmente debería abrirse un cuadro de D.O.S pero en mi caso aparece este cuadro y no tengo idea de como

    solucionarlo y espero que me puedan ayudar a solucionar este inconveniente.

     

     

    Ya e desinstalado el "Service Pack 1" y se mantiene el problema... Ojala y me puedan ayudar a solucionar este problema de lo

    contrario tendré que formatear mi PC...

    miércoles, 19 de enero de 2011 13:38

Respuestas

  • Hola mi amigo "Sergio Calderón" de antemano gracias por intentar ayudarme pero lamentablemente al ejecutar los cada uno de los registros y reiniciar la PC  los resultados fueron los mismos.

    No podía ejecutar ninguno de los archivos con exención .(CMD )

    Por cuestiones de mi trabajo e tenido que formatear la PC e instalar la última edición de Windows 7 SP1 Ultimate incorporado pero lamentablemente la PC trabaja muchísimo mas lenta que cuando tenia Windows 7 Ultimate.

    Sería genial si alguna persona se pueda comunicar con los Sr. de Microsoft y resuelvan este error y advertir que la instalación del SP1 para Windows tendrá consecuencias.

    Y si alguna persona a logrado solucionar el error lo pueda compartir en el foro..

     

    Gracias y suerte en todo.... :)


    Hola, pues directamente con tigo que tenías el problema hubiera sido el camino correcto para solucionarlo.

    Algo importante, el SP1 no está oficialmente lanzado ni integrado en ninguna edición de Windows 7 por lo que el rendimiento se te pudo haber visto comprometido por la modificación propia de esa ISO, es decir el integrar un RTM no oficial todavía.

    Te recomendaría que lo hagas con una edición sin SP1 de Windows 7 y esperes hasta el lanzamiento que no debe ser muy lejano.


    Sergio Calderón-
    • Propuesto como respuesta Ismael Borche martes, 25 de enero de 2011 14:30
    • Marcado como respuesta Ismael Borche miércoles, 26 de enero de 2011 17:46
    viernes, 21 de enero de 2011 12:51

Todas las respuestas

  • Hola,

    En el menú inicio teclea Opciones de carpeta y ábrela.

    En la ventana de Opciones de carpeta, pásate a la pestaña Ver y asegúrate de que la opción Escoder extensiones de tipos de archivo conocidas no esté seleccionada, si lo está quítasela para que se te vea la extensión .txt del archivo que creaste.

    Ahora si se te ve, debería quedarte algo como Incredimail.cmd.txt , si es así renómbralo para tenerlo como Incredimail.cmd

    Fíjate si te cambia el icono y puedes ejecutarlo.

    Saludos,


    Sergio Calderón-
    miércoles, 19 de enero de 2011 13:54
  • Hola,

    En el menú inicio teclea Opciones de carpeta y ábrela.

    En la ventana de Opciones de carpeta, pásate a la pestaña Ver y asegúrate de que la opción Escoder extensiones de tipos de archivo conocidas no esté seleccionada, si lo está quítasela para que se te vea la extensión .txt del archivo que creaste.

    Ahora si se te ve, debería quedarte algo como Incredimail.cmd.txt , si es así renómbralo para tenerlo como Incredimail.cmd

    Fíjate si te cambia el icono y puedes ejecutarlo.

    Saludos,


    Sergio Calderón-


    Algunos antivirus tienen la costumbre de eliminar la posibilidad de ejecutar .cmd o .bat (es decir elimina la asociacione en el registro).

    Saludos :)


    Osea que la pregunta sería, ¿Antivirus de terceros instalados? =)

    Aunque entonces podríamos pensar en reasociar desde el Editor de Registro.

    Saludos y gracias!


    Sergio Calderón-
    miércoles, 19 de enero de 2011 14:26
  • Hola,

    Confirmado Ximena, la asociación puede estar corrupta o eliminada.

    En este caso por los tipos de archivos por lotes.

    Para solucionarlo tendría entonces que abrir dos instancias del Blog de notas y en la primera digitar:

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\.bat]
    @="batfile"

    [HKEY_CLASSES_ROOT\.bat\PersistentHandler]
    @="{5e941d80-bf96-11cd-b579-08002b30bfeb}"

    Guardarla como Bat.reg por ejemplo y ejecutarla para aceptar todo.

    La segunda debería tener:

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\.cmd]
    @="cmdfile"

    [HKEY_CLASSES_ROOT\.cmd\PersistentHandler]
    @="{5e941d80-bf96-11cd-b579-08002b30bfeb}"

    Igualmente guardarlo como CMD.reg por ejemplo y seguir el asistente.

    En teoría, debería solucionar el problema...


    Sergio Calderón-
    miércoles, 19 de enero de 2011 14:32
  • Hola amigo Sergio Calderón..!!

    Gracias por tu ayuda... Voy a intentar con los dos codigos de registro para windows a ver que tal.. Luego te cuento como me fue...

     

    miércoles, 19 de enero de 2011 15:17
  • Hola amigo Sergio Calderón..!!

    Gracias por tu ayuda... Voy a intentar con los dos codigos de registro para windows a ver que tal.. Luego te cuento como me fue...

     


    Perfecto, quedamos pendientes!

    Saludos,


    Sergio Calderón-
    miércoles, 19 de enero de 2011 15:30
  • Hola mi amigo "Sergio Calderón" de antemano gracias por intentar ayudarme pero lamentablemente al ejecutar los cada uno de los registros y reiniciar la PC  los resultados fueron los mismos.

    No podía ejecutar ninguno de los archivos con exención .(CMD )

    Por cuestiones de mi trabajo e tenido que formatear la PC e instalar la última edición de Windows 7 SP1 Ultimate incorporado pero lamentablemente la PC trabaja muchísimo mas lenta que cuando tenia Windows 7 Ultimate.

    Sería genial si alguna persona se pueda comunicar con los Sr. de Microsoft y resuelvan este error y advertir que la instalación del SP1 para Windows tendrá consecuencias.

    Y si alguna persona a logrado solucionar el error lo pueda compartir en el foro..

     

    Gracias y suerte en todo.... :)

    viernes, 21 de enero de 2011 12:27
  • Hola mi amigo "Sergio Calderón" de antemano gracias por intentar ayudarme pero lamentablemente al ejecutar los cada uno de los registros y reiniciar la PC  los resultados fueron los mismos.

    No podía ejecutar ninguno de los archivos con exención .(CMD )

    Por cuestiones de mi trabajo e tenido que formatear la PC e instalar la última edición de Windows 7 SP1 Ultimate incorporado pero lamentablemente la PC trabaja muchísimo mas lenta que cuando tenia Windows 7 Ultimate.

    Sería genial si alguna persona se pueda comunicar con los Sr. de Microsoft y resuelvan este error y advertir que la instalación del SP1 para Windows tendrá consecuencias.

    Y si alguna persona a logrado solucionar el error lo pueda compartir en el foro..

     

    Gracias y suerte en todo.... :)


    Hola, pues directamente con tigo que tenías el problema hubiera sido el camino correcto para solucionarlo.

    Algo importante, el SP1 no está oficialmente lanzado ni integrado en ninguna edición de Windows 7 por lo que el rendimiento se te pudo haber visto comprometido por la modificación propia de esa ISO, es decir el integrar un RTM no oficial todavía.

    Te recomendaría que lo hagas con una edición sin SP1 de Windows 7 y esperes hasta el lanzamiento que no debe ser muy lejano.


    Sergio Calderón-
    • Propuesto como respuesta Ismael Borche martes, 25 de enero de 2011 14:30
    • Marcado como respuesta Ismael Borche miércoles, 26 de enero de 2011 17:46
    viernes, 21 de enero de 2011 12:51