none
Instalar Lync Edge Server con una unica IP publica y publicarlo con TMG RRS feed

  • Pregunta

  • Hola, quisiera que por favor me ayuden con este problema: He creado un servidor edge para Lync, el mismo no me ha dado ningún problema, el problema me surge al intentar realizar una prueba en https://www.testocsconnectivity.com/, el error que me arroja es:

    Testing SSLCertificate for validity.
    The SSLCertificate failed one or more certificate
    Additional Details

    If you are using a Reverse Proxy to get to the Access Edge Server, this could possibly be an issue with Reverse Proxy configuration.: Exception Details: Message: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. Type: System.IO.IOException Stack Trace:   at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)   at System.Net.FixedSizeReader.ReadPacket(Byte[] buffer, Int32 offset, Int32 count)   at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)   at System.Net.Security.SslState.ForceAuthentication(Boolean receiveFirst, Byte[] buffer, AsyncProtocolRequest asyncRequest)   at System.Net.Security.SslState.ProcessAuthentication(LazyAsyncResult lazyResult)   at System.Net.Security.SslStream.AuthenticateAsClient(String targetHost)   at TestOCSConnectivity.Tests.SSLCertificateTest.PerformTestReally() Exception Details: Message: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. Type: System.IO.IOException Stack Trace:   at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)   at System.Net.FixedSizeReader.ReadPacket(Byte[] buffer, Int32 offset, Int32 count)   at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)   at System.Net.Security.SslState.ForceAuthentication(Boolean receiveFirst, Byte[] buffer, AsyncProtocolRequest asyncRequest)   at System.Net.Security.SslState.ProcessAuthentication(LazyAsyncResult lazyResult)   at System.Net.Security.SslStream.AuthenticateAsClient(String targetHost)   at TestOCSConnectivity.Tests.SSLCertificateTest.PerformTestReally()

    Por favor quisiera que me ayuden ya que es el único problema que hasta el momento me da, al parecer es problema de un certificado, pero no se cual es el certificado que debo exportar y/o importar.

    Agradezco la valiosa ayuda que me puedan ofrecer.

    • Cambiado Lorena Marin sábado, 26 de mayo de 2012 17:41 (De:Servicios de Información Microsoft)
    viernes, 16 de marzo de 2012 21:22

Respuestas

  • Hola Diego, desde el lado de Lync ese escenario no está soportado. Debes tener tres IPs públicas para cada uno de los servicios que estas configurando en el rol de EDGE, los cuales son ACCESS, WEBCON y A/V.

    De ahi debes tener IPs adicionales para generar el nateo entre tus IPs configuradas en la topología de cada uno de esos servicios, y la regla correspondiente en el tmg para que fluya el tráfico.

    Saludos


    NOTA: Si llegaste a la solución de tu problema, por favor haz clic en "Proponer como respuesta" así otros visitantes del sitio pueden identificarlo como resuelto en caso de que les suceda lo mismo. Heber Gonzalez Consultor en mensajería & UC Microsoft www.Xelcon.com.ar http://blogs.itpro.es/hebergonzalez/ http://ar.linkedin.com/in/hebergonzalez

    miércoles, 3 de octubre de 2012 21:43

Todas las respuestas

  • Hola Diego, desde el lado de Lync ese escenario no está soportado. Debes tener tres IPs públicas para cada uno de los servicios que estas configurando en el rol de EDGE, los cuales son ACCESS, WEBCON y A/V.

    De ahi debes tener IPs adicionales para generar el nateo entre tus IPs configuradas en la topología de cada uno de esos servicios, y la regla correspondiente en el tmg para que fluya el tráfico.

    Saludos


    NOTA: Si llegaste a la solución de tu problema, por favor haz clic en "Proponer como respuesta" así otros visitantes del sitio pueden identificarlo como resuelto en caso de que les suceda lo mismo. Heber Gonzalez Consultor en mensajería & UC Microsoft www.Xelcon.com.ar http://blogs.itpro.es/hebergonzalez/ http://ar.linkedin.com/in/hebergonzalez

    miércoles, 3 de octubre de 2012 21:43


  • hola Diego hurtado me gustaria saber si ya resolviste tu problema lo que pasa es que   yo tambien monte un servidor lync2013 y no puedo echarlo andar con una sola ip y me gustaria saber si se puede o no de antemano muchas gracias..!!!

    saludos!!

    miércoles, 13 de febrero de 2013 18:01
  • Buenas tardes,

    Esta configuración es posible, pero debes cambiar los puertos por defecto de los distintos servicios publicados. Se recomienda el tener siempre 3 IP Públicas, puesto que así puedes tener todos los servicios en el puerto 443. Esto evita problemas de acceso desde cualquier red, puesto que estos puertos suelen estar habilitados en cualquier firewall.

    Si queréis implementar todos los servicios esta podría ser la combinación de puertos:

    Servicios Web (meet, Dialin, Web services, etc..): TCP 443

    EDGE:

    • Acceso: TCP 444
    • Webconf: TCP 4443
    • AV: TCP 4434

    No he podido probarlo, pero esta configuración debería funcionar. Si alguien lo puede probar sería perfecto y así vamos ajustando si es posible

    Gracias por vuestro feedback

    jueves, 28 de marzo de 2013 18:53