none
Accesibilidad - etiqueta <html lang="es-es"> RRS feed

  • Pregunta

  • Hola.

    por mucho que intento modificar en mi master la propiedad lang="es-es" a lang="es" de la etiqueta html, el sharepoint 2010 me lo modifica.

    alguna sugerencia??

    Gracias

    miércoles, 22 de febrero de 2017 13:23

Todas las respuestas

  • ¿Cómo has hecho el cambio?

    Acabo de probar y funciona sin problema

    Si has puesto un lang="es" en una etiqueta HTML propia ten en cuenta que la que lleva por defecto SharePoint te coge el idioma de tu fichero de recursos y está compuesta por $Resources:wss,language_value, por lo que cambiará el valor que indiques a mano salvo que elimines esa referencia.

    Un saludo

    • Propuesto como respuesta Moderador M miércoles, 22 de febrero de 2017 15:27
    • Votado como útil Moderador M jueves, 23 de febrero de 2017 16:54
    miércoles, 22 de febrero de 2017 14:39
  • hola.

    pues lo realice borrando de la etiqueta html la propiedad lang="<%$Resources:wss,language_value%>" y sustituyendola por lang="es"

    pero al ejecutar no devuelve el cambio.

    miércoles, 22 de febrero de 2017 15:24
  • Si lo haces tú y lo pruebas tú (sin publicar) aun así deberías verlo reflejado en el navegador.

    En cambio si se hace el cambio y la comprobación por usuarios diferentes, a no ser que publiques no se verá modificado, igual es lo que falta.

    La verdad es que no tiene más ciencia que lo que expones, cambiar lo que hay dentro del lang en la master page, guardar, publicar y debería funcionar sin problema.

    Como opción adicional se me ocurre que por algún despiste estés modificando la master page incorrecta y por eso no veas reflejados los cambios en real, si tienes varias es posible que el cambio lo hayas hecho donde no corresponde (no sería la primera vez que lo veo)

    De todos modos, en el peor de los casos, a pesar de que en accesibilidad es una buena práctica acortar al máximo la partícula de idioma si no se van a introducir variantes específicas de una región, tampoco es un error dejar el "es-es", por lo que dudo mucho que te falle algo si no consiguieras cambiarlo.

    Un saludo

    miércoles, 22 de febrero de 2017 15:45
  • hola de nuevo,

    modificando la master correcta, eliminando la propiedad lang="<%$Resources:wss,language_value%>" de la etiqueta html y añadiendo la propiedad lang="es" la aplicación me elimina esta ultima.

    miércoles, 22 de febrero de 2017 16:11
  • Pues en ese caso no se me ocurren más ideas

    ¿Con qué herramienta haces los cambios? ¿Llegas a poder guardar y verlos reflejados en el salvado del fichero?

    ¿No tendrás algo instalado que te restaure una versión anterior cuando detecte un cambio?

    miércoles, 22 de febrero de 2017 17:14
  • SPS Designer 2010
    miércoles, 22 de febrero de 2017 17:17
  • En ese caso es la misma prueba que he realizado yo en varias master page y funciona en todas.

    Por confirmar lo obvio ¿estás desprotegiendo el fichero antes de realizar los cambios?

    Para revisar todo el proceso se me ocurre que pongas paso a paso cómo haces todo desde que abres el Designer hasta que haces la comprobación en el navegador por si en alguna de las fases se nos escapa algo.

    viernes, 24 de febrero de 2017 13:18