none
Problemas con WSUS RRS feed

  • Pregunta

  • Ante todo buenos dias, he terminado de implementar y configurar WSUS en un servidor miembro de la red (SCGPS01) y he configurado WSUS mediante el puerto 80, sin embargo cuando corro ClientDiag en un equipo cliente obtengo este mensaje de error.

    WSUS Client Diagnostics Tool

    Checking Machine State
            Checking for admin rights to run tool . . . . . . . . . PASS
            Automatic Updates Service is running. . . . . . . . . . PASS
            Background Intelligent Transfer Service is running. . . PASS
            Wuaueng.dll version 7.5.7601.17514. . . . . . . . . . . PASS
                    This version is WSUS 2.0

    Checking AU Settings
            AU Option is 3 : Notify Prior to Install. . . . . . . . PASS
                    Option is from Policy settings

    Checking Proxy Configuration
            Checking for winhttp local machine Proxy settings . . . PASS
                    Winhttp local machine access type
                            <Direct Connection>
                    Winhttp local machine Proxy. . . . . . . . . .  NONE
                    Winhttp local machine ProxyBypass. . . . . . .  NONE
            Checking User IE Proxy settings . . . . . . . . . . . . PASS
                    User IE Proxy
                    192.168.27.1:3128
                    User IE ProxyByPass
                    <local>
                    User IE AutoConfig URL Proxy . . . . . . . . .  NONE
                    User IE AutoDetect
                    AutoDetect not in use

    Checking Connection to WSUS/SUS Server
                    WUServer = http://scgps01
                    WUStatusServer = http://scgps01
            UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS
            Connection to server. . . . . . . . . . . . . . . . . . PASS

    WinHttpDownloadFileToMemory(szURLDest, NULL, 0, NULL, NULL, NULL, &downloadBuffe
    r) failed with hr=0x80190194

    No Error description could be found

    Press Enter to Complete

    Que es lo que podria estar pasando, el servidor WSUS sincroniza y descarga todas las actualizaciones, he configurado GPO en 2 UO's para pruebas y he configurado ahi las politicas, sin embargo cuando se deben de instalar las actualizaciones que he aprobado, estas no se dan.

    Gracias por toda ayuda.

    miércoles, 5 de septiembre de 2012 21:05

Todas las respuestas

  • En distintos foros hablan sobre la creacion de un directorio virtual en IIS el cual deba llamarse SelfUpdate, no se que tan de cierto hay esto, pero encontre un link http://social.technet.microsoft.com/Forums/zh/winserverwsus/thread/53de4321-da34-4c24-b17d-34a97726aee9 el cual hace mencion aun caso similar, espero me puedan ayudar.

    Slds.

    Gracias

    miércoles, 5 de septiembre de 2012 22:21
  • Amigos para seguir comentando sobre este inconveniente que estoy presentando luego de la implementacion del servidor WSUS.

    1.- Me di cuenta que en IIS no habia el directorio SelfUpdate, asi que lo cree y direccione este directorio a la carpeta destino \Windows\WindowsUpdate. Al hacer esto y pasar el ClientDag en la estacion de trabajo obtengo lo siguiente: 

    WSUS Client Diagnostics Tool

    Checking Machine State
            Checking for admin rights to run tool . . . . . . . . . PASS
            Automatic Updates Service is running. . . . . . . . . . PASS
            Background Intelligent Transfer Service is running. . . PASS
            Wuaueng.dll version 7.5.7601.17514. . . . . . . . . . . PASS
                    This version is WSUS 2.0

    Checking AU Settings
            AU Option is 4: Scheduled Install . . . . . . . . . . . PASS
                    Option is from Policy settings

    Checking Proxy Configuration
            Checking for winhttp local machine Proxy settings . . . PASS
                    Winhttp local machine access type
                            <Direct Connection>
                    Winhttp local machine Proxy. . . . . . . . . .  NONE
                    Winhttp local machine ProxyBypass. . . . . . .  NONE
            Checking User IE Proxy settings . . . . . . . . . . . . PASS
                    User IE Proxy
                    192.168.27.1:3128
                    User IE ProxyByPass
                    <local>
                    User IE AutoConfig URL Proxy . . . . . . . . .  NONE
                    User IE AutoDetect
                    AutoDetect not in use

    Checking Connection to WSUS/SUS Server
                    WUServer = http://scgps01
                    WUStatusServer = http://scgps01
            UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS
            Connection to server. . . . . . . . . . . . . . . . . . PASS
            SelfUpdate folder is present. . . . . . . . . . . . . . PASS

    Press Enter to Complete

    Por ese lado creo estar andando bien.

    2.- En mi DC he creado 2 GPO en cada UO donde estan alojados los equipos y la configuracion en dichas GPO's son las siguiente: Plantillas Administrativas/Componentes Windows/Windows Update:

    - No mostrar la opcion..... Habilitada
    - No ajustar la opcion..... Habilitada
    - Configurar actualizaciones - Habilitada
    - Especificar la ubicacion..... Habilitada (aqui he puesto http://scgps01)
    - Habilitar que el cliente.... Habilitada (aqui apunta aun grupo que he creado en el servidor WSUS - Sistemas)
    - Volver a programar..... Habilitada
    - No reiniciar.... Habilitada

    Sin embargo cuando ejectuto el ClientDag en el servidor WSUS obtengo lo siguiente:

    WSUS Client Diagnostics Tool

    Checking Machine State
            Checking for admin rights to run tool . . . . . . . . . PASS
            Automatic Updates Service is running. . . . . . . . . . PASS
            Background Intelligent Transfer Service is running. . . PASS
            Wuaueng.dll version 7.6.7600.256. . . . . . . . . . . . PASS
                    This version is WSUS 2.0

    Checking AU Settings
            AU Option is 4: Scheduled Install . . . . . . . . . . . PASS
                    Option is from Control Panel

    Checking Proxy Configuration
            Checking for winhttp local machine Proxy settings . . . PASS
                    Winhttp local machine access type
                            <Direct Connection>
                    Winhttp local machine Proxy. . . . . . . . . .  NONE
                    Winhttp local machine ProxyBypass. . . . . . .  NONE
            Checking User IE Proxy settings . . . . . . . . . . . . PASS
                    User IE Proxy
                    192.168.27.1:3128
                    User IE ProxyByPass
                    <local>
                    User IE AutoConfig URL Proxy . . . . . . . . .  NONE
                    User IE AutoDetect
                    AutoDetect not in use

    Checking Connection to WSUS/SUS Server
    AU does not have Policy Set
    AU does not have Policy Set
            UseWuServer is disabled . . . . . . . . . . . . . . . . FAIL

    Press Enter to Complete

    Quiere decir que las GPO´s que he creado en mi DC no estan siendo replicadas, agradeceria mucho me puedan ayudar a resolver este inconveniente, he leido diversos foros y uno en especial el cual cito (http://itdualism.wordpress.com/2010/04/09/wsus-client-refused-to-sync/) ya que he podido comprobar que no tengo los director [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\windows\WindowsUpdate] y [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\windows\AU] en mi servidor donde aloja WSUS.

    Gracias x toda ayuda.
    jueves, 6 de septiembre de 2012 20:37