none
ERROR DOBLE SALTO AL LLMARA DESDE INFOPAHT A WEB SERVICES DE SHAREDPOINT 2010 RRS feed

  • Pregunta

  • Buenas,

    A continuación describo la infraestructura que existe y el problema:

    Se dispone de un TMG 2010 con una web listener de sharepoint por https y con autentificacion de Acitve directory por ldap y en el web listener esta la autentificación basada en formulario y por NTLM . Por otro lado se ha creado un NLB con dos frontales de sharepoint 2010  con la autentificación por NTLM tanto en el IIS y en el sharepoint 2010.  A parte se ha creado una CA (central de Administración) y otra maquina con una base de dato en sql server 2008 .

    Ahora los desarrolladores intentan acceder por la herramienta de infopath a un formulario que llama a un web service de SharePoint que ataca al weblistener desde internet. Tras monitorizar se ve un error de 401 unathorized.

    Se ha investigado por Internet y se cree que es debido al tipo de autentificacion(error de doble salto).  Se ha intentado cambiar la autentificación del portal a Kerberos  cambiando en las maquinas afectadas de NTLM a negociate kerbero (en el caso de IIS y sharepoint) y en el caso del tmg se ha puesto negociate kerbero y ntlm.

    Se ha visto en el visor de eventos de los frontales que se autentifican por kerberos pero sigue pasando lo mismo  se ha monitorizado en el tmg 2010 y se ve como dos llamadas y la primero con autentificacion y la segunda como anonimo, también hemos observado que si se pone en el tmg solo kerberos falla y nadie se autentifica .

    Por favor se me puede orientar de como pueden acceder los desarrolladores a traves de infopath desde internet  al weblistener???

    Al autenticar el portal via Kerberos sospechamos que la autentificación esta bien realizada pero el formulario infopath da el mismo error.

    Muchas Gracias por las molestias.

    miércoles, 25 de marzo de 2015 14:29

Respuestas

  • Hola ,

    Muchas Gracias por responder pero lamentablemente en el entrono de pruebas no ha funcionado (he de decir que en este entorno esta por NTLM) , y se ha probado a poner en los frontales y en el archivo host con ip 127.0.0.1 con url internet (http://) y la externa (https://) y a dado error en ambos casos

    Muchas Gracias por todo

    • Marcado como respuesta Moderador M lunes, 30 de marzo de 2015 15:36
    jueves, 26 de marzo de 2015 8:16

Todas las respuestas

  • Hola, has lo siguiente, en el archivo host (c:\windows\system32\drivers\etc\hosts) agrega las siguientes líneas:

    Para el WFE 1:
    127.0.0.1 http://url_site

    Para el  WFE 2:
    127.0.0.1 http://url_site

    Lo que va a hacer, es evitar el doble salto. 

    Saludos.

    miércoles, 25 de marzo de 2015 19:33
  • Hola ,

    Muchas Gracias por responder pero lamentablemente en el entrono de pruebas no ha funcionado (he de decir que en este entorno esta por NTLM) , y se ha probado a poner en los frontales y en el archivo host con ip 127.0.0.1 con url internet (http://) y la externa (https://) y a dado error en ambos casos

    Muchas Gracias por todo

    • Marcado como respuesta Moderador M lunes, 30 de marzo de 2015 15:36
    jueves, 26 de marzo de 2015 8:16
  • Al final ya he conseguido una solucion para este tema

    Sin kerberos

    BIENN!!!!!

    jueves, 26 de marzo de 2015 13:41
  • Muchas gracias por las molestias
    jueves, 26 de marzo de 2015 13:42