none
Windows Media Player 12 no muestra subtitulos RRS feed

  • Pregunta

  • Buenas
    Compre una notebook Dell Inspiron con Windows 7 preinstalado
    Casi todo funciona bien
    No instalo correctamente algunos frameworks de Visual Studio Team System 2008
    Eso lo resolvi pero no puedo usar programacion para celulares, no lo instalo
    Hoy quise mirar peliculas que las veia con el WMP 11 de Vista y andaban bien, mostrando subtitulos, pero en Windows 7 el WMP 12 no muestra los subtitulos.
    Como uso mi notebook para pasar las peliculas en el geriatrico, los abuelos quedaron tristes, porque con la anterior que esta con Vista o la otra, con XP, nunca tuvimos esos problemas
    Se puede instalar la version 11 del Media Player en Windows 7 o hay que instalar algo para que muestren los subtitulos?
    Julio
    lunes, 28 de diciembre de 2009 1:31

Respuestas

  • La solucion que apuntas al final es la misma que apuntaba yo, pero algun guru del foro no esta de acuerdo y prefieren otra solucion, para mi peor, pero bueno, cada maestrillo tiene su librillo y este es el mio.

    Yo lo que hago para que me funcione todo ok, es lo siguiente.

    Instalo el K-Lite Mega codec pack al cual le activo el HAALI MEDIA SPLITTER, tambien incluye el directvobsub y ademas con el Win7_DSFilterTweaker (incluido en las ultimas revisiones) desactivo del media foundation la extension .mov, ya que si no estos en alta definicion se quedan pillados y van a saltos, podeis probar con el trailer de avatar en HD.

     

    Saludos

    lunes, 12 de julio de 2010 9:19

Todas las respuestas

  • Muchas veces sucede esto porque tiene unos codecs distintos a los que administra el Windows Media Player, si fuese así deberías proceder a otro reproductor o usar los que tiene el VCL por ejemplo.
    Sin embargo si las películas que tienes, traen el archivo de subtítulo agregado, debes abrir el Windows Media Player darle al botón Organizar, luego Opciones, y en la pestaña de Seguridad activar la opción Mostrar subtítulos locales si existen y con esto se te deberían visualizar.

    Saludos,
    Sergio Calderón
    Microsoft Student Partner
    lunes, 28 de diciembre de 2009 1:44
  • Sergio
    Esto ya lo hice
    Hice todo lo que esta a mi alcance y a mi conocimiento
    Hasta la fecha, nunca tuve problemas con los programas de Microsoft, pero esto me  llevo todo el dia y no lo pude superar
    Lo peor, es que estuve leyendo en un monton de lados, usando tanto google como bing, y es un error recurrente, no corregido
    Alguna idea de como activarlo?
    Gracias
    lunes, 28 de diciembre de 2009 1:56
  • Podrías decirme de dónde son las películas, y si traen los subtítulos integrados?
    Sergio Calderón
    Microsoft Student Partner
    lunes, 28 de diciembre de 2009 1:58
  • Sergio
    Las peliculas son argentinas, en formato avi, de los años 40 y 50, y como hay muchos abuelos que no escuchan bien, les agrego en en archivo .sub o .txt los subtitulos, para que los que son poco sordos lean los subtitulos
    El tema es que los subtitulos no andan, no los muestra
    Si levanto los subtitulos con un convertidor y los grabo incluidos, asi andan, pero necesito para otros los subtitulos en guarani, y eso, es un tema, porque no los podria pasar
    Hasta la version 11 del WMP en visatA O EN xp, ESA FUNCION ANDA DE 10, no hay que tocar ningun seteo, es automatica.
    En Windows 7 NO FUNCIONA, aunque actives Mostrar subtítulos locales si existen
    Habra que esperar hasta el SP 1 del WMP?
    lunes, 28 de diciembre de 2009 2:09
  • No creo, debes asegurarte de que estén en la misma carpeta sólo el archivo de película y el archivo de subtítulo, es que no es problema completo del Media Player, sino que hay formatos que no son reconocidos o trabajados.
    Sergio Calderón
    Microsoft Student Partner
    lunes, 28 de diciembre de 2009 2:11
  • Sergio,
    Las peliculas estan en un carrier disk Wetern Digital de 512 GB
    Si lo instalo en la notebook con Vista, es profesional, anda todo de diez
    Si lo instalo en la notebook con Windows 7, el mismo carrier disk, no andan
    Por lo tanto el problema esta en el Media Player de Windows 7, o en el Windows 7, ahi no lo se
    No puedo creer que sea un problema de hardware, porque TODO lo demas anda y anda bien
    Julio
    lunes, 28 de diciembre de 2009 2:20
  • Julion,

    No me refiero a problema físico no me malentiendas compa :) , en Windows 7 una de las únicas (Tal vez la única) maneras de que te reconozca archivos de subtítulos es separando en una carpeta exclusivamente la película con el archivo de título, sin embargo funciona poco por reconocimiento.

    En Vista pudo haberte funcionado pero era Media Player 11, ahora es 12 y está más fresco, es otra versión y empezando en el período de funcionalidad, actualizaciones y demás, por esto no podría haber punto de comparación, ya que al ser dos versiones distintas lo que le ocurra a una no necesariamente debe pasarle a la otra (Aunque en muchas ocasiones debería).

    En este caso mi consejo es recurras a otro reproductor para agregar subtítulo al momento de reproducción de película.

    Saludos,
    Sergio Calderón
    Microsoft Student Partner
    lunes, 28 de diciembre de 2009 2:27
  • Sergio,
    Tenes idea que reproductor de peliculas .avi o .mp4 o .rmvb funciona en Windows 7 Home Premium de 64 bits ?
    El problema es reconocer los 64 bits, eso es lo distinto
    Mis notebooks con Vista, no andaban a 64 bits, pero esta es de 4GB de memoria ampliable a 8 GB, por lo tanto si anda a 64 bits
    La notebook con XP professional no tiene ese problema
    Gracias
    Julio

    lunes, 28 de diciembre de 2009 2:47
  • En Windows 7 x64 no tienes problema con aplicaciones que sean o no de 64 bits para que funcionen, es decir puedes instalar cualquiera que sea de 32 bits, te lo instalará en Archivos de programas (x86) y el funcionamiento será el mismo de siempre sin problemas :-)

    Saludos,
    Sergio Calderón
    Microsoft Student Partner
    lunes, 28 de diciembre de 2009 2:56
  • Puedes probar a instalar el HAALIMEDIA SPLITTER , desde aqui, http://www.afterdawn.com/software/video_software/codecs_and_filters/haalimediasplitter.cfm

    O en el paquete de codecs K-Lite codec pack tambien viene, pero en este ultimo lo debes activar o seleccionar para su funcionamiento, hay un post cerca de este en el que describia unos problemillas con peliculas con el audio dual, este tambien sirve a parte de los subtitulos para este problema que yo tenia.

    Saludos
    lunes, 28 de diciembre de 2009 20:39
  • Puedes probar a instalar el HAALIMEDIA SPLITTER , desde aqui, http://www.afterdawn.com/software/video_software/codecs_and_filters/haalimediasplitter.cfm

    O en el paquete de codecs K-Lite codec pack tambien viene, pero en este ultimo lo debes activar o seleccionar para su funcionamiento, hay un post cerca de este en el que describia unos problemillas con peliculas con el audio dual, este tambien sirve a parte de los subtitulos para este problema que yo tenia.

    Saludos
    Yo definitivamente te recomiendo que NO bajes esto. Trae problemas en tu maquina.
    Ricardo Polo "HodracirK"
    lunes, 28 de diciembre de 2009 20:55
  • Sergio,
    Tenes idea que reproductor de peliculas .avi o .mp4 o .rmvb funciona en Windows 7 Home Premium de 64 bits ?
    El problema es reconocer los 64 bits, eso es lo distinto
    Mis notebooks con Vista, no andaban a 64 bits, pero esta es de 4GB de memoria ampliable a 8 GB, por lo tanto si anda a 64 bits
    La notebook con XP professional no tiene ese problema
    Gracias
    Julio

    El reproductor funciona igual sin importar que sea de 32 o de 64.
    Igual si solo planeas dejar esas 4 GB de memoria te recomiendo una edición de 32 bits...

    Ricardo Polo "HodracirK"
    lunes, 28 de diciembre de 2009 20:57
  • Ricardo,

    Si voy a colocar los 8 GB en la notebook

    Justamente, esa es la idea

    Tiene 2 discos externos, que con el que trae la maquina, le dan 2 TB

    Por eso necesito todo eso, porque yo la necesito para que vuele el VSTS 2010, cuando salga

    Y necesito las peliculas de Microsoft para desarrollo, que les debo colocar los subtitulos

    Esa es la idea, para que aprendan unos chicos

    Entonces, debo buscar un reproductor de videos de 64 bits

    Gracias

    Julio
    lunes, 28 de diciembre de 2009 22:47
  • Pero no tiene que ser un reproductor de 64 bits (Es bien difícil encontrar uno seguro y bueno), puedes valerte por uno de tu confianza (Y de sitio confiable) que sea de 32 bit te funcionará perfectamente.
    Sergio Calderón
    Microsoft Student Partner
    lunes, 28 de diciembre de 2009 22:52
  • Ricardo,

    Si voy a colocar los 8 GB en la notebook

    Justamente, esa es la idea

    Tiene 2 discos externos, que con el que trae la maquina, le dan 2 TB

    Por eso necesito todo eso, porque yo la necesito para que vuele el VSTS 2010, cuando salga

    Y necesito las peliculas de Microsoft para desarrollo, que les debo colocar los subtitulos

    Esa es la idea, para que aprendan unos chicos

    Entonces, debo buscar un reproductor de videos de 64 bits

    Gracias

    Julio
    Te recomiendo usar VLC.

    No te preocupes que sea de 32 bits... de hecho para 64 bits hay pocos codecs, por eso el Windows Media Player que usa predeterminadamente windows 7 es de 32 y no de 64.

    VLC si lee los subtitulos sin problemas, los srt. Y no instala cosas extrañas en tu compu.

    Un saludo,

    PD: Guarani?? Que cool!!! Un saludo hermano latino

    Ricardo Polo "HodracirK"
    lunes, 28 de diciembre de 2009 23:41
  • Ricardo,

    Mi apellido, en quechua, es dulce caramelo

    Anecdota nomas

    Saludos
    martes, 29 de diciembre de 2009 17:23
  • Ricardo,

    Mi apellido, en quechua, es dulce caramelo

    Anecdota nomas

    Saludos
    En Paraguay también hablan quechua? Yo pensé que solo había hasta Bolivia...
    Ricardo Polo "HodracirK"
    martes, 29 de diciembre de 2009 19:25
  • Eso es Bolivia, no Paraguay

    Saludos
    jueves, 31 de diciembre de 2009 0:56
  • Puedes probar a instalar el HAALIMEDIA SPLITTER , desde aqui, http://www.afterdawn.com/software/video_software/codecs_and_filters/haalimediasplitter.cfm

    O en el paquete de codecs K-Lite codec pack tambien viene, pero en este ultimo lo debes activar o seleccionar para su funcionamiento, hay un post cerca de este en el que describia unos problemillas con peliculas con el audio dual, este tambien sirve a parte de los subtitulos para este problema que yo tenia.

    Saludos
    Yo definitivamente te recomiendo que NO bajes esto. Trae problemas en tu maquina.
    Ricardo Polo "HodracirK"

    Podrias decribir los problemas que tendrá, segun muchas paginas esta version esta actualizaa y compatible con W7, tanto para 32 como para 64.

    Aunque rectifico ya que este le seriviria solo  para poder usar los codecs de AVC h.264, compatibles tambien con CUDA de Nvidia para liberar al procesador de la descompresion de video si es el caso, como no lo es es posiblemente y no es el programa necesario para los subtitulos es  de sabios rectificar y no es necesario que lo instale.

    Lo que realmente SI le hace falta es el DirectVobSub por ejemplo, que tambien lo puede instalar desde el K-Lite codec pack, problemas 0, ya que el WMP 12 no le hace caso a ninguno de los codecs extras que instalas, pero esto si que funciona ok

    La verdad  es que lo he instalado solo por probarlo en este caso y el unico problema que tengo es que ahora veo los subtitulos, teniendolos como siempre con el mismo nombre del video que reproduces en extension .srt .

    Si nos puedes describir mas sobre el problema que tendria el HAALI, seria de ayuda para todos, para no caer en el error y saber mas de esa incomptibilidad.


    Saludos
    viernes, 1 de enero de 2010 12:35
  • Hermano, Creo que tengo solución para tu caso, aunque ya este post tiene varios meses, yo tenia el mismo problema windows media player 12 no muestra subtitulos en windows 7, navegando me encontré con una pagina que daba estas instrucciones, y a mi me funcionó y ya puedo ver los subtitulos en las peliculas, instala estas 2 aplicaciones, directvobsub y haali

    http://www.free-codecs.com/download/directvobsub.htm

    http://haali.su/mkv/

    despues de instalarlos trata nuevamente abrir el archivo .avi igual como lo hacias regularmente con el archivo de subtitulos en la misma carpeta, y vuala!! deberias de ver los subtitulos, si no funciona, trata lo siguiente

    Revisa que la aplicacion haali, este configurada para mostrar los subtitulos, dandole clic derecho en el icono en la barra de tareas mientras estas reproduciendo el video si aún no hay subtitulos, cierra el WMP12 y ve hacia la carpeta Haali media y da clic en application settings, ve hacia options y en under compatibility habilita "Autoload VSFilter". con esto se debera solucionar, asi de simple.

    lunes, 12 de julio de 2010 3:57
  • La solucion que apuntas al final es la misma que apuntaba yo, pero algun guru del foro no esta de acuerdo y prefieren otra solucion, para mi peor, pero bueno, cada maestrillo tiene su librillo y este es el mio.

    Yo lo que hago para que me funcione todo ok, es lo siguiente.

    Instalo el K-Lite Mega codec pack al cual le activo el HAALI MEDIA SPLITTER, tambien incluye el directvobsub y ademas con el Win7_DSFilterTweaker (incluido en las ultimas revisiones) desactivo del media foundation la extension .mov, ya que si no estos en alta definicion se quedan pillados y van a saltos, podeis probar con el trailer de avatar en HD.

     

    Saludos

    lunes, 12 de julio de 2010 9:19
  • aaaaaaaaaaaa gracias me salvaste =)
    viernes, 23 de septiembre de 2011 19:41