none
Vincular 2 o mas libros en Excel RRS feed

  • Pregunta

  • Me llamo Pedro, soy ingeniero electrónico y lamentablemente soy muy malo en cuanto a Excel se refiere, por lo que recurro a la ayuda de los 

    expertos. Sucede que recientemente me surgió un problema en la empresa en la que trabajo, necesito que un libro de Excel (llamémoslo 

    "Libro1") se actualice de manera automática con los datos que constantemente cambian o aumentan en otro u otros libros (llamémoslos 

    "LibroA", "LibroB", "LibroC",..., "LibroZ"); y estaría muy agradecido si pudieran ayudarme con mi problema.

    La situación es esta; en el "LibroA" tengo una columna que contiene solo palabras, dichas palabras se repiten de forma aleatoria en las 

    filas de dicha columna y lo que necesito es que se haga un conteo del número de veces que se repite cada palabra en esa columna pero que 

    este conteo se haga en un libro diferente, lo único que he podido hacer hasta el momento es que ese conteo se haga en una hoja diferente 

    pero del mismo libro. Por ejemplo, si quiero que me muestre el conteo de la palabra "PERSONAL" en la misma hoja utilizo esta fórmula para 

    hacerlo: =CONTAR.SI(A1:A10000,"PERSONAL") y de esta manera para cada palabra que quiero contar; para hacerlo en una hoja diferente del mismo 

    libro utilizo la fórmula: =CONTAR.SI(Hoja1!A1:A10000,"PERSONAL"). Pero como ya te mencioné necesito hacer esto para cada libro del "LibroA" 

    al "LibroZ", pero los resultados de cada palabra de cada libro uno me deben aparecer en una celda diferente del "Libro1". Ah!!!!, casi lo 

    olvido, los libros "LibroA" al "LibroZ" están todos en direcciones diferentes incluso algunos están en discos duros diferentes dentro de una 

    "red de trabajo" por lo que las direcciones IP de cada libro cambian. Recuerdo que si pude hacerlo con esa fórmula pero solo funcionaba para 

    libros que tenían la misma ubicación (dirección) en el mismo disco duro y yo necesito que esto funcione para cualquier ubicación dentro de 

    la red. Por supuesto que verifiqué que la red funciona al 100%.

    Muestro la fórmula que utilicé con la que me funcionó en libros diferentes con la misma ubicación:

    =CONTAR.SI('\\10.241.220.184\Prueba_Control\[LibroA.xlsx]Hoja1'!$A$1:$A$10000,"PERSONAL")

    Agradezco de antemano por la atención que puedan brindarme y me despido enviándoles un saludo.



    Gracias.
    martes, 9 de marzo de 2010 23:29

Respuestas