locked
Error al abrir la consola y el powershells de Exchange 2010 RRS feed

  • Pregunta

  • Hola a todos,

    Me salta un error al intentar abrir tanto la consola como el powershell de exchante.  La instalacion del servidor Exchange es correcta, puedo reiniciar todos los servicios de exchange sin problemas, en el visor de sucesos no idica nada de que no esté funcionando el servidor de correo, pero cuando intento abrir la consola o el powershell me  saca el siguiente error:

    DETALLADO: Conectando a SRVExchange.dominio.es
    [SRVExchange.dominio.es] Error al procesar los datos del servidor remoto. Mensaje de error: El usuario "dominio.es/Users/admin" no está asignado a ninguna función de administración. Para obtener más información, consulte el tema de la Ayuda about_Remote_Troubleshooting.
        + CategoryInfo: OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportException
        + FullyQualifiedErrorId : PSSessionOpenFailed

    Tiene instalado el SP1, mi usuario admin y el servidor exchange estan dentro de los grupos correctos de Organization Managemen y Exchange Server y por más vueltas que le doy no soy capaz de saber que le pasa al servidor.

    Muchas gracias por vuestra ayuda.

    un saludo

    martes, 14 de julio de 2015 8:15

Respuestas

  • ya está solucionado.

    Me faltaban todos los roles, por algun motivo no se instalaron al instalar el Exchange 2010

    y ejecutando el cmdlet se crearon las asignaciones de funciones requeridas entre los grupos de funciones y roles que deberían haber sido creadas durante la instalación.

    Ahora la consola abre y puedo crear mis buzones.

    • Marcado como respuesta AlbertoRioja jueves, 10 de septiembre de 2015 7:41
    jueves, 10 de septiembre de 2015 7:41

Todas las respuestas

  • Estimado,

    Pero el usuario es Admin de Exchange?

    Saludos,


    Edwin Duran Ospina _____________________________________________ Si la respuesta ha sido la solución, favor marcarla.

    martes, 14 de julio de 2015 13:23
  • Te copio la respuesta que puse en el otro hilo ... 

    Hola

    Podrían por favor revisar que el grupo de seguridad de Exchange de nombre "Organization Management" pertenezca al tipo de Grupo "Universal Security Group"  ...  verán que dice "Universal Group | Security Enabled "  ,...  porque universal?  porque por defecto debería ser Universal.,..  no solo ser del dominio...  a veces es parte de un grupo de seguridad del Dominio...  en particular este grupo "Organization Management" deberá ser "Universal".,..  no solo del "Dominio".

    El objeto esta dentro de la OU que se llama Microsoft Exchange Security Groups

    Espero les resulte útil la información

    Saludos!

    • Propuesto como respuesta Moderador M jueves, 16 de julio de 2015 19:34
    • Marcado como respuesta Moderador M viernes, 17 de julio de 2015 14:39
    • Desmarcado como respuesta Moderador M miércoles, 22 de julio de 2015 16:03
    miércoles, 15 de julio de 2015 19:44
  • hola,

    Si que es administrador del exchange, está dentro del grupo de Organization Management.

    Lo que intento es migrar de Exchange 2003 a 2010. He creado un nuevo super usuario, y lo he añadido en la delegacion de exchange 2003, por si tuviera algo que ver.

    El grupo Organization es universal.

    y he actualizado el DA con setup /pl , setup/ps, setup/p y setup /PrepareAllDomain

    La instalacion del exchange la realiza de forma perfecta sin ningun tipo de error.  Solo aparecen errores en l visor de sucesos cuando abro la consola y me indica que no tengo permisos.

    ¿hay alguna forma de saber quien es el usuario maestro en exchange 2003?. puede que venga por ahi el error.

    muchas gracias

    muchas gracias

    miércoles, 22 de julio de 2015 11:37
  • Ya veo..

    Una consulta,

    Obtienes algún error al conectar al server desde una sesión importada de PowerShell?

    http://mikepfeiffer.net/2010/02/managing-exchange-2010-with-remote-powershell/

    $s = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri http://phx-ex01.exchangelab.com/PowerShell/ -Authentication Kerberos o...  también puedes especificar las credenciales.,.,,

    $s = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri http://phx-ex01.exchangelab.com/PowerShell/ -Authentication Kerberos -Credential (Get-Credential)

    y ya luego importas la sesion

    Import-PSSession $s

    Espero ayude..

    Saludos!

    • Propuesto como respuesta Moderador M miércoles, 29 de julio de 2015 16:01
    lunes, 27 de julio de 2015 21:32
  • hola, muhcas gracias por la ayuda

    Me sigue saliendo el mismo error "dominio.es/Users/admin" no está asignado a ninguna función de administración.

    Sin embargo para comprobar si mi usuario admin está realmente dentro del grupo "Organization Management" ejecuto lo siguiente:

    Add-PSSnapin Microsoft.Exchange.Management.PowerShell.E2010

    Get-RoleGroupMember "Organization Management" y como resultado me indica que admin está dentro del grupo, pero la consola no abre, como si tuviera un problema con la autenticacion de kerberos.

    ¿existe alguna sentencia para saber si la autenticacion de kerberos esta funcionando de forma correcta?

    lunes, 7 de septiembre de 2015 7:13
  • Hola,

    Tiene algo que ver con que esté intentando migrar desde un Exchange 2003 a un 2010, de que el usuario que este usando no sea el administrador de Exchange.

    En la consola de Exchange 2003, en las opciones de delagar control, mi usuario admin es administrador total de Exchange y esta dentro del grupo de Organization Managemenet  ¿tiene que ser miembro de algún grupo más?

    muchas gracias.

    lunes, 7 de septiembre de 2015 7:21
  • ya está solucionado.

    Me faltaban todos los roles, por algun motivo no se instalaron al instalar el Exchange 2010

    y ejecutando el cmdlet se crearon las asignaciones de funciones requeridas entre los grupos de funciones y roles que deberían haber sido creadas durante la instalación.

    Ahora la consola abre y puedo crear mis buzones.

    • Marcado como respuesta AlbertoRioja jueves, 10 de septiembre de 2015 7:41
    jueves, 10 de septiembre de 2015 7:41