none
referencia a celdas en formato texto RRS feed

  • Pregunta

  • necesito saber como poder acceder al contenido de una celda, cuya referencia tengo en modo texto, es decir, acceder por ejemplo a la celda que me genera la formula =DIRECCION(8;1), que seria "$A$8", pero me sale en la celda $A$8, y no el contenido.
    O tambien que pueda acceder a las celdas "A8" (sin el $), tambien en texto, por ejemplo por haber concatenado "A" con un numero resultado de una operacion/formula.
    Alguna idea?
    martes, 19 de septiembre de 2006 11:06

Respuestas

  • bueno, encontre otra forma de hacerlo sabiendo solo el indice de linea que se desea y el de columna.
    ejemplo:
    =INDIRECTO(DIRECCION(F3;2))


    en F3 habra la linea deseada y el 2 es la columna deseada.
    • Marcado como respuesta Ismael Borche miércoles, 6 de abril de 2011 14:41
    martes, 19 de septiembre de 2006 14:20
  • Hola Jandro la parte con DIRECCION sobra :-) Prueba las siguientes formulas en orden de mi preferencia:

    Suponiendo que F3=8

    =INDICE($B:$B;F3)

    =INDICE(1:65536;F3;2)

    =INDIRECTO("B"&F3)

    =INDIRECTO(DIRECCION(2;F3))

    Las primeras dos tienen dos ventajas importantes:

    - no son volatiles (solo recalculan cuando es estrictamente necesario)

    - son mas rapidas

    • Marcado como respuesta Ismael Borche miércoles, 6 de abril de 2011 14:41
    martes, 19 de septiembre de 2006 15:22

Todas las respuestas

  • bueno, encontre otra forma de hacerlo sabiendo solo el indice de linea que se desea y el de columna.
    ejemplo:
    =INDIRECTO(DIRECCION(F3;2))


    en F3 habra la linea deseada y el 2 es la columna deseada.
    • Marcado como respuesta Ismael Borche miércoles, 6 de abril de 2011 14:41
    martes, 19 de septiembre de 2006 14:20
  • Hola Jandro la parte con DIRECCION sobra :-) Prueba las siguientes formulas en orden de mi preferencia:

    Suponiendo que F3=8

    =INDICE($B:$B;F3)

    =INDICE(1:65536;F3;2)

    =INDIRECTO("B"&F3)

    =INDIRECTO(DIRECCION(2;F3))

    Las primeras dos tienen dos ventajas importantes:

    - no son volatiles (solo recalculan cuando es estrictamente necesario)

    - son mas rapidas

    • Marcado como respuesta Ismael Borche miércoles, 6 de abril de 2011 14:41
    martes, 19 de septiembre de 2006 15:22