none
error al instalar exchange 2013 RRS feed

  • Pregunta

  • buen dia

    estoy queriendo montar un servidor exchange2013 en windows server 2012 R2, he seguido diversas guias tanto de microsoft como externas pero siempre al momento de instalar me sale el siguiente error al instalar el rol de MailBox

                                                                    

    Error:
    Se ha generado el siguiente error cuando se ejecutó "$error.Clear(); 
                if ($RoleProductPlatform -eq "amd64")
                {
                    $useAttachMode = $false;
                    $fastInstallConfigPath = Join-Path -Path $RoleBinPath -ChildPath "Search\Ceres\Installer";
                    $command = Join-Path -Path $fastInstallConfigPath -ChildPath "InstallConfig.ps1";
                    $fastDefaultDataFolderPath = Join-Path -Path $RoleBinPath -ChildPath "Search\Ceres\HostController\Data";
                    $dataFolderPath = $fastDefaultDataFolderPath;

                    if ([System.IO.Directory]::Exists($fastDefaultDataFolderPath))
                    {
                        $useAttachMode = $true;
                    }
                    else
                    {
                        if ($RoleIsDatacenter -eq $true)
                        {
                            $preferredDataFolderPathRoot = "D:\";
                            if ([System.IO.Directory]::Exists($preferredDataFolderPathRoot))
                            {
                                $dataFolderPath = Join-Path -Path $preferredDataFolderPathRoot -ChildPath "ExchangeSearchData";
                                if ([System.IO.Directory]::Exists($dataFolderPath))
                                {
                                    $useAttachMode = $true;
                                }
                            }
                        }
                    }

                    if ($useAttachMode -eq $true)
                    {
                        &$command -action a -dataFolder $dataFolderPath -silent;
                    }
                    else
                    {
                        try
                        {   
                            &$command -action i -dataFolder $dataFolderPath -silent;
                        }
                        catch
                        {
                            $errorMsg = "Failure running SearchFoundation installconfig.ps1 - " + $_.Exception.Message;
                            Write-ExchangeSetupLog -Error $errorMsg;
                            &$command -action u -silent;
                            try
                            {
                                if ([System.IO.Directory]::Exists($dataFolderPath))
                                {
                                    [System.IO.Directory]::Delete($dataFolderPath, $true);
                                }
                            }
                            catch
                            {
                                $deleteErrorMsg = "Failure cleaning up SearchFoundation Data folder. - " + $dataFolderPath + " - " + $_.Exception.Message;
                                Write-ExchangeSetupLog -Error $deleteErrorMsg;
                            }
                        }
                    }
                }
            ": "Couldn’t attach the data folder 'C:\Program Files\Microsoft\Exchange Server\V15\Bin\Search\Ceres\HostController\Data'. Path doesn’t contain old nodes belonging to the system 'Fsis'.".

    Advertencia:
    Se produjo un error inesperado y se está generando un volcado de Watson: Se ha generado el siguiente error cuando se ejecutó "$error.Clear(); 
                if ($RoleProductPlatform -eq "amd64")
                {
                    $useAttachMode = $false;
                    $fastInstallConfigPath = Join-Path -Path $RoleBinPath -ChildPath "Search\Ceres\Installer";
                    $command = Join-Path -Path $fastInstallConfigPath -ChildPath "InstallConfig.ps1";
                    $fastDefaultDataFolderPath = Join-Path -Path $RoleBinPath -ChildPath "Search\Ceres\HostController\Data";
                    $dataFolderPath = $fastDefaultDataFolderPath;

                    if ([System.IO.Directory]::Exists($fastDefaultDataFolderPath))
                    {
                        $useAttachMode = $true;
                    }
                    else
                    {
                        if ($RoleIsDatacenter -eq $true)
                        {
                            $preferredDataFolderPathRoot = "D:\";
                            if ([System.IO.Directory]::Exists($preferredDataFolderPathRoot))
                            {
                                $dataFolderPath = Join-Path -Path $preferredDataFolderPathRoot -ChildPath "ExchangeSearchData";
                                if ([System.IO.Directory]::Exists($dataFolderPath))
                                {
                                    $useAttachMode = $true;
                                }
                            }
                        }
                    }

                    if ($useAttachMode -eq $true)
                    {
                        &$command -action a -dataFolder $dataFolderPath -silent;
                    }
                    else
                    {
                        try
                        {   
                            &$command -action i -dataFolder $dataFolderPath -silent;
                        }
                        catch
                        {
                            $errorMsg = "Failure running SearchFoundation installconfig.ps1 - " + $_.Exception.Message;
                            Write-ExchangeSetupLog -Error $errorMsg;
                            &$command -action u -silent;
                            try
                            {
                                if ([System.IO.Directory]::Exists($dataFolderPath))
                                {
                                    [System.IO.Directory]::Delete($dataFolderPath, $true);
                                }
                            }
                            catch
                            {
                                $deleteErrorMsg = "Failure cleaning up SearchFoundation Data folder. - " + $dataFolderPath + " - " + $_.Exception.Message;
                                Write-ExchangeSetupLog -Error $deleteErrorMsg;
                            }
                        }
                    }
                }
            ": "Couldn’t attach the data folder 'C:\Program Files\Microsoft\Exchange Server\V15\Bin\Search\Ceres\HostController\Data'. Path doesn’t contain old nodes belonging to the system 'Fsis'.".

    ya intente volviendo a instalar todo el sistema operativo pero nada, he estado revisando pero no encuentro cual puede ser el error, agradeceria si me pudieran dar un norte para ver que es lo que sucede


    miércoles, 28 de febrero de 2018 17:49

Respuestas

Todas las respuestas