none
Hyper-V: ¿problema de red o comportamiento esperado para un conmutador virtual privado? RRS feed

  • Pregunta

  • Hola,

    Tengo separados los equipos físicos y virtuales en subredes distintas, estos últimos están conectados (todos) a un mismo conmutador privado y la salida a internet para esta subred de máquinas virtuales (VMs) la controlo mediante un servidor (virtual) que junto las funciones de servidor DHCP y DNS para dicha subred de VMs también hace de Router LAN entre las dos subredes. Para este último rol el servidor también está conectado a un conmutador externo al que conecto el equipo físico que sirve de host para Hyper-V (con Windows 10 Pro 1809).

    En la subred de VMs tengo conexión a internet, accedo a las carpetas compartidas de ambas subredes (tanto por nombre de máquina como por IP vía 'ejecutar' Win+R) y después de habilitar las reglas para el 'Echo Request -ICMPv4' (el OS de la VM configurada como Router LAN es Windows Server 2016) no pierdo paquetes al realizar 'Test-Connection' en IPs de ambas subredes pero sí que los pierdo al usar los nombres de máquina de la subred física ("...Error debido a falta de recursos").

    Desde la subred física no puedo acceder a las carpetas compartidas de la subred de VMs (ni por nombre ni por IP: error 0x80070035 tras 'ejecutar: \\ip o nombre') y 'Test-Connection' finaliza con error sobre IPs (o nombre de máquinas) de la subred a la que no pertenece (error: ''...Error debido a falta de recursos'').

    Soy nuevo en esto de Hyper-V y hasta ahora mi forma práctica de usar los conmutadores virtuales era pensar en ellos como si precisamente fueran conmutadores pero... ¿lo que me ocurre es el comportamiento esperado en un conmutador privado o hay algún problema con la configuración de red?

    Saludos.
    lunes, 27 de mayo de 2019 0:12

Respuestas

  • Hola DoGonet, hay que separar el tema en dos partes

    1.- Conectividad IP: lo primero a revisar es que el Router que conecta la red de las virtuales con la física (host físico) esté haciendo enrutamiento puro, y no NAT, ya qu esto último justamente oculta las IPs
    Por otro lado lo que seguramente tienes es un problema de enrutamiento. Todas las máquinas tienen definida la Puerta de Enlace, esto es, que todo lo que no sea la red actual, se lo envíen al Router. El problema es que no saben dónde están tus otras redes internas. Esto se puede solucionar pero hay que agregar manualmente entradas en la tabla de enrutamiento, ROUTE /? te da todas las opciones del comando

    2.- Por otra lado está el tema de resolución de nombres. Si hay ambiente de Dominio esto se hace por DNS. Debería haber un servidor que tenga configurados Reenviadores Condicionales para que sepa a qué otro DNS debe reenviarle la resolución de determinados sufijos de Dominio. O si fueran en Grupo de Trabaja habría que poner un WINS y que todas las máquinas se registren en el mismo

     


    Guillermo Delprato
    Buenos Aires, Argentina
    El Blog de los paso a paso

    MCSE - MCSA2012
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration

    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    • Marcado como respuesta DoGoGnet martes, 28 de mayo de 2019 23:14
    • Desmarcado como respuesta DoGoGnet martes, 28 de mayo de 2019 23:54
    • Marcado como respuesta DoGoGnet martes, 28 de mayo de 2019 23:55
    lunes, 27 de mayo de 2019 11:26