none
condicional exel RRS feed

  • Pregunta

  • Hola tengo renglones expresados de esta forma

     

    Descriccion                 criticidad                    ABC

     

    Tornillo                       01                               B

    Pieza                         03                               C

    Destornillador             02                               A

    Motor                         02                               B

    Pintura                       02                               C

    Clavos                        03                               B

    ….                                                                    

     

    Estos no son todos los renglones pero espero q funcione como ejemplo

     

    Lo que quiero saber es que condición puedo usar para saber cuantos renglones hay q tengan en criticidad 01 y ABC= A; criticidad 01 y ABC = B; criticidad 01 y ABC= C;

    Criticidad 02 y ABC=A; Criticidad 02 y ABC=B; Criticidad 02 y ABC=C; Criticidad 03 y ABC=A; Criticidad 03 y ABC=B; Criticidad 03 y ABC=C y que lo muestre en forma de matriz.

     

    01

    02

    03

                A         B         C

    De antemano mil gracias a quien me pueda ayudar…

    martes, 24 de junio de 2008 6:34

Respuestas

  • Hola George,

     

    Supongo que te planteas resolverlo mediante fórmulas, aunque una buena solución sería emplear tablas dinámicas, que son muy potentes para obtener este tipo de información.

     

    Bueno, con fórmulas podrías obtener los resultados que necesitas utilizando la función SUMAPRODUCTO. Por ejemplo, suponiendo que tienes la tabla con los datos en el rango A1:C100. Dado que la Descripción no interviene en tu búsqueda y que la primera columna se reserva para los títulos, el rango queda restringido a B2:C100. Necesitas saber (por ejemplo) el número de Ítems que tienen una criticidad de 2 y un ABC de A. Puedes usar:

     

    =SUMAPRODUCTO((B2:B100=2)*(C2:C100="A"))

     

    Prueba a ver si es lo que necesitas y repregunta si te queda alguna duda.

     

    Saludos,

    Ramon

    martes, 24 de junio de 2008 14:38