none
Problema con cambio de servidor W2003 RRS feed

  • Pregunta

  • Hola,

    En mi empresa hemos tenido que cambiar el servidor (un windows 2003 server standard) porqué el hardware estaba ya obsoleto. Después de mucho leer, me decidi por el siguiente procedimiento:

    - Instalar el mismo windows 2003 server standard en el servidor nuevo, con todos los parches de seguridad y service pack 2.
    - Ejecutar dcpromo y hacerlo controlador de dominio adicional
    - Instalar servidor DNS
    - Hacer que sea catalogo global
    - Transferirle los 5 roles FSMO
    Todo esto lo realicé sin ningún error ni problema. Después para probar cambié las dns en 2 pc's que apuntaban al servidor viejo y les puse la ip del servidor nuevo. Apagué el servidor viejo, comprobé estos dos pc's en concreto y ninguno de los 2 podia navegar. Ejecuté SET en una ventana de comandos en los 2 pc's y el logonserver me lo daba contra el servidor viejo.
    No entiendo que puede estar pasando, que paso me he dejado? He hecho algo incorrecto? Ahora tengo la red funcionando, pero sólo si los dos servers están en marcha. La idea es dejar la red solamente con el server nuevo y el viejo formatearlo. Alguna idea de que es lo me puede estar fallando?

    Muchas gracias
    jueves, 10 de julio de 2008 14:29

Todas las respuestas

  • Hola !!!!

    Todo lo que hiciste está bien. Creo que el problema es que los DNS no han replicado, Comprueba que en la maquina nueva el DNS tiene todo la información necesaria. Si en el DNS de segundo server sólo están las referencias al primero, ese es tu problema.

     

    Saludos !!!!

    http://www.itpropuebla.net

    http://ocorreas.spaces.live.com

    ----------------------------------------------

    Recuerden siempre seleccionar "SI" (donde dice ¿Ha resultado útil este mensaje?) en caso de que su duda se resuelva con alguna de las recomendaciones de los foristas.

     

    jueves, 10 de julio de 2008 14:51
  • Hola Oscar, Gracias por responder.

    Me podrias explicar exactamente que es lo que tengo que mirar en el servidor nuevo sobre las DNS.

    Habria alguna manera de volver a configurar de nuevo el servidor de DNS por si hubiera algun problema con ello?


    Gracias

    jueves, 10 de julio de 2008 15:36
  • Hola !!!

     

    En ambos DNS debes tener la misma información, que incluye:

     

    - Una "ZONA FORWARD" que se llama _msdcs.tudominio.algo
    - deben existir debajo de esa ZONA las siguientes entradas:

     DC
     DOMAINS
     GC
     PDC

    - Debajo por ejemplo de DC debe existir "_tcp" y ahi adentro dos referencias a "_kerberos" y "_ldap" una para cada server que tienes.

     

    Si en estas entradas solo hace referencia a tu server anterior, quiere decir que las maquinas no conocen todavía la existencia del nuevo server, por eso a pesar de que tiene AD, dependes todavía del primer server


    Si gustas en mi blog hay un video de algo parecido a lo que tú hiciste, sólo que de Windows 2000 a Windows 2003, para el problema que tú tienes, creo que te podría servir echarle un ojo.

     

    http://ocorreas.spaces.live.com/blog/cns!42E469AC54FA2F26!278.entry

     

     

    Saludos !!!!

     

    http://www.itpropuebla.net
    http://ocorreas.spaces.live.com
    ----------------------------------------------
    Recuerden siempre seleccionar "SI" (donde dice ¿Ha resultado útil este mensaje?) en caso de que su duda se resuelva con alguna de las recomendaciones de los foristas.

     

    jueves, 10 de julio de 2008 17:44
  • Gracias Oscar,

    En cuanto pueda consultar las recomendaciones que me has dado te comento el resultado.

    Saludos

    jueves, 10 de julio de 2008 18:00
  • Hola,

     

    He mirado todo el tema de las DNS y estan tal como me comentabas que tenian que estar. Después de revisar varias cosas me he dado cuenta que el servidor antiguo tiene las carpetas compartidas Sysvol y Netlogon, que en el servidor nuevo no estan compartidas (Sysvol) y Netlogon no existe. Es posible que el problema de que si apago el server antiguo los pc's no puedan iniciar sesión en el dominio (inician sesion con el perfil local) venga provocado por este motivo?

     

    En caso afirmativo, como puedo solucionar el problema?

     

    Saludos

     

     

    domingo, 13 de julio de 2008 19:08
  • Revisa este artículo: http://support.microsoft.com/?id=315457
    domingo, 13 de julio de 2008 20:38
  • Hola,

     

    He revisado el link de tu respuesta y después de leer el artículo entero varias veces me surge una duda:

     

    4. Reinicie FRS en el controlador de dominio de referencia con el valor del Registro establecido en D4.
    5. Reinicie el FRS en los demás controladores de dominio del dominio con el valor del Registro establecido en D2.

     

    De los dos servidores que ahora mismo tengo funcionando, uno nuevo y uno antiguo, ¿cúal seria el de referencia?

    Porqué teniendo en cuenta que ahora mismo, el servidor antiguo es el único que tiene las carpetas Sysvol y Netlogon y que cuando todo funcione correctamente, lo apagaré y formatearé. Pues no sé cual escoger.

    ¿Qué os parece?

     

    Saludos

     

     

     

    lunes, 14 de julio de 2008 15:12