none
Migración SBS2003 a SBS2011 - Problemas con los perfiles de usuarios RRS feed

  • Pregunta

  • Hola a todos,

    He realizado una migración desde SBS2003 a SBS2011 STD y en general parece funcionar bien.
    El problema que tengo es que los usuarios, en sus máquinas XP y W7, no pueden usar sus perfiles locales.
    Cuando inician sesión en sus máquines, después de entrar usuario y contraseña, aparece un cuadro de dialogo que dice:

    "Windows no puede encontrar el perfil local y está iniciando la sesión con un perfil temporal. Los cambios que se efectúen en este perfil se perderán cuando se cierre la sesión."

    Para unir los equipos al dominio he utilizado el asistente: http://connect.

    En el visor de eventos de los PC, aparece este:

    Nombre de registro:System
    Origen:        Microsoft-Windows-GroupPolicy
    Fecha:         01/12/2011 5:58:49
    Id. del evento:1065
    Categoría de la tarea:Ninguno
    Nivel:         Error
    Palabras clave:
    Usuario:       DOMINIO\Usuario
    Equipo:        EQUIPO-C.DOMINIO.local
    Descripción:
    Error al procesar la directiva de grupo. Windows no puede evaluar el filtro del Instrumental de administración de Windows (WMI) para el objeto de directiva de grupo CN={04167066-6589-4CE0-A866-92FA285E28BE},CN=POLICIES,CN=SYSTEM,DC=DOMINIO,DC=LOCAL. Esto se puede deber a que RSoP está deshabilitado o a que el servicio Instrumental de administración de Windows (WMI) está deshabilitado, detenido o presenta otros errores. Asegúrese de que el servicio Instrumentación de administración de Windows se haya iniciado y de que el tipo de inicio esté establecido como "automático". Los objetos o la configuración de la nueva directiva de grupo no se procesarán hasta que se haya resuelto este evento.
    XML de evento:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-GroupPolicy" Guid="{AEA1B4FA-97D1-45F2-A64C-4D69FFFD92C9}" />
        <EventID>1065</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>1</Opcode>
        <Keywords>0x8000000000000000</Keywords>
        <TimeCreated SystemTime="2011-12-01T04:58:49.591968400Z" />
        <EventRecordID>15748</EventRecordID>
        <Correlation ActivityID="{84950048-2DB2-4A96-9B15-7CBF2523A855}" />
        <Execution ProcessID="492" ThreadID="2120" />
        <Channel>System</Channel>
        <Computer>EQUIPO-C.DOMINIO.local</Computer>
        <Security UserID="S-1-5-21-3665357212-564636439-3446883858-1183" />
      </System>
      <EventData>
        <Data Name="SupportInfo1">4</Data>
        <Data Name="SupportInfo2">631</Data>
        <Data Name="ProcessingMode">1</Data>
        <Data Name="ProcessingTimeInMilliseconds">1311</Data>
        <Data Name="ErrorCode">2147749890</Data>
        <Data Name="ErrorDescription">
        </Data>
        <Data Name="DCName">\\SERVIDOR.DOMINIO.local</Data>
        <Data Name="GPOCNName">CN={04167066-6589-4CE0-A866-92FA285E28BE},CN=POLICIES,CN=SYSTEM,DC=DOMINIO,DC=LOCAL</Data>
      </EventData>
    </Event>

     

    En el visor de eventos del servidor SBS2011, aparece este:

    Nombre de registro:System
    Origen:        Microsoft-Windows-GroupPolicy
    Fecha:         01/12/2011 5:38:44
    Id. del evento:1065
    Categoría de la tarea:Ninguno
    Nivel:         Error
    Palabras clave:
    Usuario:       SYSTEM
    Equipo:        SERVIDOR.DOMINIO.local
    Descripción:
    Error al procesar la directiva de grupo. Windows no puede evaluar el filtro del Instrumental de administración de Windows (WMI) para el objeto de directiva de grupo CN={04167066-6589-4CE0-A866-92FA285E28BE},CN=POLICIES,CN=SYSTEM,DC=DOMINIO,DC=LOCAL. Esto se puede deber a que RSoP está deshabilitado o a que el servicio Instrumental de administración de Windows (WMI) está deshabilitado, detenido o presenta otros errores. Asegúrese de que el servicio Instrumentación de administración de Windows se haya iniciado y de que el tipo de inicio esté establecido como "automático". Los objetos o la configuración de la nueva directiva de grupo no se procesarán hasta que se haya resuelto este evento.
    XML de evento:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-GroupPolicy" Guid="{AEA1B4FA-97D1-45F2-A64C-4D69FFFD92C9}" />
        <EventID>1065</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>1</Opcode>
        <Keywords>0x8000000000000000</Keywords>
        <TimeCreated SystemTime="2011-12-01T04:38:44.310464200Z" />
        <EventRecordID>16395</EventRecordID>
        <Correlation ActivityID="{01744FC8-D2BC-43E2-8A99-EDC27EA55FF3}" />
        <Execution ProcessID="960" ThreadID="6336" />
        <Channel>System</Channel>
        <Computer>SERVIDOR.DOMINIO.local</Computer>
        <Security UserID="S-1-5-18" />
      </System>
      <EventData>
        <Data Name="SupportInfo1">4</Data>
        <Data Name="SupportInfo2">631</Data>
        <Data Name="ProcessingMode">0</Data>
        <Data Name="ProcessingTimeInMilliseconds">578</Data>
        <Data Name="ErrorCode">2147749890</Data>
        <Data Name="ErrorDescription">
        </Data>
        <Data Name="DCName">\\SERVIDOR.DOMINIO.local</Data>
        <Data Name="GPOCNName">CN={04167066-6589-4CE0-A866-92FA285E28BE},CN=POLICIES,CN=SYSTEM,DC=DOMINIO,DC=LOCAL</Data>
      </EventData>
    </Event>

    He revisado en el servidor, que el servicio Instrumentación de administración de Windows está activado, y en automático.

    ¿Alguien sabe donde puedo encontrar una solución para este problema?.

    Gracias por anticipado.


    Tomas
    jueves, 1 de diciembre de 2011 6:31

Respuestas

  • Revisa en regedit en HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\ProfileList las subclaves que aparecen (el nombre corresponde a los SIDs de los usuarios), para ver a qué a carpeta apuntan con el valor ProfileImagePath; si no es la correcta modificalo para que apunte a la correcta, revisa (y corrige si es necesario) que el usuario sea propietario de esa carpeta y que tenga permiso de control total y haz que el usuario reinicie sesión.

    Un saludo

    Fernando Reyes [MS MVP]
    MCSA 2000/2003
    MCSE 2000/2003
    MCITP EnterpriseAdministrator
    Web: http://freyes.svetlian.com
    Blog: http://urpiano.wordpress.com
    RSS: http://urpiano.wordpress.com/feed/
    freyes.champú@champú.mvps.org
    (Aclárate la cabeza si quieres escribirme)
    • Marcado como respuesta Tomas-Msdn viernes, 2 de diciembre de 2011 19:46
    jueves, 1 de diciembre de 2011 11:26
    Moderador

Todas las respuestas

  • Pues tiene toda la pinta de que han perdido la propiedad y los permisos en sus perfiles. Haz la prueba de darle la propiedad sobre su carpeta de perfil a un usuario y de darle permisos de control total (ambas cosas deben ser propagadas desde la carpeta del perfil a las demás) y que pruebe a iniciar sesión a ver si así le deja.
    Un saludo

    Fernando Reyes [MS MVP]
    MCSA 2000/2003
    MCSE 2000/2003
    MCITP EnterpriseAdministrator
    Web: http://freyes.svetlian.com
    Blog: http://urpiano.wordpress.com
    RSS: http://urpiano.wordpress.com/feed/
    freyes.champú@champú.mvps.org
    (Aclárate la cabeza si quieres escribirme)
    jueves, 1 de diciembre de 2011 8:31
    Moderador
  • Hola Fernando,

    He revisado la carpeta Documents and Settings del PC del usuario, y no aparece una carpeta con su nombre para darle los permisos de control total, en su lugar aparece una larga lista de carpetas, una por cada vez que se ha iniciado sesión en el PC, los nombres de las carpetas tienen el formato TEMP.DOMINIO.000 y el 000 se va incrementando en + 1.

    ¿Estoy mirando en el sitio equivocado, o debo hacer algo extra para solventar el problema?.

    Gracias,


    Tomas
    • Editado Tomas-Msdn viernes, 2 de diciembre de 2011 19:50
    jueves, 1 de diciembre de 2011 10:24
  • Revisa en regedit en HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\ProfileList las subclaves que aparecen (el nombre corresponde a los SIDs de los usuarios), para ver a qué a carpeta apuntan con el valor ProfileImagePath; si no es la correcta modificalo para que apunte a la correcta, revisa (y corrige si es necesario) que el usuario sea propietario de esa carpeta y que tenga permiso de control total y haz que el usuario reinicie sesión.

    Un saludo

    Fernando Reyes [MS MVP]
    MCSA 2000/2003
    MCSE 2000/2003
    MCITP EnterpriseAdministrator
    Web: http://freyes.svetlian.com
    Blog: http://urpiano.wordpress.com
    RSS: http://urpiano.wordpress.com/feed/
    freyes.champú@champú.mvps.org
    (Aclárate la cabeza si quieres escribirme)
    • Marcado como respuesta Tomas-Msdn viernes, 2 de diciembre de 2011 19:46
    jueves, 1 de diciembre de 2011 11:26
    Moderador
  • Vale, veo que en el registro hay una serie de SIDs, y ninguno de ellos contiene la ruta hacia la carpeta del usuario.

    Hay uno que apunte a una carpeta TEMP.DOMINIO.011, quue supongo debe ser la carpeta con la que yo he iniciado sesión en el PC.

    Resumiendo, en el registro no tengo ninguna entrada que haga referencia a la carpeta del usuario, y dentro de  Documents and Settings, tampo tengo ninguna una carpeta con el nombre del usuario.

    Creía que cuando se hacia http://Connect, se creaba en  Documents and Settings, la carpeta del usuario que estabas indicando en este asistente, pero, o no es asi, o falla algun paso.

    ¿Que puedo hacer para crear esa carpeta del usuario en Documents and Settings y que coga su configuración del servidor SBS2011?

    Gracias.


    Tomas
    jueves, 1 de diciembre de 2011 12:02
  • Tienes que identificar el SID del usuario y ver en qué carpeta tiene asignado el perfil en ProfileList. Si no es la que debe, cambiar eser valor en el registro y asignas la carpeta que deba tener en Document and settings, comprobando que sea propietario y tenga control total.

    De todas maneras esa migración que dices que ha hecho ¿qué implica, nuevo dominio? Si es así ¿Has unido al equipo cliente al nuevo dominio?


    Un saludo

    Fernando Reyes [MS MVP]
    MCSA 2000/2003
    MCSE 2000/2003
    MCITP EnterpriseAdministrator
    Web: http://freyes.svetlian.com
    Blog: http://urpiano.wordpress.com
    RSS: http://urpiano.wordpress.com/feed/
    freyes.champú@champú.mvps.org
    (Aclárate la cabeza si quieres escribirme)
    jueves, 1 de diciembre de 2011 13:52
    Moderador
  • La migración se ha hecho desde SBS2003 a SBS2011, usando la modalidad que ofrece el producto, de elegir migración, en lugar de instalación nueva.

    Los equipos cliente, estaban en SBS2003, unidos todos al dominio.

    Al terminar la migración del servidor, fui de equipo en equipo, y usando una cuenta de administrador del nuevo dominio, inicié el asistente http://connect y procedí a seguir las instrucciones para unir el equipo al nuevo dominio SBS2011.

    Lo que ahora no me está funcionando, es lo explicado en el hilo del perfil de usuario y otro tema que es, que la carpeta de Mis documentos del usuario, sigue apuntando al antiguo servidor SBS2003, en lugar de apuntar al nuevo servidor SBS2011, para sincronizar los documentos, y esto último me muestra un mensaje de error que me dice que no encuentra la ruta del anterior servidor, con toda la razón, porque ya no está en la red.

    De esto último también estoy buscando información en Internet.

    Ahora voy a mirar esto último del perfil, que me has comentado en tu respuesta.

    Gracias por tu amabilidad y seguir este hilo.


    Tomas
    jueves, 1 de diciembre de 2011 17:51
  • Pues le llamará migración, pero todo parece apuntar a que hace un dominio nuevo, si sólo fuese una migración no habría que unir los equipos al dominio de 2011, eso implica que se trata de un nuevo dominio. Supongo que habrás echado un vistazo a ésto antes de nada ¿no?:

    Migrate to Windows Small Business Server 2011 Standard from Windows Small Business Server 2003
    http://technet.microsoft.com/en-us/library/gg563801.aspx


    Un saludo

    Fernando Reyes [MS MVP]
    MCSA 2000/2003
    MCSE 2000/2003
    MCITP EnterpriseAdministrator
    Web: http://freyes.svetlian.com
    Blog: http://urpiano.wordpress.com
    RSS: http://urpiano.wordpress.com/feed/
    freyes.champú@champú.mvps.org
    (Aclárate la cabeza si quieres escribirme)
    viernes, 2 de diciembre de 2011 7:23
    Moderador
  • Efectivamente, este guión es el que he seguido paso a paso.

    Hay un documento para imprimir en este sitio: http://www.microsoft.com/download/en/details.aspx?id=14570.

    Voy a seguir depurando los flecos que me quedan por solventar.

    Gracias de nuevo.

     

     


    Tomas
    viernes, 2 de diciembre de 2011 19:44
  • Tomas

     

    Disculpa la intromisión, estoy en proceso de realizar la misma migración (sbs 2003std a sbs 2011std) y me dejaste preocupado con tu problema (perfiles). Lo pudiste solucionar bien ?

    cual fue el problema ?

    Gracias

    Christian

     

    lunes, 16 de enero de 2012 15:04
  • Hola Insoch,


    Pues la verdad es que después de intentar solucionar, sin éxito, el problema con los perfiles, me encontraba con problemas para sincronizar las carpetas de los clientes con el servidor, porque seguía buscando en el servidor anterior, el SBS2003.


    Todavía hoy tengo que encontrar una solución para limpiar la "suciedad" de los PC de los clientes para quitar de la sincronización de las carpetas, el anterior servidor SBS2003, porque esto provoca un error en los usuarios cuando encienden y apagan las máquinas, al intentar sincronizar con un servidor que ya no existe.


    Al final, y debido a las "pequeñas cosas", que aparecían a cada paso que daba en el proceso de configuración, pero que provocaban una pérdida de tiempo importante en buscar soluciones, opté por cortar por lo sano, y decidí parar y realizar una nueva instalación del servidor, en este caso como una instalación nueva, limpia.


    El proceso fue perfecto, desaparecieron los problemas que aparecieron con la migración, salvo la suciedad que me quedó en los PC, con lo comentado de la sincronización de las carpetas.


    No descarto que el problema haya sido mio, al no entender bien el proceso de migración, y no hacer algún paso de la forma correcta, pero visto el estado actual del servidor, comparado con como me quedó después de la migración, no hay color. El servidor queda limpio, sin heredar historias del SBS2003 y más estable que como quedó con la migración.


    No tengo autoridad técnica para recomendarte nada, soy aprendiz de esto, pero si tienes pocos PC, en mi caso poco más de 20, y no tienes muchas configuraciones especiales con tus clientes, plantéate hacer una instalación limpia. Cuesta un poco más de trabajo, pero, en mi caso, al final, duermes más tranquilo.

    Saludos.


    Tomas
    lunes, 16 de enero de 2012 16:59
  • YO TENGO UNA PREGUNTA SI AL CREAR UN NUEVO DOMINIO CON EL NOMBRE DISTINTO AL QUE TENIA EN EL SBS2003. Y EN EL SBS2011 AL YO IRME AL COMPUTADOR DEL CLIENTE FINAL. QUE SE DEBE HACEr? me explico.. el equipo cliente esta dentro del dominio CALIANZA.COOP yo quiero meter ese equipo al dominio nuevo que es ALIANZA.COOP PERO SIN AFECTAR EL SETTINGS DEL USUARIO SE PUEDE HACER?
    viernes, 15 de junio de 2012 18:29
  • Hola Marduk48,

    En mi caso, como tengo pocos PC, antes de instalar el nuevo servidor con el nuevo dominio, quité todos los PC del dominio SBS2003, dejándolos en grupo de trabajo.

    Lógicamente, antes de quitar los PC del dominio, hice copia de seguridad dentro de cada PC, de sus carpetas sincronizadas con el servidor, los buzones de correo si fuese necesario, y cualquier otro dato o configuración que pudiera perder al sacar el PC del dominio.

    Luego, al instalar el nuevo servidor, volví a unir los PC al nuevo dominio SBS2011, coloqué las copias en su sitio, recuperé los buzones de correo y ajusté las configuraciones de cada PC según su uso.

    Hacer esto es largo y entretenido, pero al final todo funcionó perfectamente.

    Saludos.


    Tomas

    sábado, 16 de junio de 2012 11:03
  • Gracias, no te habia contestado, al igual que tu decidí hacer una instalacion limpia.

    Gracias nuevamente.

    Christian

    martes, 14 de agosto de 2012 19:00