locked
Pantallazo azul recurrente. Problemas con el kernel de Windows 7 RRS feed

  • Pregunta

  • Hola. Desde que instalé W7 x64 Ultimate estoy teniendo pantallazos azules recurrentes. No siguen un patrón lógico. A veces me saltan cuando navego, otras cuando juego, otras sin tocar nada... es un caos.

    Instalé windbg para ver si podía dar con la solución pero sinceramente me pierdo entre tanta historia xD

    A ver si alguien que entienda del tema puede aclararme algo de estos datos sobre mi último pantallazo

     

    Loading Dump File [D:\Usuarios\Mithrandir\Desktop\dump\MEMORY.DMP]
    Kernel Summary Dump File: Only kernel address space is available
    
    Symbol search path is: SRV*c:\websymbols*http://msdl.microsoft.com/download/symbols
    Executable search path is: 
    Windows Vista Kernel Version 7600 MP (4 procs) Free x64
    Product: WinNt, suite: TerminalServer SingleUserTS
    Built by: 7600.16385.amd64fre.win7_rtm.090713-1255
    Kernel base = 0xfffff800`02c61000 PsLoadedModuleList = 0xfffff800`02e9ee50
    Debug session time: Mon Nov 21 02:02:04.397 2011 (GMT+1)
    System Uptime: 0 days 11:05:41.647
    Loading Kernel Symbols
    ............................................................................................................................................................
    Loading User Symbols
    
    Loading unloaded module list
    ........
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    Use !analyze -v to get detailed debugging information.
    
    BugCheck 7E, {ffffffffc0000005, fffff80002ce24f5, fffff8800330f658, fffff8800330eeb0}
    
    Probably caused by : ntkrnlmp.exe ( nt!FsRtlAcquireFileForModWriteEx+40 )
    
    Followup: MachineOwner
    ---------
    
    3: kd> !analyze -v
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    SYSTEM_THREAD_EXCEPTION_NOT_HANDLED (7e)
    This is a very common bugcheck.  Usually the exception address pinpoints
    the driver/function that caused the problem.  Always note this address
    as well as the link date of the driver/image that contains this address.
    Arguments:
    Arg1: ffffffffc0000005, The exception code that was not handled
    Arg2: fffff80002ce24f5, The address that the exception occurred at
    Arg3: fffff8800330f658, Exception Record Address
    Arg4: fffff8800330eeb0, Context Record Address
    
    Debugging Details:
    ------------------
    
    
    EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - La instrucci n en 0x%08lx hace referencia a la memoria en 0x%08lx. La memoria no se pudo %s.
    
    FAULTING_IP: 
    nt!IoGetRelatedDeviceObject+15
    fffff800`02ce24f5 488b4818        mov     rcx,qword ptr [rax+18h]
    
    EXCEPTION_RECORD:  fffff8800330f658 -- (.exr fffff8800330f658)
    ExceptionAddress: fffff80002ce24f5 (nt!IoGetRelatedDeviceObject+0x0000000000000015)
       ExceptionCode: c0000005 (Access violation)
      ExceptionFlags: 00000000
    NumberParameters: 2
       Parameter[0]: 0000000000000000
       Parameter[1]: ffffffffffffffff
    Attempt to read from address ffffffffffffffff
    
    CONTEXT:  fffff8800330eeb0 -- (.cxr fffff8800330eeb0)
    rax=fffefa80050e8030 rbx=0000000000000000 rcx=fffffa8007d5f070
    rdx=fffffa8007d5f070 rsi=0000000000000153 rdi=fffffa8007d5f070
    rip=fffff80002ce24f5 rsp=fffff8800330f898 rbp=fffffa80070fd8d0
     r8=fffffa8006f0c268  r9=fffffa8000000000 r10=fffff8800330fbe8
    r11=0000000000000000 r12=fffffa8007d5f070 r13=fffffa80061acd00
    r14=fffffa8006f0c268 r15=fffff8800330f8d0
    iopl=0         nv up ei ng nz na po nc
    cs=0010  ss=0000  ds=002b  es=002b  fs=0053  gs=002b             efl=00010286
    nt!IoGetRelatedDeviceObject+0x15:
    fffff800`02ce24f5 488b4818        mov     rcx,qword ptr [rax+18h] ds:002b:fffefa80`050e8048=????????????????
    Resetting default scope
    
    DEFAULT_BUCKET_ID:  VISTA_RC
    
    PROCESS_NAME:  System
    
    CURRENT_IRQL:  0
    
    ERROR_CODE: (NTSTATUS) 0xc0000005 - La instrucci n en 0x%08lx hace referencia a la memoria en 0x%08lx. La memoria no se pudo %s.
    
    READ_ADDRESS: unable to get nt!MmNonPagedPoolExpansionStart
     ffffffffffffffff 
    
    BUGCHECK_STR:  0x7E
    
    LAST_CONTROL_TRANSFER:  from fffff80002d09b54 to fffff80002ce24f5
    
    STACK_TEXT:  
    fffff880`0330f898 fffff800`02d09b54 : fffffa80`039a5570 fffff800`02d09e33 00000000`00000000 00000000`00000000 : nt!IoGetRelatedDeviceObject+0x15
    fffff880`0330f8a0 fffff800`02d099e8 : 00000000`05700000 fffff880`0330fbe8 00000000`00000000 fffffa80`0040e900 : nt!FsRtlAcquireFileForModWriteEx+0x40
    fffff880`0330fb50 fffff800`02d0a258 : 00000000`00000000 fffffa80`06f0c220 fffffa80`00000000 fffff8a0`0b7cb000 : nt!MiGatherMappedPages+0x6c4
    fffff880`0330fc50 fffff800`02f76166 : fffffa80`039f3530 00000000`00000080 fffffa80`039d39e0 00000000`00000000 : nt!MiMappedPageWriter+0x198
    fffff880`0330fd40 fffff800`02cb1486 : fffff800`02e4be80 fffffa80`039f3530 fffff800`02e59c40 00000000`00000000 : nt!PspSystemThreadStartup+0x5a
    fffff880`0330fd80 00000000`00000000 : fffff880`03310000 fffff880`0330a000 fffff880`0330f8d0 00000000`00000000 : nt!KxStartSystemThread+0x16
    
    
    FOLLOWUP_IP: 
    nt!FsRtlAcquireFileForModWriteEx+40
    fffff800`02d09b54 498bcc          mov     rcx,r12
    
    SYMBOL_STACK_INDEX:  1
    
    SYMBOL_NAME:  nt!FsRtlAcquireFileForModWriteEx+40
    
    FOLLOWUP_NAME:  MachineOwner
    
    MODULE_NAME: nt
    
    IMAGE_NAME:  ntkrnlmp.exe
    
    DEBUG_FLR_IMAGE_TIMESTAMP:  4a5bc600
    
    STACK_COMMAND:  .cxr 0xfffff8800330eeb0 ; kb
    
    FAILURE_BUCKET_ID:  X64_0x7E_nt!FsRtlAcquireFileForModWriteEx+40
    
    BUCKET_ID:  X64_0x7E_nt!FsRtlAcquireFileForModWriteEx+40
    
    Followup: MachineOwner
    


    Eso es lo que me dice el windbg. El problema parece estar en un archivo del kernel llamado ntkrnlmp.exe, pero ni idea de qué lo puede provocar. A ver si me podéis echar una mano.

    Gracias por adelantado.

    lunes, 21 de noviembre de 2011 5:04

Respuestas

  • Gracias por responder.

    Sería raro que fuera un problema físico porque el PC tiene menos de un mes, con todos los componentes comprados de primera mano.

    El HD ha pasado un control del fabricante y no ha reportado problemas, al igual que la memoria. La gráfica y el procesador ya digo que son nuevos, al igual que la placa base.

    Por lo que voy leyendo es un problema muy serio porque no está para nada definido. Puede ser problema de hardware, software, bios, de virus... vamos, de cualquier cosa. Creo que estoy muy jodido, no?


    Ten en cuenta que aun nuevo, puede ser físico, por daño tal vez la probabilidad sea baja, pero está también la compatibilidad entre hardware por ejemplo.

    ¿Desde cuánto tiempo después de comprado el equipo empezó a suceder? Puedes empezar por hacer una actualización de tu firmware, es decir, de BIOS.


    lunes, 21 de noviembre de 2011 18:54

Todas las respuestas

  • Hola, cuando sucede esto, varias veces y por diferentes posibles razones, el problema puede ser físico, es decir, puede estar en memoria, energía, disco duro, etc y el camino sería analizar cada uno.
    lunes, 21 de noviembre de 2011 11:23
  • Gracias por responder.

    Sería raro que fuera un problema físico porque el PC tiene menos de un mes, con todos los componentes comprados de primera mano.

    El HD ha pasado un control del fabricante y no ha reportado problemas, al igual que la memoria. La gráfica y el procesador ya digo que son nuevos, al igual que la placa base.

    Por lo que voy leyendo es un problema muy serio porque no está para nada definido. Puede ser problema de hardware, software, bios, de virus... vamos, de cualquier cosa. Creo que estoy muy jodido, no?

    lunes, 21 de noviembre de 2011 16:56
  • Gracias por responder.

    Sería raro que fuera un problema físico porque el PC tiene menos de un mes, con todos los componentes comprados de primera mano.

    El HD ha pasado un control del fabricante y no ha reportado problemas, al igual que la memoria. La gráfica y el procesador ya digo que son nuevos, al igual que la placa base.

    Por lo que voy leyendo es un problema muy serio porque no está para nada definido. Puede ser problema de hardware, software, bios, de virus... vamos, de cualquier cosa. Creo que estoy muy jodido, no?


    Ten en cuenta que aun nuevo, puede ser físico, por daño tal vez la probabilidad sea baja, pero está también la compatibilidad entre hardware por ejemplo.

    ¿Desde cuánto tiempo después de comprado el equipo empezó a suceder? Puedes empezar por hacer una actualización de tu firmware, es decir, de BIOS.


    lunes, 21 de noviembre de 2011 18:54
  • Puede que sea problema de hardware, como comenta Sergio, aunque sea nuevo puede fallar. Aunque también cabe la posibilidad de que sea algun driver, ya que comentas que instalaste w7 x64 y desde ahí tienes problemas. Comprueba esto desde el Administrador de Dispositivos, haber si sale algun triangulo de advertencia o si le falta algun driver.
    martes, 22 de noviembre de 2011 9:25