none
Error en IIS 7 en aplicación mixta: ASP + ASP.NET RRS feed

  • Pregunta

  • Hola, he creado un nuevo sitio web en mi IIS7 en el que ejecuto una aplicación que tiene mezcla de ASP y de ASP.NET.

    Todo va más o menos bien pero ocurre un error en todos los navegadores menos Firefox (Chrome, Safari e Internet Explorer): en la página de login, cuando hago login a continuación de haber salido se queda esperando indefinidamente. Si recargo la página (F5) y vuelvo a intentarlo funciona correctamente.

    Esta página hace uan coenxión a BD para contrastar el usuario y fija varias variables de sesión y aplicación. ¿Alguna idea de qué puede estar fallando? Si paso la aplicación al sitio web por defecto todo funciona perfectamente, he comparado las configuraciones apartado por apartado y parece que todo está igual...

    El log de IIS:

    #Software: Microsoft Internet Information Services 7.5
    #Version: 1.0
    #Date: 2010-12-31 07:17:02
    #Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status time-taken
    2010-12-31 07:17:02 ::1 GET /miaplicacion/admin/ - 81 - ::1 Mozilla/5.0+(Windows;+U;+Windows+NT+6.1;+es-ES)+AppleWebKit/531.22.7+(KHTML,+like+Gecko)+Version/4.0.5+Safari/531.22.7 200 0 0 3135
    2010-12-31 07:17:04 ::1 GET /miaplicacion/admin/login.asp - 81 - ::1 Mozilla/5.0+(Windows;+U;+Windows+NT+6.1;+es-ES)+AppleWebKit/531.22.7+(KHTML,+like+Gecko)+Version/4.0.5+Safari/531.22.7 200 0 0 38
    2010-12-31 07:19:31 ::1 POST /miaplicacion/admin/usuario_validar.asp - 81 - ::1 Mozilla/5.0+(Windows;+U;+Windows+NT+6.1;+es-ES)+AppleWebKit/531.22.7+(KHTML,+like+Gecko)+Version/4.0.5+Safari/531.22.7 400 0 64 126622
    2010-12-31 07:21:41 ::1 POST /miaplicacion/admin/usuario_validar.asp - 81 - ::1 Mozilla/5.0+(Windows;+U;+Windows+NT+6.1;+es-ES)+AppleWebKit/531.22.7+(KHTML,+like+Gecko)+Version/4.0.5+Safari/531.22.7 400 0 64 129938

    Gracias

    viernes, 31 de diciembre de 2010 8:27