none
Error al subir archivos grandes RRS feed

  • Pregunta

  • Hola a todos.

    Tengo un Sharepoint Foundation 2010 al cual intento subir un archivo de unos 400MB.

    Tras buscar información, he subido el límite de carga de archivos en la administración central a 1GB.

    También he subido el maxRequestLength, incluso el executionTimeout del IIS, pero aún así, no puedo subir dicho archivo.

    El error que me aparece es:


    Error

    La
    dirección URL 'xxxxx/xxxxxxx' no es válida.
    Puede que haga referencia a una carpeta o un archivo que no existe, o a una
    carpeta o un archivo válido que no está en el sitio web actual.

    Solucionar
    problemas de Microsoft SharePoint Foundation.

    Identificador de correlación:
    5c75e950-edbc-4bcf-b7be-74ecc986972d

    Fecha y hora: 11/03/2014
    10:09:30

    Tras mirar el log, encuentro esta línea con el id del error, que tampoco da más pistas sobre la causa:

    03/11/2014 10:07:04.52  w3wp.exe (0x2210)                        0x110C SharePoint Foundation          Logging Correlation Data       xmnv Medium   Name=Request (POST:http://xxxxi:80/xxxxxx/xxxxx/_layouts/Upload.aspx?List=%7B865F9720-4169-4978-9A31-D5A3B1B6021B%7D&RootFolder=&IsDlg=1) 5c75e950-edbc-4bcf-b7be-74ecc986972d


    ¿Alguien sabe a qué puede deberse?

    Muchas gracias







    Sergio

    martes, 11 de marzo de 2014 9:28

Todas las respuestas

  • Hola,

    Aunque subas el límite de tamaño de archivo en SharePoint, si en IIS no lo haces no te va a servir de nada. De todos modos, cargar un archivo de 1 GB de tamaño por interfaz web es algo que puede dar estos problemas que tienes y que no se debería permitir.

    Saludos


    ------------------------------------------------------------
    Juan Carlos Gonzalez Martin
    MVP de SharePoint Server - Director revista CompartiMOSS:
    http://www.compartimoss.com
    Blog: http://geeks.ms/blogs/jcgonzalez
    Twitter: @jcgm1978
    ------------------------------------------------------------

    martes, 11 de marzo de 2014 12:41
  • Hola Juan Carlos.

    Gracias por tu respuesta.

    Supongo que cuando hablas de subirlo en IIS, te refieres a subirlo en el maxRequestLength del web.config, ¿no?

    Porque ahí también lo subí, pero el problema sigue igual.

    El límite de 1GB era para no quedarme corto, ya que como comenté en mi post, el archivo es de unos 400MB.

    ¿Alguna otra idea de cómo solucionarlo?

    Muchas gracias


    Sergio



    martes, 11 de marzo de 2014 12:53
  • Hola Sergio, ¿esto sucede única y exclusivamente con este archivo? tal vez podrías probar con otro archivo más pequeño, otro de un tamaño aproximado y comentarnos tus resultados, quedamos a la espera.

    Saludos.


    EL CONTENIDO ES PROVISTO "COMO ESTA" SIN GARANTIA DE NINGUN TIPO, YA SEA EXPLICITA O IMPLICITA& Gracias TechNet Community Support Por favor recuerda "Marcar como respuesta" las respuestas que resolvieron tu problema. Es una manera común de reconocer a quienes te ayudaron, y hace más fácil para otros visitantes el encontrar una solución después.

    miércoles, 12 de marzo de 2014 21:16
  • Hola,

    Tal y como te ha comentado Juan Carlos subir ficheros de ese tamaño no es recomendable. Ahora bien con que modelo de objetos estas subiendolo: Cliente, Servidor, .NET, JavaScript, API Rest. Recientemente rellene una Curah con diversos post que he escrito sobre este tema puedes echarle un vistazo http://curah.microsoft.com/48204/subir-ficheros-a-bibliotecas-de-sharepoint-mediante-programaci%C3%B3n por si te sirve de ayuda.

    Un saludo,


    MCPD SharePoint 2010 Mi blog: http://blogs.encamina.com/desarrollandosobresharepoint Twitter: @AdrianDiaz81

    miércoles, 12 de marzo de 2014 21:28
  • Hola.

    He hecho varias pruebas con distintos archivos y tamaños, y es imposible subir ninguno que pese más de 50MB.

    Si no me equivoco, ese es el tamaño predefinido en SharePoint por defecto, ¿verdad?

    Es como si los cambios que he hecho para incrementar el tamaño máximo de archivo no se estuvieran teniendo en cuenta. No tiene sentido.

    ¿Hay algún sitio más, aparte de la administración central y el web.config, donde indicar ese tamaño máximo?

    Un saludo


    Sergio

    jueves, 13 de marzo de 2014 10:02
  • Hola Adrián.

    Sé que no es recomendable, pero lo necesito para subir unos archivos que tiene que estar en el SharePoint.

    Estoy usando la interfaz web del SharePoint para subirlos.

    Un saludo


    Sergio

    jueves, 13 de marzo de 2014 10:03
  • Hola Sergio,

    Entiendo que estás probando en sitios bajo la App Web que has configurado...si estás probando con otra, tienes que repetir los cambios.

    Saludos


    ------------------------------------------------------------
    Juan Carlos Gonzalez Martin
    MVP de SharePoint Server - Director revista CompartiMOSS:
    http://www.compartimoss.com
    Blog: http://geeks.ms/blogs/jcgonzalez
    Twitter: @jcgm1978
    ------------------------------------------------------------

    jueves, 13 de marzo de 2014 10:24
  • Es correcto.

    Todas las pruebas son bajo la App Web.

    Saludos


    Sergio

    jueves, 13 de marzo de 2014 10:28
  • Recuerda también setear la propiedad Maximum allowed content length(Bytes) del IIS.
    Request Filtering -> Edit Feature Settings –> cambia la propiedad Maximum allowed content length(Bytes), por ej: 209715200 

    Revisa el punto 4, del siguiente post para validar las configuraciones que realizaste.

    http://todosharepoint.blogspot.com.ar/2013/06/tips-info-13-sharepoint-2013.html

    Saludos.

    domingo, 20 de abril de 2014 1:03