none
Deteccion de proceso que me cierra servidor RRS feed

  • Pregunta

  • Buen dia. Tengo un servidor con windows 2012 r2 con rol de hyper-v. y sus respectivas maquinas virtuales.

    Me esta sucediendo que el mismo se viene apagando solo, y por lo que indica el siguiente log, programado. No hay un patron fijo de horario y dia.

    The process wininit.exe (127.0.0.1) has initiated the shutdown of computer <PC NAME> on behalf of user NT AUTHORITY\SYSTEM for the following reason: Legacy API shutdown
    Reason Code: 0x80070000
    Shutdown Type: shutdown
    Comment: 

    No veo evidencia de cual es el proceso, o aplicación que lo provoca, via eventviewer.

    Quiero entender cual es la causa, y encontre lo siguiente:

    SHTDN_REASON_FLAG_PLANNED
    0x80000000

    The shutdown was planned. The system generates a System State Data (SSD) file. This file contains system state information such as the processes, threads, memory usage, and configuration.

    If this flag is not present, the shutdown was unplanned. Notification and reporting options are controlled by a set of policies. For example, after logging in, the system displays a dialog box reporting the unplanned shutdown if the policy has been enabled. An SSD file is created only if the SSD policy is enabled on the system. The administrator can useWindows Error Reporting to send the SSD data to a central location, or to Microsoft.

    Lo que no encuentro es informacion de como ver ese archivo SSD. Tampoco de como se activaria la ssd policy, (ya que al buscar via google por dicho criterio me da informacion de discos ssd :( )

    Gracias de antemano


    marcelo_adrian@hotmail.com

    jueves, 1 de junio de 2017 14:41

Respuestas

  • Dice ser un "apagado programado", así que lo más probable es que venga de un apagado de alguna tarea programada, o la UPS. Quizás aparezca algo relacionado en el log de aplicaciones, toca revisar muchos eventos :)

    Comentario: sería mejor que edites tu pregunta y comentarios, y borres la dirección de correo. En un foro nunca se responde directamente al correo, y hay "robots" que se encarga de buscar ese tipo de información, y armar listas de spam

     


    Guillermo Delprato
    Buenos Aires, Argentina
    El Blog de los paso a paso

    MVP - MCSE - MCSA2012
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration

    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    jueves, 1 de junio de 2017 22:20
    Moderador

Todas las respuestas

  • Me parece que no va a ser fácil :)

    Primero que nada trata de revisar en el "Task Scheduler" que no exista una tarea programada que haga el apagado

    También que no pase una persona delante del servidor y pulse el botón de apagado

    ¿Hay UPS? trata de revisar por este lado también, que no vaya a ser que tenga una falla que haga el apagado del servidor

    Otra posibilidad: revisa en el log de "Applications" si justo antes del apagado aparece algo

    También habría que revisar si no hay un problema de, por ejemplo temperatura del procesador, que haga el apagado por protección del hardware

     


    Guillermo Delprato
    Buenos Aires, Argentina
    El Blog de los paso a paso

    MVP - MCSE - MCSA2012
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration

    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    • Propuesto como respuesta Moderador M jueves, 1 de junio de 2017 21:32
    jueves, 1 de junio de 2017 15:44
    Moderador
  • muy agradecido por la respuesta! me imagine que va a dar batalla.

    Con relación al log que debería indicar razón de apagado? (system state data)

    Saludos!


    marcelo_adrian@hotmail.com

    jueves, 1 de junio de 2017 20:59
  • Dice ser un "apagado programado", así que lo más probable es que venga de un apagado de alguna tarea programada, o la UPS. Quizás aparezca algo relacionado en el log de aplicaciones, toca revisar muchos eventos :)

    Comentario: sería mejor que edites tu pregunta y comentarios, y borres la dirección de correo. En un foro nunca se responde directamente al correo, y hay "robots" que se encarga de buscar ese tipo de información, y armar listas de spam

     


    Guillermo Delprato
    Buenos Aires, Argentina
    El Blog de los paso a paso

    MVP - MCSE - MCSA2012
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration

    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    jueves, 1 de junio de 2017 22:20
    Moderador
  • Hola Marcelo,

    Yo te recomendaria que aparte de lo dicho por otros compañeros revises la parte de management del server (ilo,idrac,oa...) para descartar que el apagado no venga de aqui por temperatura, suministro electrico...

    Saludos

    jueves, 1 de junio de 2017 22:59
  • Gracias por el comentario!

    era efectivamente la ups que por bajas importantes de tensión apagaba el equipo. el admin de la ups me dio la info, muchas gracias!


    marcelo_adrian@hotmail.com

    viernes, 2 de junio de 2017 13:13