none
Error en Autenticación por FBA RRS feed

  • Pregunta

  • Hola, soy nueva en el foro y llevo poco manejando SharePoint, les pido paciencia si describo algo mal.

    Utilizo SharePoint 2010.

    Cree un sitio FBA, creando una base en SQL, doy de alta la CS, los proveedores membership y role sin problema, pero al querer entrar en ROLE para probar la conexión, manda un error y no reconoce al usuario que previamente se dio de alta en el servidor de SQL, ya cheque el usuario, la contraseña y el nombre de la base y todo esta bien, dentro del servidr de SQL hace conexión sin problema.

    Lo mas raro es que después de eso el proveedor que di de alta como SQLROLE se queda como proveedor por default y no puedo removerlo y "c" aparece como cualquier proveedor y se puede remover.

    Espero me puedan ayudar

    Saludos

    Atte. 

    Verónica Mejía García


    Verónica Mejía

    sábado, 2 de agosto de 2014 2:08

Respuestas

  • Hola,

    Creo q te has dejado algunas configuraciones x hacer...sigue este paso a paso: http://blogs.technet.com/b/mahesm/archive/2010/04/07/configure-forms-based-authentication-fba-with-sharepoint-2010.aspx.

    Saludos


    ------------------------------------------------------------
    Juan Carlos Gonzalez Martin
    MVP de SharePoint Server - Director revista CompartiMOSS:
    http://www.compartimoss.com
    Blog: http://geeks.ms/blogs/jcgonzalez
    Twitter: @jcgm1978
    ------------------------------------------------------------

    • Propuesto como respuesta Uriel Almendra martes, 5 de agosto de 2014 14:00
    • Marcado como respuesta Uriel Almendra miércoles, 6 de agosto de 2014 15:27
    lunes, 4 de agosto de 2014 16:48

Todas las respuestas

  • Hola Verónica,

    ¿Nos puedes detallar todos los pasos que has seguido en la configuración de FBA? Lo que me extraña es lo que comenta de que se queda como proveedor por defecto en tu aplicación web...normalmente el proveedor por defecto es Windows.

    Un saludo


    ------------------------------------------------------------
    Juan Carlos Gonzalez Martin
    MVP de SharePoint Server - Director revista CompartiMOSS:
    http://www.compartimoss.com
    Blog: http://geeks.ms/blogs/jcgonzalez
    Twitter: @jcgm1978
    ------------------------------------------------------------

    sábado, 2 de agosto de 2014 17:30
  • Hola, 

    Entro al servidor  de SharePoint y corro el archivo aspnet_regsql.exe para la base de datos en SQL, le otorgo los permisos al usuario en el servidor de SQL y pruebo el usuario con la base creada y sin problema entro.

    Creo la webapplication con las caracteristicas :

    - activo Claims Based Authentication

    - Activo Enabled Forms Based Athentication (FBA)

    - Pongo los nombres de los proveedores de role y membership

    y me crea la webapplication 

    En el IIS doy de alta los proveedores y me los da de alta sin problema, y el usuario de windows esta por default, después de intentar la conexión como le comente anteriormente, me manda el error de usuario y el proveedor de que di de alta se pone como proveedor por default.

    Muchas gracias, espero me pueda ayudar.


    Verónica Mejía

    lunes, 4 de agosto de 2014 14:54
  • Hola,

    Has configurado los archivos web.config?

    Un saludo


    ------------------------------------------------------------
    Juan Carlos Gonzalez Martin
    MVP de SharePoint Server - Director revista CompartiMOSS:
    http://www.compartimoss.com
    Blog: http://geeks.ms/blogs/jcgonzalez
    Twitter: @jcgm1978
    ------------------------------------------------------------

    lunes, 4 de agosto de 2014 15:16
  • Si, bueno solo para poner en la sección

    <PeoplePickerWildcards>

          <clear />

          <add key="AspNetSqlMembershipProvider" value="%" />

    </PeoplePickerWildcards>

    el nombre del proveedor membership que di de alta. Aparte del que ya esta.


    Ver&amp;#243;nica Mej&amp;#237;a


    • Editado Verosmg38 lunes, 4 de agosto de 2014 16:04
    lunes, 4 de agosto de 2014 15:51
  • Indague en los VirtualDirectories de la aplicación y me esta creando otros archivos que en sitios FBA anteriores que creé no aparecían, me permito enviarle una imagen para que vea las diferencias y he seguido los mismos pasos que en los sitios FBA que creé anteriormente.

    esta es la del sitio actual:

    Y esta de una anterior

    hay dos archivos layouts que antes no se creaban, no se si esto tenga que ver o porque los este creando.

    Saludos


    Ver&amp;#243;nica Mej&amp;#237;a


    • Editado Verosmg38 lunes, 4 de agosto de 2014 16:02
    lunes, 4 de agosto de 2014 16:00
  • Hola,

    Creo q te has dejado algunas configuraciones x hacer...sigue este paso a paso: http://blogs.technet.com/b/mahesm/archive/2010/04/07/configure-forms-based-authentication-fba-with-sharepoint-2010.aspx.

    Saludos


    ------------------------------------------------------------
    Juan Carlos Gonzalez Martin
    MVP de SharePoint Server - Director revista CompartiMOSS:
    http://www.compartimoss.com
    Blog: http://geeks.ms/blogs/jcgonzalez
    Twitter: @jcgm1978
    ------------------------------------------------------------

    • Propuesto como respuesta Uriel Almendra martes, 5 de agosto de 2014 14:00
    • Marcado como respuesta Uriel Almendra miércoles, 6 de agosto de 2014 15:27
    lunes, 4 de agosto de 2014 16:48
  • Ok, voy a checar entonces el blog y ver las configuraciones para que funcione. Le comentó en un rato si ya se soluciono el problema.

    Muchas Gracias :)



    Ver&amp;#243;nica Mej&amp;#237;a

    lunes, 4 de agosto de 2014 19:14
  • Hice las modificaciones en el web.config y siguió haciendo el mismo error, cree otra aplicación con un número de puerto diferente y me la creo sin problema. No se si haya sido el puerto o que paso.

    Muchas gracias por responder y ayudarme.  :)

    Saludos


    Ver&amp;#243;nica Mej&amp;#237;a


    • Editado Verosmg38 miércoles, 6 de agosto de 2014 16:18
    miércoles, 6 de agosto de 2014 16:17
  • Hola Verónica complementando la respuesta de juan carlos te dejo un video que te puede ayudar a despejar tus dudas y a configurar de manera rápida el FBA.

    https://www.youtube.com/watch?v=S3fXX3z60kU

    Slds.

    Ademir


    • Editado Ademir Soleto miércoles, 24 de septiembre de 2014 7:05
    miércoles, 24 de septiembre de 2014 7:05