locked
No me funciona el UAC después de haber usado el userpasswords2 RRS feed

  • Pregunta

  • Una pc con Windows 7 Home Premium

    2 cuentas un administrador con clave y una standard sin clave

    Lo que quería hacer es tener el usuario administrador con clave cosa de hacerle dificil la cosa a los virus, pero a la vez tener una cuenta standard sin contraseña y logueo automático para hacerle fácil el uso de la pc a mi familia (arrancar y que entre derecho al escritorio)

    Usé el comando control userpasswords2 para que inicie automáticamente el usuario estandard, desactivando la opción que los usuarios deban escribir su nombre y contraseña.

    Pues bien, anda al pelo, arranco Windows 7 y se loguea en el usuario standard. Pero al querer hacer algo que requiera privilegios de administrador me aparece el UAC sin cuadro de texto para poner clave, y con la opción si desabilitada.

    Probé el runas y pasa lo mismo

    Probé en un cmd el comando runas /user:administrador cmd.exe y en ese cmd como administrador ejecutar control userpasswords2 para revertir la cosa, pero me vuelve a salir el UAC con el si desabilitado

    Tampoco puedo desabilitar el UAC porque para eso hace falta ser administrador.

    martes, 4 de mayo de 2010 19:53

Respuestas

  • Una pc con Windows 7 Home Premium

    2 cuentas un administrador con clave y una standard sin clave

    Lo que quería hacer es tener el usuario administrador con clave cosa de hacerle dificil la cosa a los virus, pero a la vez tener una cuenta standard sin contraseña y logueo automático para hacerle fácil el uso de la pc a mi familia (arrancar y que entre derecho al escritorio)

    Usé el comando control userpasswords2 para que inicie automáticamente el usuario estandard, desactivando la opción que los usuarios deban escribir su nombre y contraseña.

    Pues bien, anda al pelo, arranco Windows 7 y se loguea en el usuario standard. Pero al querer hacer algo que requiera privilegios de administrador me aparece el UAC sin cuadro de texto para poner clave, y con la opción si desabilitada.

    Probé el runas y pasa lo mismo

    Probé en un cmd el comando runas /user:administrador cmd.exe y en ese cmd como administrador ejecutar control userpasswords2 para revertir la cosa, pero me vuelve a salir el UAC con el si desabilitado

    Tampoco puedo desabilitar el UAC porque para eso hace falta ser administrador.

    Es que un usario estandar no puede subirse privilegios en el UAC. 

    Arranca en modo seguro, y desactiva lo del logon automatico.

     


    Jose Manuel Tella Llop news://jmtella.com

    martes, 4 de mayo de 2010 19:58
  • probaré lo que dices, aunque la idea era esa

    que se loguee automaticamente a usuario standard y si hay que hacer cosas con privilegiom el UAC me pida la clave de administrador

    En modo seguro me aparece el mismo problema al querer ejecutar algo como administrador, me sale el uac sin campo para contraseña y el boton si desactivado

    Entonces, arranca con el DVD, selecciona recuperacion, y recupera desde un punto de restauracion anterior a la configuracion de logon automatico.

    Un saludo,


    Jose Manuel Tella Llop news://jmtella.com

    martes, 4 de mayo de 2010 21:04

Todas las respuestas

  • Una pc con Windows 7 Home Premium

    2 cuentas un administrador con clave y una standard sin clave

    Lo que quería hacer es tener el usuario administrador con clave cosa de hacerle dificil la cosa a los virus, pero a la vez tener una cuenta standard sin contraseña y logueo automático para hacerle fácil el uso de la pc a mi familia (arrancar y que entre derecho al escritorio)

    Usé el comando control userpasswords2 para que inicie automáticamente el usuario estandard, desactivando la opción que los usuarios deban escribir su nombre y contraseña.

    Pues bien, anda al pelo, arranco Windows 7 y se loguea en el usuario standard. Pero al querer hacer algo que requiera privilegios de administrador me aparece el UAC sin cuadro de texto para poner clave, y con la opción si desabilitada.

    Probé el runas y pasa lo mismo

    Probé en un cmd el comando runas /user:administrador cmd.exe y en ese cmd como administrador ejecutar control userpasswords2 para revertir la cosa, pero me vuelve a salir el UAC con el si desabilitado

    Tampoco puedo desabilitar el UAC porque para eso hace falta ser administrador.

    Es que un usario estandar no puede subirse privilegios en el UAC. 

    Arranca en modo seguro, y desactiva lo del logon automatico.

     


    Jose Manuel Tella Llop news://jmtella.com

    martes, 4 de mayo de 2010 19:58
  • probaré lo que dices, aunque la idea era esa

    que se loguee automaticamente a usuario standard y si hay que hacer cosas con privilegiom el UAC me pida la clave de administrador

    En modo seguro me aparece el mismo problema al querer ejecutar algo como administrador, me sale el uac sin campo para contraseña y el boton si desactivado

    martes, 4 de mayo de 2010 20:44
  • probaré lo que dices, aunque la idea era esa

    que se loguee automaticamente a usuario standard y si hay que hacer cosas con privilegiom el UAC me pida la clave de administrador

    En modo seguro me aparece el mismo problema al querer ejecutar algo como administrador, me sale el uac sin campo para contraseña y el boton si desactivado

    Entonces, arranca con el DVD, selecciona recuperacion, y recupera desde un punto de restauracion anterior a la configuracion de logon automatico.

    Un saludo,


    Jose Manuel Tella Llop news://jmtella.com

    martes, 4 de mayo de 2010 21:04
  • Hola,

    Coméntanos si con la restauración arreglaste, porque probablemente perdió el usuario que tuviera los privilegios administrativos para elevar, y por tanto te deshabilita la solicitud de credenciales, en caso de que no funcione creo que todavía hay un "How to" de Jose Manuel para recuperar una cuenta administrativa.

    Saludos,


    Sergio Calderón-

    • Marcado como respuesta Atilla ArrudaModerator jueves, 6 de mayo de 2010 13:18
    • Desmarcado como respuesta leo3487 viernes, 7 de mayo de 2010 10:12
    martes, 4 de mayo de 2010 23:26
  • Hola Tella y Sergio

    No me funcionó tampoco el restaurar desde el DVD. Me seguía mostrando el UAC con el botón si desactivado.

    Así que no me quedó otra que formatear y poner todo de vuelta, total, tengo Windows y los programas en C y los datos en D. Y dado que es la compu de escritorio de la familia, estoy con un solo usuario, administrador y sin contraseña.

    Cómo hago ahora para no meter la pata?

    Les repito lo que había querido hacer y que originó el error:

    - Crear usuario estandard sin contraseña

    - Crearle clave al usuario administrador

    - Usar el Control userpasswords2 para loguearse automáticamente al usuario standard

    Pero al completar esos pasos se me jode el UAC

    viernes, 7 de mayo de 2010 10:25
  • Hola Tella y Sergio

    No me funcionó tampoco el restaurar desde el DVD. Me seguía mostrando el UAC con el botón si desactivado.

    Así que no me quedó otra que formatear y poner todo de vuelta, total, tengo Windows y los programas en C y los datos en D. Y dado que es la compu de escritorio de la familia, estoy con un solo usuario, administrador y sin contraseña.

    Cómo hago ahora para no meter la pata?

    Les repito lo que había querido hacer y que originó el error:

    - Crear usuario estandard sin contraseña

    - Crearle clave al usuario administrador

    - Usar el Control userpasswords2 para loguearse automáticamente al usuario standard

    Pero al completar esos pasos se me jode el UAC

    ¿formatear por esto cuando hay mil maneras de entrar como SYSTEM?... joer... yo que tengo fama de aconsejar formatear nunca te lo aconsejaria por esto porque está chupao' entrar). Yo aoncsejo formateo solo cuando veo malas practicas en el usuario que han provocado riesgo en la seguridad, o malfuncionamiento feneralizado por instalar cosas que no se deben, pero por estas cosas nunca!... :-P

    Bien, ahora estoy fuera, dejame una hora poco mas o menos para una prueba y te comento...

    Un saludo,


    Jose Manuel Tella Llop news://jmtella.com

    viernes, 7 de mayo de 2010 11:53
  • Hola Tella y Sergio

    No me funcionó tampoco el restaurar desde el DVD. Me seguía mostrando el UAC con el botón si desactivado.

    Así que no me quedó otra que formatear y poner todo de vuelta, total, tengo Windows y los programas en C y los datos en D. Y dado que es la compu de escritorio de la familia, estoy con un solo usuario, administrador y sin contraseña.

    Cómo hago ahora para no meter la pata?

    Les repito lo que había querido hacer y que originó el error:

    - Crear usuario estandard sin contraseña

    - Crearle clave al usuario administrador

    - Usar el Control userpasswords2 para loguearse automáticamente al usuario standard

    Pero al completar esos pasos se me jode el UAC

    ¿formatear por esto cuando hay mil maneras de entrar como SYSTEM?... joer... yo que tengo fama de aconsejar formatear nunca te lo aconsejaria por esto porque está chupao' entrar). Yo aoncsejo formateo solo cuando veo malas practicas en el usuario que han provocado riesgo en la seguridad, o malfuncionamiento feneralizado por instalar cosas que no se deben, pero por estas cosas nunca!... :-P

    Bien, ahora estoy fuera, dejame una hora poco mas o menos para una prueba y te comento...

    Un saludo,


    Jose Manuel Tella Llop news://jmtella.com

    Bien, los primero, en ti caso ¿como podrias haberte evistao el formateo?... pues simplemente "hackeando" tu propia maquina, es decir, siguiendo las instrucciones con las que soluciono el problema a este usuario:

    http://social.technet.microsoft.com/Forums/es-ES/wcvistaes/thread/a1001475-50c3-4e47-99f8-1dbf7139bd9b

    De esta forma consigues una consola como SYSTEM y ya puedes hacer lo que sea. EL SYSTEM tiene mas privilegios que el propio Administrador.

    Y ahora, si quieres hacer lo que habias propuesto en el hilo, por desgracia necesitas un softaware de terceros... Veamos la idea:

    * Si pudieses acceder por escritorio remoto a tu misma maquina desde otra sesion de usuario, estaría solucionado. Te conectas por escritorio remoto con credenciales del Administrador y a correr. Peroooo:

    * Windows no permite conectarse a la IP de la propia maquina... (solucionable apuntando a un clon de la local host, es decir a 127.0.0.2 en vez de a la 127.0.0.1)

    * Se necesitaría profesional o superior.

    * Y por desgracia, aunque esta es la teoria, limita el numero de conexiones a consola y por tanto solo funcionaría en un server W2008.

    Ante esto parece que estamos atados de manos, pero si compramos (29 euros) este sofware con una licencia "lite" para una conexion, nos permite para cualquier windows (no solo Profesiona o superior) y nos permite conectanos a la 127.0.0.2 desde un usuario limitado contra otro usuario (Administrador) en la misma maquina:

    http://www.thinstuff.com/products/xpvs-server/

    (lo acabo de probar y funciona de cine... puedes probarlo con la version Demo de 30 dias antes de comprarlo)

    Comentame...


    Jose Manuel Tella Llop news://jmtella.com

    viernes, 7 de mayo de 2010 16:01