none
Error Sharepoint: "Server Error in '/' application" RRS feed

  • Pregunta

  • Buenos días:

    Os explico. Tenía instalado el Sharepoint ya que estoy haciendo unas pruebas, entonces instalé un dominio (dcpromo) y me salíe ese error, después de buscar pense que fue pro instalar el dominio después que el sharepoint, así que lo desinstalé y volví a instalar, pero me sigue saliendo el  mismo error:

    "Server Error in '/' Application.
    --------------------------------------------------------------------------------

    Runtime Error
    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed.

    Details: To enable the details of this specific error message to be viewable on the local server machine, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "RemoteOnly". To enable the details to be viewable on remote machines, please set "mode" to "Off".


    <!-- Web.Config Configuration File -->

    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly"/>
        </system.web>
    </configuration>
     

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


    <!-- Web.Config Configuration File -->

    <configuration>
        <system.web>
            <customErrors mode="On" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>"

    La solución que encontré fue que a "<customErrors mode=on" hay que cambiarle pro un off, en el fichero web.config.

    una vez modificado me sale el siguiente error:

    "Server Error in '/' Application.
    --------------------------------------------------------------------------------

    Configuration Error
    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: '?' is an unexpected token. The expected token is '='. Line 53, position 173.

    Source Error:


    Line 51:       <SafeControl Src="~/_controltemplates/*" IncludeSubFolders="True" Safe="True" AllowRemoteDesigner="True" />
    Line 52:       <SafeControl Assembly="Microsoft.Office.Workflow.Feature, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" Namespace="Microsoft.Office.Workflow.Feature" TypeName="ProcessAllTasksButton" Safe="True" />
    Line 53:       <SafeControl Assembly="Microsoft.Office.Excel.WebUI, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" Namespace="Microsoft.Office.Excel.WebUI" Type?ame="*" />
    Line 54:       <SafeControl Assembly="Microsoft.Office.Server.UI, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" Namespace="Microsoft.Office.Server.WebControls" TypeName="*" />
    Line 55:       <SafeControl Assembly="Microsoft.SharePoint.Portal, Version=11.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" Namespace="Microsoft.SharePoint.Portal.WebControls" TypeName="*" />
     

    Source File: C:\Inetpub\wwwroot\wss\VirtualDirectories\16939\web.config    Line: 53"

    Que vale, es por que han salido interrogaciones pro el editor de windows.

    Una vez modificadas las ? me da el siguiente error:

    "Server Error in '/' Application.
    --------------------------------------------------------------------------------

    The current identity (NT AUTHORITY\NETWORK SERVICE) does not have write access to 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files'.
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Web.HttpException: The current identity (NT AUTHORITY\NETWORK SERVICE) does not have write access to 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files'.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below. 

    Stack Trace:


    [HttpException (0x80004005): The current identity (NT AUTHORITY\NETWORK SERVICE) does not have write access to 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files'.]
       System.Web.HttpRuntime.SetUpCodegenDirectory(CompilationSection compilationSection) +8913774
       System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags) +152

    [HttpException (0x80004005): The current identity (NT AUTHORITY\NETWORK SERVICE) does not have write access to 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files'.]
       System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +8886319
       System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +85
       System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +259"


    Cambio los permisos para el usuario qeu dice y me da permiso denegado!!!


    No se que hacer....sólo estoy modificando el web.config para acceder a la administración central.

    He buscado mucho peor no encuentor solución y aquí tampoco he visto solución.

    Así que a ver qeu me podéis comentar al respecto.

    Muchas gracias.
    Yo molo mogollón!!
    miércoles, 3 de junio de 2009 11:06

Respuestas

  • sí, tienes que mirar la identidad del pool de aplicaciones que utiliza tu web site, esto lo puedes ver en IIS > application pools > seleccionas la que utilice tu web site > propiedades > identidad.  en la pestaña identidad verifica que usuario tienes.

    De todas formas si te sigue dando error mira en el log de windows y en el log de sharepoint que por defecto estará en "C:\Program Files\Common Files\microsoft shared\Web Server Extensions\12\LOGS"


    http://geeks.ms/blogs/mcortes/ http://mariocortesflores.blogspot.com/
    • Marcado como respuesta Madrikeka jueves, 4 de junio de 2009 17:51
    miércoles, 3 de junio de 2009 14:02
  • Muchas gracias!!!

    Fui a los logs y me daba el siguiente error:

    "06/04/2009 17:41:38.62     w3wp.exe (0x02C4)                           0x0BAC    Windows SharePoint Services       Runtime                           6610    Critical    El modo a prueba de errores no se inició correctamente. El elemento <SafeControl> del archivo web.config tiene un atributo no reconocido: 'Typename'. Observe que los nombres de atributo distinguen entre mayúsculas y minúsculas."


    Finalmente la culpa la tenía una N, ese Typename debía ser TypeName.

    Ya puedo acceder a la administración central.

    Así que una vez se me han ido solucionando todos los errores ya puedo dar por finalizada la respuesta.

    Yo molo mogollón!!
    • Marcado como respuesta Madrikeka jueves, 4 de junio de 2009 17:50
    jueves, 4 de junio de 2009 17:50

Todas las respuestas

  • Prueba a cambiar las credenciales del pool de aplicaciones web que utiliza tu web application de sharpeoint. Cambia el usuario NETWORK SERVICE por un usuario con permisos de administración en la máquina y haz un iisreset o recilca el pool.
    http://geeks.ms/blogs/mcortes/ http://mariocortesflores.blogspot.com/
    miércoles, 3 de junio de 2009 11:22
  • Muchas gracias.

    He mirado en la seguridad de "web sites" y sólo tenía marcado Enable anonymous acces; lo ghe puesto para que se integre con windows y ahora me sale este error:

    "Volver al sitio 
    Error 
     
       
     
     
       
     
    Error inesperado.
    Solución de problemas de Windows SharePoint Services."

    Pero me sale sobre la pantalla de Sharepoint, así que se puede decir qeu tengo semiacceso.

    Si se te ocurre algo mas...yo voy a seguir probando con los permisos y una vez lo consiga lo dejo en el post todos los pasos que hice.

    Muchas gracias.


    Yo molo mogollón!!
    miércoles, 3 de junio de 2009 12:42
  • sí, tienes que mirar la identidad del pool de aplicaciones que utiliza tu web site, esto lo puedes ver en IIS > application pools > seleccionas la que utilice tu web site > propiedades > identidad.  en la pestaña identidad verifica que usuario tienes.

    De todas formas si te sigue dando error mira en el log de windows y en el log de sharepoint que por defecto estará en "C:\Program Files\Common Files\microsoft shared\Web Server Extensions\12\LOGS"


    http://geeks.ms/blogs/mcortes/ http://mariocortesflores.blogspot.com/
    • Marcado como respuesta Madrikeka jueves, 4 de junio de 2009 17:51
    miércoles, 3 de junio de 2009 14:02
  • Los "identities" están como Network service, he probado a poner cualquiera de las otras opciones incluso personalizado y no funciona.

    Seguiré buscando mas opciones, de todas maneras, como ya he dicho anteriormente si encuentro una solución la expondré aquí para que la gente tenga mas opciones.

    Nuevamente muchas gracias!!
    Yo molo mogollón!!
    jueves, 4 de junio de 2009 15:19
  • Muchas gracias!!!

    Fui a los logs y me daba el siguiente error:

    "06/04/2009 17:41:38.62     w3wp.exe (0x02C4)                           0x0BAC    Windows SharePoint Services       Runtime                           6610    Critical    El modo a prueba de errores no se inició correctamente. El elemento <SafeControl> del archivo web.config tiene un atributo no reconocido: 'Typename'. Observe que los nombres de atributo distinguen entre mayúsculas y minúsculas."


    Finalmente la culpa la tenía una N, ese Typename debía ser TypeName.

    Ya puedo acceder a la administración central.

    Así que una vez se me han ido solucionando todos los errores ya puedo dar por finalizada la respuesta.

    Yo molo mogollón!!
    • Marcado como respuesta Madrikeka jueves, 4 de junio de 2009 17:50
    jueves, 4 de junio de 2009 17:50