none
Problemas para agregar usuarios en SharePloint RRS feed

  • Pregunta

  • Hola!

     

    Estamos desarrollando un software para gestionar de forma centralizada todas las instalaciones de una gran empresa. Como mecanismo para la gestión documental se empleará SharePoint Services 3.0 y será necesario hacer uso de los Web services para integrar SharePoint con nuestro software basado en Java.
    Con la intención de probar como acceder a estos web services, hace cosa de unos pocos días instalé SharePoint Services 3.0 en uno de los servidores de la empresa, para crear un pequeño ejemplo y así empezar a hacer pruebas.

     

    Por el momento tengo configurado la página de administración central de SharePoint y la aplicación creada por defecto en el pueto 80 con la utentificación básica y puedo acceder correctamente desde cualquier ordenador de la intranet, utilizando siempre la cuenta de administrador del servidor donde está instalado SharePoint
     

    No obstante, por el momento SharePoint no me permite agregar más usuarios. Cuando le doy a agregar usuario no encuentra ninguna de las cuentas de dominio de Windows y sólo me reconoce las cuentas de usuario como:

     administrador
       Cuenta del sistema (SHAREPOINT\system)
       Farm administrators
       NT_AUTHORITY\LOCAL SERVICE
       NT_AUTHORITY\NETWORK SERVICE
       ... 

     

    No me reconoce ninguna de las cuentas de dominio que tenemos todos los empleados (que son del tipo EMPRESA\usuario y que se generan en uno de los servidores instalados en otra de las filiales de la empresa)

     

    Por el contrario si que puedo acceder a esas cuentas de usuario desde otras aplicaciones como Internet...

     

    Por lo que supongo que tendría que configurar SharePoint para poder acceder a esas cuentas de dominio de Windows, pero no se desde donde se debe hacer, si desde el Administrador IIS o dese la propia página de Administración central de SharePoint

     

    ¿alguién podría darme algunas indicaciones al respecto? Llevo batallando un par de días con ello y no se entonces como puedo añadir usuarios en SharePoint

     

    Muchas gracias

    jueves, 3 de mayo de 2007 10:50

Respuestas

  • Muchas gracias

    Teniais razon, el problema que tenía inicialmente cuando no me detectaba ninguna de las cuentas de dominio era porque la máquina por lo visto no estaba bien conectada al dominio de la empresa. En cuanto arregleron este tema automáticamente podía ver desde l sharepoint las diferentes cuentas de dominio de la empresa e irlas agragando al sharepoint sin problemas.

    De todas formas, tambén estaba interesada en conocer si era posible configurar Sharepoint en un Active Directory independiente y de tal forma que desde el mismo sharepoint fuera posible además el Crear usuarios sobre ese active directory...
    Como me habías dicho tanto en sharepoint como en 2007 se pueden usar cuentas locales de windows o remotas de AD, he encontrado un documento muy util que lo explica muy claremante http://office.microsoft.com/download/afile.aspx?AssetID=AM102157711033

    Muchas gracias de nuevo,
    martes, 29 de mayo de 2007 7:01

Todas las respuestas

  • mira, yo acabo de hacer mi primer sitio sharepoint,no se si servira, pero yo utilice el active directory para agregar ahi a los usuarios y luego en el sitio sharepoint, ahora, yo tenia el central administration y el active en un mismo servidor(no es recomendable Tongue Tied) pero asi pude agregar a los otros usuarios. Una vez q cree el active directory, simplemente el el propio sitio web agregue a los usuarios con sus respectivos permisos. Solo me queda duda si hay un procedimiento diferente cuando usas tienes el sitio en un servidor, el active directory en otro servidor, la base de datos en otro, etc...  no se si habra q hacer algo mas, asi q si alguien coopera seria bueno ; )
    lunes, 21 de mayo de 2007 15:47
  • Hola,
    Yo en mi caso tengo el Active Directory en otro servidor ubicado en sede central de la empresa,
    y creo que no se acaba entonces de coger bien entonces al dominio, porque no me reconoce ninguna de las cuentas de dominio ni siquiera al inciar el servidor (únicamente puedo iniciarlo con una cuenta local)

    He leido que en sharepoint 2007 se pueden crear usuarios que no esten en el Active Directory, pero, ¿es también es posible en sharepoint services 3.0?

    Muchas gracias



       
    miércoles, 23 de mayo de 2007 16:44
  • creo q en el 2007 puedes agregar los usuarios agregandolloos desde la autenticacion de windows y en el 3.0 tambien, pero no estoy muy seguro....Sad
    miércoles, 23 de mayo de 2007 17:13
  • Hola,

    Tanto en SharePoint 2003 como en 2007 se pueden usar cuentas locales de Windows o remotas de AD, o ambos al mismo tiempo.

    Saludos,

    Gustavo

    jueves, 24 de mayo de 2007 20:33
  • Muchas gracias

    Teniais razon, el problema que tenía inicialmente cuando no me detectaba ninguna de las cuentas de dominio era porque la máquina por lo visto no estaba bien conectada al dominio de la empresa. En cuanto arregleron este tema automáticamente podía ver desde l sharepoint las diferentes cuentas de dominio de la empresa e irlas agragando al sharepoint sin problemas.

    De todas formas, tambén estaba interesada en conocer si era posible configurar Sharepoint en un Active Directory independiente y de tal forma que desde el mismo sharepoint fuera posible además el Crear usuarios sobre ese active directory...
    Como me habías dicho tanto en sharepoint como en 2007 se pueden usar cuentas locales de windows o remotas de AD, he encontrado un documento muy util que lo explica muy claremante http://office.microsoft.com/download/afile.aspx?AssetID=AM102157711033

    Muchas gracias de nuevo,
    martes, 29 de mayo de 2007 7:01
  • Hola,

     

    Si que se puede perfectamente trabajar con sharepoint services y active directory, de echo, creo q es la mejor manera para configurar el tema de los usuarios.

     

    En mi empresa, el servidor principal q hace de dominio y tiene active directory, no tiene el sharepoint, este, lo tengo en otro servidor. Cuando lo instale tube el mismo problema, yo queria q el sistema reconociera a los usuarios de active directory.

     

    Lo que hize fue crera el servidor donde tengo el sharepoint como replica del dominio del principal, a través de DCPROMO, de esta manera pude tener el active directory en el servidor de sharepoint y todo fue genial.

     

    Un saludo!

    martes, 17 de julio de 2007 9:15
  • Tengo el mismo problema que se planteaba en este post. Dábais como solución "La máquina por lo visto no estaba bien conectada al dominio de la empresa". Pero realmente como lo habéis conseguido. He realizado pruebas con el AD, y no se realmente como lo habéis conseguido. Si podríais decirme como conectar bien el Servidor de MOSS al AD.

    Gracias...

     

    miércoles, 12 de septiembre de 2007 15:41
  • Despues de haber leido lo anterior, me pregunto si alguien sabe como configurar usuarios en Sharepoint sin utilizar active directory... he tenido hartos quebraderos de cabeza con esto... de antemano gracias

    martes, 2 de septiembre de 2008 17:04