none
Problema para mostrar documentos agrupados por tipo de contenido. RRS feed

  • Pregunta

  • Tengo Sharepoint  Foundation 2010, no se que pude haber desconfigurado en la biblioteca publica de mi sitio que perdí el agrupamiento por tipo de contenido que tenía configurada. Ya he validado que la biblioteca tenga habilitada la permisibiidad para la administración de tipos de contenido y los tipos de contenido están ya agregados dentro de la misma biblioteca. Si yo agrego, en la vista que estoy utilizando, el campo Tipos de contenido, me muestra este valor para cada documento de la biblioteca pero ha sido imposible lograr agrupar por este campo, en la opción "agrupar por" de la vista en uso no me muestra el campo "Tipos de contenido".  Como les indico inicialmente si se estaba mostrando esta agrupación. ¿Que pude haber desconfigurado?, ¿Como solucionar?. Gracias de antemano por su apoyo. Saludos desde Costa Rica
    martes, 17 de abril de 2012 21:53

Respuestas

Todas las respuestas

  • Hola,

    ¿Has probado a crear una nueva vista y hacer en la misma la agrupación?

    Un saludo


    ------------------------------------------------------------
    Juan Carlos González Martín MVP de SharePoint Server
    Director revista CompartiMOSS: http://www.gavd.net/servers/compartimoss/compartimoss_main.aspx
    Blog: http://geeks.ms/blogs/ciin
    Twitter: @jcgm1978
    ------------------------------------------------------------

    miércoles, 18 de abril de 2012 6:07
  • Gracias por tu respuesta Juan Carlos, por cierto estuve en una de tus charlas en el Simposio realizado este año acá en San José (Publo Antiguo).

    Te comento que no lo habia hecho pero por tu sugerencia lo realice, en la biblioteca con el problema creé una nueva vista la cual nombre "Por tipo de contenido", incluí en ella la columna Tipo de contenido (quise agrupar de una vez por este mismo campo pero en la opción "Agrupar por" NO se me mostró el campo Tipo de contenido, cosa que me pasa con cualquiera de las vistas que tengo habilitadas en este biblioteca). Puse la vista recién creada como predeterminada pero no se mostró la agrupación por el tipo de contenido, cuando abro la biblioteca, para todos los archivos se muestra la columna Tipo de contenido pero sin poder agrupar por ese campo.

    Gracias de antemano por tu atención.

    miércoles, 18 de abril de 2012 13:44
  • Hola,

    He encontrado este enlace que explica una manera de crear una vista similar a que quieres usando Sharepoint Designer

    http://www.sharepointanalysthq.com/2010/06/how-to-group-by-content-type-in-sharepoint-2010/

    Espero que te sirva

    miércoles, 18 de abril de 2012 14:23
  • Me queda la duda si debo de incluir una a una en las bibliotecas en que requiera agrupar por el tipo de contenido el código que sugiere el hilo, pero lo probaré. Aún así espero llegar a encontrar que fue lo que por error desconfiguré y que me provocó la pérdida de esta agrupación.

    Gracias KrennonC

    miércoles, 18 de abril de 2012 14:42
  • Gracias KrennonC la solucion del link fue efectiva.
    • Marcado como respuesta JoseACr jueves, 19 de abril de 2012 21:26
    jueves, 19 de abril de 2012 21:26