none
La red hospedada (hostednetwork) ha dejado de asignar IPs RRS feed

  • Pregunta

  • ¡Saludos!

    Desde hace tiempo uso la red hospedada de windows para conectar dispositivos al ordenador y mediante una aplicación mandar archivos.
    Tengo una tarea creada para en cuanto arranca el ordenador iniciar la red:

    netsh wlan start hostednetwork

    Dicha red se configura tal que así:

    netsh wlan set hostednetwork mode=allow ssid=Nombre_delaRed key=*******

    Hasta la versión 1703 de windows10 el "invento" ha funcionado si problemas, siempre y cuando la tarjeta de red permita la red hospedada.

    Pues bien, desde la versión 1709 esta funcionalidad ha dejado de asignar IP a los dispositivos que se conectan a la red. Los dispositivos llegan a autenticarse, pero no obtienen dirección IP, además la máscara de red ha pasado de 255.255.255.0 a 255.255.0.0. 

    Por tanto resulta imposible conectar dispositivos móviles (iPhone y Android).

    He buscado este problema y he visto hilos en los que se explica que habilitando la función de "Permitir que los usuarios de otras redes se conecten a través de la conexión a Internet de este equipo" se soluciona el error. Pero en el momento que lo habilito y le doy a "Aceptar" la ventana se queda bloqueada y no responde, y no se aplica el cambio.


    Por favor, necesito hacer que los dispositivos se conecten y obtengan IP automáticamente.

    ¿Alguien me puede ayudar con esto?

    Un saludo a todos los que habéis dedicado un momento a leer esto y gracias de antemano!

    jueves, 23 de noviembre de 2017 7:08

Respuestas

  • Hola Fran Servifot,

    Este es el último parche que repara la mayor cantidad de errores presentados en los aplicativos.

    ***Te recomendamos probarla y comentarnos tus resultados:

    https://support.microsoft.com/es-es/help/4051314/compatibility-update-for-upgrading-to-windows-10-version-1709-november

    Esperamos que sea de utilidad para ti, cualquier actualización quedamos al pendiente.

    Gracias por usar los foros de TechNet.

    Juan
     _____

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde. 

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft.  

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    • Marcado como respuesta Fran Servifot lunes, 4 de diciembre de 2017 8:51
    viernes, 24 de noviembre de 2017 15:46
    Moderador
  • Hola Fran Servifot,

    Te comentamos que una posible solución a tu consulta puede ser regresar a la versión anterior del sistema debido a que algunos aplicativos no funcionan de manera correcta.

    Esperamos que sea de utilidad para ti, cualquier actualización quedamos al pendiente.

    Gracias por usar los foros de TechNet.

    Juan
    _____

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde. 

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft.  

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    jueves, 23 de noviembre de 2017 17:43
    Moderador

Todas las respuestas

  • Hola Fran Servifot,

    Te comentamos que una posible solución a tu consulta puede ser regresar a la versión anterior del sistema debido a que algunos aplicativos no funcionan de manera correcta.

    Esperamos que sea de utilidad para ti, cualquier actualización quedamos al pendiente.

    Gracias por usar los foros de TechNet.

    Juan
    _____

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde. 

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft.  

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    jueves, 23 de noviembre de 2017 17:43
    Moderador
  • Hola Juan.

    Muchas gracias por tu respuesta, efectivamente en algún equipo he podido revertir la versión y se ha quedado en la 1603. En esa versión vuelve a funcionar todo perfectamente.

    El problema es que en algunos equipos ya no me aparece la opción de volver a la versión anterior, ¿existe alguna forma de forzar que vuelva a versiones anteriores?

    Gracias por tu ayuda.

    viernes, 24 de noviembre de 2017 13:46
  • Hola Fran Servifot,

    Este es el último parche que repara la mayor cantidad de errores presentados en los aplicativos.

    ***Te recomendamos probarla y comentarnos tus resultados:

    https://support.microsoft.com/es-es/help/4051314/compatibility-update-for-upgrading-to-windows-10-version-1709-november

    Esperamos que sea de utilidad para ti, cualquier actualización quedamos al pendiente.

    Gracias por usar los foros de TechNet.

    Juan
     _____

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde. 

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft.  

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    • Marcado como respuesta Fran Servifot lunes, 4 de diciembre de 2017 8:51
    viernes, 24 de noviembre de 2017 15:46
    Moderador
  • Hola.

    Efectivamente, la última compilación de la versión 1709 corrige el error que estaba teniendo, y ya vuelve a funcionar todo.

    ¡Un saludo y gracias!

    lunes, 4 de diciembre de 2017 8:51
  • Hola,

    (otra vez...)

    El problema sigue sin solucionarse, llevo varios días revisando el error y ya no se me ocurre que más se puede hacer.

    He probado a reiniciarlo todo, el adaptador de red, compartir internet y dejar de compartirlo a través de la red hospedada, y no funciona nada.

    He descubierto más cosas. En el "Editor del Registro" de windows, hay 3 claves que definen los parámetros de la red hospedada. Estos están en:

    Equipo\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\{...}\{XXXXXX} - En esta tenemos la red que se genera, en una de las subclaves aparece en la Clave "Connection" los parámetros Name, PnPInstanceId. El primero describe el nombre de la red, y el segundo es un identificador que no se para que sirve.

    Después en Equipo\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Adapters\{XXXXXX}

    y en Equipo\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{XXXXXX}

    Encontramos más parámetros de configuración. He probado de pasar los de un equipo que funciona a este equipo que no funciona, pero nada... 

    Lo que me parece extraño es que la red que se genera, a parte de tener la máscara 255.255.0.0 no tiene una ip local, la IP es 169.254.X.Y, donde X e Y van cambiando cada vez que elimino el adaptador de red "Miscrosoft Hosted Network Virtual Adapter".

    Parece que al arrancar el servicio no puede recuperar la información que debe, y genera una por defecto.
    ¿Sabemos de donde saca la información el wlansvc para montar la hostednetwork? Igual buscando por ese camino encontramos el problema.

    ¿Alguien tiene alguna idea?

    Cualquier pisa o ayuda podría ser la solución!

    ¡¡Gracias de antemano!!

    martes, 19 de diciembre de 2017 11:26
  • Por lo que veo las IP 169.254.X.Y las ponen las tarjetas de red cuando ningún servidor DHCP les asigna IP. Entonces el problema debe ser que la hostednetwork no está encontrando un DHCP para asignar las IP.

    Lo que no se es como "Reiniciar" ese DHCP o como hacer que funcione.

    ¿Alguna idea?

    martes, 19 de diciembre de 2017 12:30
  • tengo este mismo problema y no encuentro como solucionarlo, probe instalando el parche pero la version no es compatible con mi version 1803.-

    hay alguna opcion que solucione este problema??

    miércoles, 20 de febrero de 2019 6:36