none
Solicitud de credenciales de usuario en SharePoint 2010 desde Internet RRS feed

  • Pregunta

  • Buenas Noches Estimados

    Estoy en un proyecto de SharePoint con el siguiente escenario:
    -Granja de 10 Servidores de SP 2010  ( 4 APL , 2 WFE -Red Interna- y 4 WFE -En DMZ para usuarios externos - ), los WFE estan en NLB.
    - 1 Web Aplication con su Content Data Base dedicada.
    -Usuarios Internos
    -Usuarios Externos con cuentas de dominio para acceso a site, desde fuera de la RED
    -Sitio Interno http://sitio.midominio.com (sin certificado)
    -Sitio Externo http://sitio.midominio.net (sin certificado) con zona INTERNET

    Los usuarios externos aceden al sitio con su cuentas de dominio perfectamente y navegan por el site, al intentar modificar elementos de una lista empieza a solicitar credenciales a cada rato y no deja realizar ninguna modificacion.

    Unicamente solicita credenciales si me conecto al sitio de SharePoint desde Internet.

    A mi parecer no mantiene las credenciales de inicio de sesion cuando ingresa al site.


    He revisado foros , realice cambios en el tipo de autenticacion y nada , la falla persiste.

    necesito resolver esto cuanto antes, ya que tengo proveedores que necesitan agregar, modificar y eliminar elementos de listas y bibliotecas.

    Que se les ocurre ??

    Gracias por el apoyo

    Saludos
    JAC


    Jose Antonio Cermeño- Caracas-Venezuela **http://jacermeno.wordpress.com "Colabora con el foro,vota si te ha servido la respuesta"

    martes, 19 de marzo de 2013 1:46

Respuestas

  • **SOLUCION **

    Estimados

    La solución fue eliminar la zona Intranet y crear una nueva zona como EXTRANET , una vez realizado el cambio para poder probar, baje 3 de los WFE de la DMZ, ejecute el configuration wizard en los APL y luego en el WFE.  FUNCIONO.

    Una vez validado ejecute Conf. Wizard en los restantes servidores de la granja.

    Authentication Providers

    Gracias por el apoyo
    JAC


    Jose Antonio Cermeño- Caracas-Venezuela **http://jacermeno.wordpress.com "Colabora con el foro,vota si te ha servido la respuesta"

    • Marcado como respuesta JACERMENO miércoles, 20 de marzo de 2013 22:31
    martes, 19 de marzo de 2013 19:37

Todas las respuestas

  • Hola,

    Seguramente tengas problemas de double hop y tengas que configurar Kerberos para solventarlo.

    Saludos


    ------------------------------------------------------------
    Juan Carlos González Martín MVP de SharePoint Server
    Director revista CompartiMOSS: http://www.compartimoss.com
    Blog: http://geeks.ms/blogs/ciin
    Twitter: @jcgm1978
    ------------------------------------------------------------

    martes, 19 de marzo de 2013 10:30
  • Hola Juan Antonio, te hago algunas consultas.

    1) EL sitio lo estás publicando mediante un ISA Server?

    2) Los usuarios tiene problemas para trabajar con todas las listas o son algunas en particular?

    3) Que tipo de autenticación tienes configurada? Nos cuentas que probaste distintos tipos de autenticación, usaste Kerberos tal como comenta Juan Carlos?

    Por otro lado, probaste de poner el sitio como sitio de confianza en el IE y marcar la opción Automatically Logon with current user name and passworden en la sección User Authentication > Logon

    Saludos

    Msorli


    Msorli

    martes, 19 de marzo de 2013 12:58
  • Hola msroli

    1. No uso isa server , mi firewall es un IPS de IBM.

    2. En este caso en una lista en particular, ya verifique los permisos de la lista, inclusive estoy probando con un usuario administrador de site.

    3. La autenticación que estoy utilizando en la Zona Internet es la siguiente:

    Zona_Internet
    Ya probé utilizando Kerberos y habilitando Client Integration

    4. Adicionalmente configure los sitios de confianza en el explorador, que es lo primero que encuentras en los foros.



    Jose Antonio Cermeño- Caracas-Venezuela **http://jacermeno.wordpress.com "Colabora con el foro,vota si te ha servido la respuesta"

    martes, 19 de marzo de 2013 15:05
  • Y la lista es una lista común de SharePoint o es una lista Externa?

    Saludos


    Msorli

    martes, 19 de marzo de 2013 15:07
  • Una lista común de SharePoint

    Si necesitas mas detalles me avisas, sigo documentandome

    Gracias por el apoyo

    Saludos

    Jose Antonio Cermeño- Caracas-Venezuela **http://jacermeno.wordpress.com "Colabora con el foro,vota si te ha servido la respuesta"

    martes, 19 de marzo de 2013 15:28
  • **SOLUCION **

    Estimados

    La solución fue eliminar la zona Intranet y crear una nueva zona como EXTRANET , una vez realizado el cambio para poder probar, baje 3 de los WFE de la DMZ, ejecute el configuration wizard en los APL y luego en el WFE.  FUNCIONO.

    Una vez validado ejecute Conf. Wizard en los restantes servidores de la granja.

    Authentication Providers

    Gracias por el apoyo
    JAC


    Jose Antonio Cermeño- Caracas-Venezuela **http://jacermeno.wordpress.com "Colabora con el foro,vota si te ha servido la respuesta"

    • Marcado como respuesta JACERMENO miércoles, 20 de marzo de 2013 22:31
    martes, 19 de marzo de 2013 19:37