none
Deploy Sharepoint 2013 RRS feed

  • Pregunta

  • hola  chicos buenas tardes

    quisiera hacerles una pregunta debido a un problema que surgió recientemente debido al cambio de plataforma(SP2010-->SP2013) que solicitaron nuestros clientes en el transcurso de proyecto.

    tengo un sitio que hice en SP2010  que consiste en page application y un webapart desarrollado en visual studio 2010(esto es un archivo .wsp que utilice para pasar a QA la solucion) y tengo tambien otro archivo .wsp que corresponde a la plantilla del sitio.

    estos dos archivos wsp los instale en Sharepoint 2010 a traves del powershell de Sharepoint con los siguientes comandos

    add-spsolution [ruta del archivo]

    install-spsolution -identity [nombre solucion(wsp)] -gacdeployment -force -allwebaplications

    y esto sin problemas en Sharepoint 2010, podia crear el sitio a traves de la plantilla y utilizar las page application que desarrolle.de hecho esto lo instale 5 o 6 veces de la misma manera y ningun problema.

    ahora quiero hacer esto mismo en SP2013 y no funciona cuando quiero aplicar el comando install

    mensaje de error cuando quiero instalar la planilla del sitio:

    PS C:\temp\SharePoint> Install-SPSolution -Identity scic_site.wsp -GACDeploymen
     -Force -AllWebApplications
    Install-SPSolution : This solution contains no resources scoped for a Web
    application and cannot be deployed to a particular Web application.
    At line:1 char:1
    + Install-SPSolution -Identity scic_site.wsp -GACDeployment -Force
    -AllWebApplicat ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ~~~
        + CategoryInfo          : InvalidData: (Microsoft.Share...InstallSolution:
       SPCmdletInstallSolution) [Install-SPSolution], SPException
        + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletInstallS
       olution

    mensaje de error cuando quiero instalar las page application:

    Install-SPSolution : Admin SVC must be running in order to create deployment
    timer job.
    At line:1 char:1
    + Install-SPSolution -Identity scic.wsp -GACDeployment -Force
    -AllWebApplications
    +
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidData: (Microsoft.Share...InstallSolution:
       SPCmdletInstallSolution) [Install-SPSolution], SPCmdletException
        + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletInstallS
       olution

    La verdad no se si una solucion hecha en vS2010 se puede llevar a Sharepoint 2013  o no se cual es la forma de implementarla en SP2013.

    si me pudieran ayudar, asesorar, lo agredeceria infinitamente.

    saludos

    jueves, 18 de abril de 2013 20:05

Respuestas

Todas las respuestas

  • Hola Masterkapell,

    El primer error (scic_site.wsp) te está indicando que no tiene elementos para ser implementado en una WebApplication específica, por lo tanto, no utilices la opción -AllWebApplications para definirla.

    El segundo error (scic.wsp) te está indicando que para implementar una solución desde powerShell debes tener activado el servicio de Windows "Administración de SharePoint 2010" que encontrarás en la lista de servicios del servidor donde tienes instalado SharePoint.

    Saludos.

    Manuel

    jueves, 18 de abril de 2013 21:39
  • Hola Manuel GB

    Podrías ser un poco mas preciso que esto es mi primer alcance con SharePoint 2013???

    martes, 23 de abril de 2013 19:19
  • Hola,

    Lo primero que tienes que hacer es habilitar el servicio de Windows "Administración de SharePoint 2010". Puedes hacerlo utilizando estos dos comandos en una consola de Windows:

    SC CONFIG SPAdminV4 start= auto

    SC START SPAdminV4

    Una vez realizado, puedes desplegar las soluciones utilizando en la consola de PowerShell:

    Install-SPSolution -Identity scic_site.wsp -GACDeploymen -Force

    Install-SPSolution -Identity scic.wsp -GACDeployment -Force -AllWebApplications

    Saludos.

    miércoles, 24 de abril de 2013 17:56
  • gracias, puedo subir los archivos pero tengo problemas aun para instalarlos.

    una solucion SP2010 se puede instalar en 2010 a pesar de las diferencias que existen en el framework??

    lunes, 29 de abril de 2013 16:14
  • Buenas,

    puedes intentar aplicar la misma solución que en este foro http://social.msdn.microsoft.com/Forums/en-US/sharepointdevpreview/thread/93bc1f0a-b84a-41df-9c13-2bdfa92a529f

    aunque después tendrás que corregir los errores que te aparezcan por utilizar objetos que hayan podido quedar obsoletos o modificados.

    Saludos.

    lunes, 29 de abril de 2013 21:36