none
servidor Exchange 2007 murio, ahora instalar todo de cero RRS feed

  • Pregunta

  • Buenas.

    Quisiera que me ayuden con este grandisimo problema. Estaba tratando de actualizar a SP2 y luego SP3 mi exchange 2007 sobrre Win2008 x64 y me dieron algunos errores luego del cual reinicie el servidor y seguian mas errores, volvi a reiniciar y nunca mas levanto el servidor.

    Ahora tengo que instalar todo desde cero, instalar windows y luego el exchange con el mismo nombre e ip en el mismo equipo pero como hago? supongo que en el esquema de active directory debe haber quedado huellas del Exchange 2007 caido y como haria para realizar una instalacion de cero de Exchange 2007 y no tener problemas??? Por lo buzones no me preocupo xq puedo backupearlo a PST y de ahi importarlos al Exchange.

    Cuando el servidor todavia estaba en sus ultimos minutos de vida trate de usar setup /recoverserver pero me salia errores de que no encontraba el servidor en active directory, por lo que deseo realizar una instalacion de cero y limpia de Exchange 2007 y no tener problemas con cualquier referencia a la organizacion del servidor Exchange caido.

    Por favor agradecere su apoyo ya que ahora si estoy en apuros, mr han dado todo este dia para terminarlo.

    Supongo  que si hubiese tenido un backup o imagen de todo el sistema operativo lo habria recuperado de ahi no?

    Gracias.


    OrlandoP
    • Editado OrlandoP miércoles, 30 de noviembre de 2011 7:08
    miércoles, 30 de noviembre de 2011 7:08

Respuestas

Todas las respuestas

  • La opción más adecuada sería la que ya has comentado: setup.com /m:recoverserver. Para ello, necesitas que el "nuevo" servidor se llame igual que el muerto y que tenga la misma IP.

    Cualquier otra opción se hace difícil al estar, como ya has visto, todo muy integrado en el AD: http://theessentialexchange.com/blogs/michael/archive/2008/01/04/manually-removing-an-exchange-2007-organization.aspx.


    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCTS: Microsoft Lync Server 2010, Configuring
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card
    miércoles, 30 de noviembre de 2011 12:19
    Moderador
  • Hola Marc, tratare de ejcutar nuevamente la opcion setup.com /m:recoverserver esto debo hacerlo usando el isntalador de Exchange 2007 SP3, SP2 o SP1 y este instalador puede estar ubicado en cualquier ruta?, espero todo vaya bien, podrias enviarme algun link recomendado donde esten los pasos de setup.com /m:recoverserver. En caso producirse algun error no hay forma de reinstalar todo nuevamente segun me indicas o en todo caso es mas complicado, bueno a tocar madera y se pueda reestablecer todo con setup.com /m:recoverserver.

    Respecto del error que te habia mencionado de que el servidor no existe en active directory me fui a adsiedit Configuration -> Services -> Microsoft Exchange -> Org name -> Administrative Groups -> Exchange Admin Group -> Servers y no encuentro el nombre del servidor caido.

    Primero probare con setup.com /m:recoverserver, en caso tenga algun problema tratare de desintalarlo manualmente, aunque cual sea recomendado lo primero o lo segundo que menciono.

    Saludos.


    OrlandoP


    • Editado OrlandoP miércoles, 30 de noviembre de 2011 14:30
    miércoles, 30 de noviembre de 2011 13:40
  • Estimado.

    No pude hacerlo con recovery ya que viendo el adisedit no habia ningun servidor bado el contenedor CN=servers.

    Asi que me borre todo el contenedor CN=Exchange, luego instale el nuevo servidor y todo normal pero veo que las cuentas de correo estan creados, no se supone que al borrar todo el contenedor CN=Exchange se borra todo rastro del Exchange, bueno quiero ver las propiedades de la cuenta de correo pero me sale:

    Las propiedases de <user> tiene datos no validos. si ahce clic en aceptar, se utilizaran los valores predeterminados.

    Eso me sale en todas las cuentas de correo que aprecen en el mailbox sin que yo las haya creado, no entiendo de de donde salio esa informacion, asumo que esa asociacion quedo huerfana pero en las propiedades de cuentas de usuarios de Ad no aparece ningun atributo de Exchange.

    En el visor de sucesos me sale lo sgte:

    Proceso mmc.exe (EMC) (PID=4580). Error en la validación del objeto de destinatario CN=taller,OU=Usuarios ,DC=dominio,DC=com leído en server.dominio.com, se excluirá del conjunto de resultados. Establezca el nivel de registro de eventos de la categoría de validación en Máximo para obtener eventos adicionales acerca de cada error.        

    Que puedo hacer para solucionar este inconveniente, solo falta eso y ya queda el servidor.

    Saludos.


    OrlandoP
    • Editado OrlandoP lunes, 5 de diciembre de 2011 5:05
    lunes, 5 de diciembre de 2011 4:54
  • Siento que no pudieras aplicar el "recoverserver" y tocara instalar desde cero.

    Respecto a que te aparezcan cuentas, es normal dado que esos datos están en las cuentas de cada usuario/grupo que tengas en el AD. Supongo que si creas una cuentas desde cero, no te dará esos problemas.

    Respecto a esas cuentas que te salen, elimina el buzón (si te deja) y prueba de crearlo para ver si refresca los valores y deja de dar mensajes de error.


    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCTS: Microsoft Lync Server 2010, Configuring
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    Visita mi blog en ITPro.es
    MCP Virtual Bussines Card
    lunes, 5 de diciembre de 2011 9:43
    Moderador
  • Hola.

    No pude hacerlo desde la consola de administracion, asi que me fui a consola powershell usando disable-mailbox aliascorreo y listo.

    Saludos.


    OrlandoP
    martes, 6 de diciembre de 2011 22:02