locked
Problemas para asignar privilegios a una unidad de red RRS feed

  • Pregunta

  • Hola a todos

    Os expongo el problema.

    Tengo un dominio bajo server 2003, los clientes mapean una unidad para ejecutar un programa, hasta ahora todos eran win XP.

    Hemos instalado un cliente con Windows 7 pro y después de mapear la unidad e instalar el programa con cuenta de administrador, el usuario no puede acceder a los archivos.

    Cosas que he intentado:

    Dar privilegios de administrador al usuario, tomar posesión de las carpetas y dar control total al usuario, en cuanto le quito los privilegios de administrador no puede acceder.

    Dar privilegios a Todos de control total sobre ese disco. tampoco funciona.

    El caso que ahora tengo al usuario con privilegios de administrador para que pueda trabajar, pero quiero solucionar esto.

    ¿que estoy haciendo mal?

    Muchas gracias

    martes, 15 de enero de 2013 21:21

Respuestas

  • Hola a todos

    Os expongo el problema.

    Tengo un dominio bajo server 2003, los clientes mapean una unidad para ejecutar un programa, hasta ahora todos eran win XP.

    Hemos instalado un cliente con Windows 7 pro y después de mapear la unidad e instalar el programa con cuenta de administrador, el usuario no puede acceder a los archivos.

    Cosas que he intentado:

    Dar privilegios de administrador al usuario, tomar posesión de las carpetas y dar control total al usuario, en cuanto le quito los privilegios de administrador no puede acceder.

    Dar privilegios a Todos de control total sobre ese disco. tampoco funciona.

    El caso que ahora tengo al usuario con privilegios de administrador para que pueda trabajar, pero quiero solucionar esto.

    ¿que estoy haciendo mal?

    Muchas gracias

    ¿has instalado en el controlador de Dominio las plantillas administrativas para soportar W8?... En los foros de server te pueden orientar sobre este punto.


    Jose Manuel Tella Llop news://jmtella.com

    martes, 15 de enero de 2013 21:34
  • Puede ser por varias cosas, dependiendo del programa. Si tienes un dominio yo crearía en el dominio un grupo de seguridad con los usuarios que deban ejecutar el programa. El en recurso compartido le daría acceso de control total a ese grupo de seguridad y en los permisos NTS le daría todos los permisos menos control total.

    Así controlas los permisos a nivel de grupo, el día de mañana cuando tengas otro usuario lo metes dentro del grupo y no tienes que ir a la carpeta compatida a volver a asignarle los permisos. Es lo recomendado.

    Por otro lado, puede que la aplicación tenga que hacer cambios en el equipo local y que sea eso lo que te está fallando, has probado a ejecutarla con el botón derecho / Ejecutar como administrador?

    Si entras en la carpeta compartida con el explorador de windows puedes crear una carpeta, por ejemplo? (para descartar problemas de permisos)


    Eclat2K | www.2ksystems.com | Mantenimiento informático y Diseño web | @2ksystems
    Colobora con el foro: Si la respuesta es de utilidad para resolver tu duda/problema, usa la opción "Marcar como repuesta". Otros usuarios con dudas similares -en un futuro- lo agradecerán.

    miércoles, 16 de enero de 2013 9:53

Todas las respuestas

  • Hola a todos

    Os expongo el problema.

    Tengo un dominio bajo server 2003, los clientes mapean una unidad para ejecutar un programa, hasta ahora todos eran win XP.

    Hemos instalado un cliente con Windows 7 pro y después de mapear la unidad e instalar el programa con cuenta de administrador, el usuario no puede acceder a los archivos.

    Cosas que he intentado:

    Dar privilegios de administrador al usuario, tomar posesión de las carpetas y dar control total al usuario, en cuanto le quito los privilegios de administrador no puede acceder.

    Dar privilegios a Todos de control total sobre ese disco. tampoco funciona.

    El caso que ahora tengo al usuario con privilegios de administrador para que pueda trabajar, pero quiero solucionar esto.

    ¿que estoy haciendo mal?

    Muchas gracias

    ¿has instalado en el controlador de Dominio las plantillas administrativas para soportar W8?... En los foros de server te pueden orientar sobre este punto.


    Jose Manuel Tella Llop news://jmtella.com

    martes, 15 de enero de 2013 21:34
  • Puede ser por varias cosas, dependiendo del programa. Si tienes un dominio yo crearía en el dominio un grupo de seguridad con los usuarios que deban ejecutar el programa. El en recurso compartido le daría acceso de control total a ese grupo de seguridad y en los permisos NTS le daría todos los permisos menos control total.

    Así controlas los permisos a nivel de grupo, el día de mañana cuando tengas otro usuario lo metes dentro del grupo y no tienes que ir a la carpeta compatida a volver a asignarle los permisos. Es lo recomendado.

    Por otro lado, puede que la aplicación tenga que hacer cambios en el equipo local y que sea eso lo que te está fallando, has probado a ejecutarla con el botón derecho / Ejecutar como administrador?

    Si entras en la carpeta compartida con el explorador de windows puedes crear una carpeta, por ejemplo? (para descartar problemas de permisos)


    Eclat2K | www.2ksystems.com | Mantenimiento informático y Diseño web | @2ksystems
    Colobora con el foro: Si la respuesta es de utilidad para resolver tu duda/problema, usa la opción "Marcar como repuesta". Otros usuarios con dudas similares -en un futuro- lo agradecerán.

    miércoles, 16 de enero de 2013 9:53
  • Muchas gracias a los dos.

    Al final el problema radicaba en que el programa al funcionar generaba un archivo directamente en C, por eso solo funcionaba con administradores. La empresa que suministra el programa ya me ha dado las instrucciones para hacer que ese archivo se cree en otro directorio.

    Un saludo.
    miércoles, 16 de enero de 2013 20:48
  • Correcto, por eso te preguntaba lo de que ejecutaras como administrador, cuando las aplicaciones tienen que hacer algún cambio en ubicaciones protegidas del sistema suelen dar problemas (por ejemplo c:\, c:\windows, c:\windows\system32, etc...).

    Me alegro de que ya lo hayas solucionado ;)


    Eclat2K | www.2ksystems.com | Mantenimiento informático y Diseño web | @2ksystems
    Colobora con el foro: Si la respuesta es de utilidad para resolver tu duda/problema, usa la opción "Marcar como repuesta". Otros usuarios con dudas similares -en un futuro- lo agradecerán.

    miércoles, 16 de enero de 2013 20:55