none
Clientes con XP no resuelve nombre del servidor Win2008 RRS feed

  • Pregunta

  • Tengo un servidor 2008 con varios clientes conectados. luego de instalar las licencias CAL de escritorio remoto, ningún equipo con WinXP "ve" al servidor. lo extraño es que si hago ping por medio de la ip, responde. pero por nombre no responde. esto me causa problemas pues tengo un sistema con SQL Server corriendo en el servidor y necesito referenciar a la instancia del SQL por medio del nombre del servidor. OBSERVACIÓN: los clientes con vista o W7 se conectan sin ningun problema...

    viernes, 10 de junio de 2011 14:16

Respuestas

  • Sigue este procedimiento para crearlo de nuevo: http://support.microsoft.com/kb/972034   (tambien puedes copiarlo desde otra máquina)

    Y recuerda añadir una linea al final con la ip de tu server 2008 y al menos un espacio en blanco entre la IP y su nombre.


    Salu2!, Dani Gracia - Madrid España MCSA/MCSE 2003 Security MCITP: Enterprise Administrator (Windows Server 2008) MCTS: System Center Operations Manager 2005 MVA: Microsoft Virtual Academy MAP: Microsoft Active Professional (2010/2011)
    sábado, 11 de junio de 2011 9:59

Todas las respuestas

  • Hola que tal, Primero de todo parto de la base que tus equipos forman parte de un Dominio y que tienes servidores DNS. Es extraño que la resolución por nombre DNS contra ese servidor funcione desde W7,Vista y no desde XP. EL ping a la IP ha descartado un problema de comunicaciones pero nada más. Yo primero de todo revisaría en tus XP que configuración DNS tienen, quiero decir que mires si apuntan a un DNS interno de tu organización. Segundo que en dicho DNS exista un registro A con el nombre de tu servidor y su IP, si no existe (desde el server 2008 ejecuta IPCONFIG /REGISTERDNS. Despues de revisar que los XP apuntan a un DNS, desde un XP prueba a vaciar su caché dns con el comando IPCONFIG /FLUSHDNS y ejecuta de nuevo ping.
    Salu2!, Dani Gracia MCSA/MCSE 2003 Security MCITP: Enterprise Administrator (Windows Server 2008) MCTS: System Center Operations Manager 2005 MVA: Microsoft Virtual Academy MAP: Microsoft Active Professional (2010/2011)
    viernes, 10 de junio de 2011 14:33
  • Hola que tal Dani, te agradezco que respondas. Los equipos no están en un dominio, simplemente en un grupo de Trabajo. A qué te refieres con "yo primero de todo revisaría en tus XP que configuración DNS tienen, quiero decir que mires si apuntan a un DNS interno de tu organización"??? Soy desarrollador de sistemas, y si hablamos de VB y SQL Svr, sin problemas. pero soy un ignorante en administración de W2008. podrías ayudarme un poco con eso?. Podrías ser algo del netbios estoy leyendo pero realmente no encuentro cómo realizar chequeos y demas....

    viernes, 10 de junio de 2011 17:04
  • Ok, disculpame hay veces que hablo y escribo, y al leerlo ni yo mismo se lo que digo ;-)

     

    Puedes explicar un poco más detalladamente tu entorno? 

    Todos los datos que tengas son relevantes y quizás te podamos ayudar mucho mejor.  El problema lo tienes al resolver nombre del server o que no resuelven nombreuna instancia SQL?

    Tienes algún servidor de resolución de nombres?

    Y de nombres netbios WINS?

     

    De momento ya has dejado claro que tus máquinas no pertenecen a un dominio, sino a GRupo de trabajo.

     

    ¿Puedes mirar la configuración de red de un cliente XP de los que te falla? ejecuta en el cliente IPCONFIG /ALL  y mira que datos tiene en DNS servers y WIns y los comparas con un Windows vista o 7, para ver si coinciden.

    ¿Desde Win 7 y Vista, puedes hacer ping al nombre del server?


    Salu2!, Dani Gracia - Madrid España MCSA/MCSE 2003 Security MCITP: Enterprise Administrator (Windows Server 2008) MCTS: System Center Operations Manager 2005 MVA: Microsoft Virtual Academy MAP: Microsoft Active Professional (2010/2011)
    • Editado Dani Gracia viernes, 10 de junio de 2011 17:45 modificacion
    viernes, 10 de junio de 2011 17:43
  • gracias nuevamente, explico el entorno:

    Servidor Win2008 (firewall desactivado, sin antivirus ni otro firewall) al cual acceden varias PC, algunas con WinVista, otras Win7 y la mayoría en XP. Trataré de resumir lo último que se realizó sin tantos detalles técnicos: Resulta que hasta antes de ayer todo normal, accedían TODAS las máquinas a un sistema que se conecta a un SQL Server que corre en el Servidor. Lo que se hizo fue aplicar las licencias CAL de escritorio remoto (ya que también hay una sucursal conectada por VPN que levanta en el TS el sistema). Ayer (luego de que venció el periodo de prueba de TS, primeramente no se pudieron conectar las PC de la sucursal).  luego de reiniciar el servidor ya ni en modo cliente servidor dentro de la misma red (en casa central). 

    Luego un colega consiguió desinstalar las CAL y al volverlas a instalar, la sucursal ya FUNCIONA. solo que en casa central, las PC's con XP dejaron de funcionar al referenciar el NOMBRE del servidor.

    Observación: Sí se puede acceder por TS al servidor escribiendo la IP, pero necesitamos dejar instalado el sistema en cada pc y que se conecten desde como anteriormente estaban (por el tema de la cantidad de licencias de TS)

    Voy a ejecutar el comando IPConfig /ALL y posteo lo que encuentre...

     

    Disculpen la extensión del post...

    viernes, 10 de junio de 2011 18:11
  • Quedamos a la espera de ese dato.
    Salu2!, Dani Gracia - Madrid España MCSA/MCSE 2003 Security MCITP: Enterprise Administrator (Windows Server 2008) MCTS: System Center Operations Manager 2005 MVA: Microsoft Virtual Academy MAP: Microsoft Active Professional (2010/2011)
    viernes, 10 de junio de 2011 18:28
  • Esto es lo que retorna IPConfig / ALL en el Equipo con XP:

     

    Microsoft Windows XP [Versión 5.1.2600]

    (C) Copyright 1985-2001 Microsoft Corp.

     

    C:\Documents and Settings\Usuario>ipconfig /all

     

    Configuración IP de Windows

     

            Nombre del host . . . . . . . . . : Ventas4

            Sufijo DNS principal  . . . . . . :

            Tipo de nodo . . . . . . . . . .  : desconocido

            Enrutamiento habilitado. . . . . .: No

            Proxy WINS habilitado. . . . .    : No

     

    Adaptador Ethernet Conexiones de red inalámbricas          :

     

            Estado de los medios. . . .: medios desconectados

            Descripción. . . . . . . . . . .  : Ralink Turbo Wireless LAN Card

            Dirección física. . . . . . . . . : 00-08-A1-AD-99-0B

     

    Adaptador Ethernet Conexión de área local          :

     

            Sufijo de conexión específica DNS :

            Descripción. . . . . . . . . . .  : Atheros AR8121/AR8113/AR8114 PCI-E E

    thernet Controller

            Dirección física. . . . . . . . . : E0-CB-4E-CE-4F-31

            DHCP habilitado. . . . . . . . .  : No

            Autoconfiguración habilitada. . . : Sí

            Dirección IP. . . . . . . . . . . : 192.168.1.101

            Máscara de subred . . . . . . . . : 255.255.255.0

            Puerta de enlace predeterminada   : 192.168.1.250

            Servidor DHCP . . . . . . . . . . : 192.168.1.251

            Servidores DNS . . . . . . . . . .: 200.85.32.2

                                                200.85.32.3

            Concesión obtenida . . . . . . .  : Viernes, 10 de Junio de 2011 02:02:2

    2 p.m.

            Concesión expira . . . . . . . . .: Viernes, 10 de Junio de 2011 04:02:2

    2 p.m.

     

     

    En este momento no estoy teniendo acceso (no estoy en la empresa)  a las pcs con Win7 que sí se conectan

    viernes, 10 de junio de 2011 18:46
  • Al ejecutar dicho comando en mi notebook (aclaro que en este momento no estoy en la misma red que presenta el problema), devuelve en su encabezado esto:

     

     

    Microsoft Windows [Versión 6.1.7600]

    Copyright (c) 2009 Microsoft Corporation. Reservados todos los derechos.

     

    C:\Users\AldoG>ipconfig /all

     

    Configuración IP de Windows

     

       Nombre de host. . . . . . . . . : NB-ALDO

       Sufijo DNS principal  . . . . . :

       Tipo de nodo. . . . . . . . . . : híbrido

       Enrutamiento IP habilitado. . . : no

       Proxy WINS habilitado . . . . . : no

     

     

    Lo que no de diferente es que en la parte que dice Tipo de Nodo en el XP dice "desconocido" y en mi not dice híbrido...

    viernes, 10 de junio de 2011 18:49
  • Parece que usais como servidores de nombre DNS Ips públicas (no estoy seguro)

    Tienes la opción de modificar el fichero hosts de los XP y añadir a mano una entrada que haga referencia a tu servidor 2008.


    El fichero hosts se encuentra en: \windows\system32\drivers\etc\hosts  lo editas como si fuera un fichero de texto

    Y escribes en la primera linea en blanco que veas abajo del texto  "DIRECCIÓN IP SERVER 2008"        "NOMBRE SERVER2008"

    Supongamos que tu server tiene una 10.10.10.1  y su nombre es Server2008, la linea a incluir sería la que he puesto en negrita:

     

     For example:
    #
    #      102.54.94.97     rhino.acme.com          # source server
    #       38.25.63.10     x.acme.com              # x client host

    # localhost name resolution is handled within DNS itself.
    # 127.0.0.1       localhost
    # ::1             localhost

    10.10.10.1    server2008

    Con esto estamos creando un mapeo de de IP a hostnames, haz esta prueba eb un XP y nos cuentas el resultado.


    Salu2!, Dani Gracia - Madrid España MCSA/MCSE 2003 Security MCITP: Enterprise Administrator (Windows Server 2008) MCTS: System Center Operations Manager 2005 MVA: Microsoft Virtual Academy MAP: Microsoft Active Professional (2010/2011)
    viernes, 10 de junio de 2011 19:02
  • Dani, ingrese a una de las maquinas con XP, y fue al path que indicaste solo que dentro de la carpeta etc NO HAY NADA! no existe el fichero hosts. podria ser este nuestro problema??
    viernes, 10 de junio de 2011 21:59
  • Sigue este procedimiento para crearlo de nuevo: http://support.microsoft.com/kb/972034   (tambien puedes copiarlo desde otra máquina)

    Y recuerda añadir una linea al final con la ip de tu server 2008 y al menos un espacio en blanco entre la IP y su nombre.


    Salu2!, Dani Gracia - Madrid España MCSA/MCSE 2003 Security MCITP: Enterprise Administrator (Windows Server 2008) MCTS: System Center Operations Manager 2005 MVA: Microsoft Virtual Academy MAP: Microsoft Active Professional (2010/2011)
    sábado, 11 de junio de 2011 9:59
  • Hola compañeros, yo estoy experimentando el mismo problema con los clientes XP, les comento mi escenario.

     

    Anteriormente estos equipos estaban en un dominio windows server 2003 y tenían un cliente de netware con lo que cargaban sus carpetas  y podían imprimir, su DNS primario era el DC 2003 con IP pública, los clientes con IPs privadas. Desde hace un tiempo pensábamos migrar ya a windows Server 2008 y lo hicimos con aproximadamente unas 300 computadoras con windows 7 sin problemas, pero el resto del equipo que tiene windows XP hasta ahora lo estamos migrando debido a que el servidor Netware se murió. El hecho es que todos los equipos XP tienen problemas de resolución de nombre al arranque de tal manera que no pueden siquiera resolver el nombbre del DC el cual es su DNS primario y también tiene una IP pública, por lo tanto, no cargan GPOs que conectan sus carpetas e impresoras, y algunos servicios de SQL tampoco funcionan hasta que localmente en el equipo reinicias el cliente DNS y en ese entonces ya funciona todo, pero hacer eso diario con 400 equipo no es nada agradable, ahora bien, si pongo un bat en los equipos para que reinicien el cliente DNS , no todos lo pueden hacer ya que nos son adminstradores locales.

    Alguna sugerencia aparte de editar el archivo hosts?

    Saludos.


    jparias
    sábado, 26 de noviembre de 2011 2:56
  • Hola compañeros, yo estoy experimentando el mismo problema con los clientes XP, les comento mi escenario.

     

    Anteriormente estos equipos estaban en un dominio windows server 2003 y tenían un cliente de netware con lo que cargaban sus carpetas  y podían imprimir, su DNS primario era el DC 2003 con IP pública, los clientes con IPs privadas. Desde hace un tiempo pensábamos migrar ya a windows Server 2008 y lo hicimos con aproximadamente unas 300 computadoras con windows 7 sin problemas, pero el resto del equipo que tiene windows XP hasta ahora lo estamos migrando debido a que el servidor Netware se murió. El hecho es que todos los equipos XP tienen problemas de resolución de nombre al arranque de tal manera que no pueden siquiera resolver el nombbre del DC el cual es su DNS primario y también tiene una IP pública, por lo tanto, no cargan GPOs que conectan sus carpetas e impresoras, y algunos servicios de SQL tampoco funcionan hasta que localmente en el equipo reinicias el cliente DNS y en ese entonces ya funciona todo, pero hacer eso diario con 400 equipo no es nada agradable, ahora bien, si pongo un bat en los equipos para que reinicien el cliente DNS , no todos lo pueden hacer ya que nos son adminstradores locales.

    Alguna sugerencia aparte de editar el archivo hosts?

    Saludos.


    jparias

    Juan Pablo, tengo exactamente el mismo problema... me seria de gran ayuda saber si encontraste una solución para esto, por favor si puedes enviarme un mail a puchocorp01@hotmail.com (o por messenger).

    A todos los demás les pido disculpas, pero no encontré manera de enviarle un mensaje privado a Juan Pablo.

    Saludos!


    Augusto Figueroa

    jueves, 15 de marzo de 2012 19:15