none
Problemas nuevo sitio IIS 7 con Autenticación Windows RRS feed

  • Pregunta

  • Hola a todos y Felicidades en el 2010

    Tengo un problema que espero me puedan ayudar a solucionar y lo explico más o menos así:

    Se ha desarrollado una aplicación Intranet en VisualStudio 2008, la misma que en su página de inicio hace el requerimiento para utilizar la información del usuario autenticado de Windows. En el Servidor de Aplicaciones  (Server 2008 con IIS 7 que está unido al dominio) se configura la solución como una Aplicación del Default Web Site y funciona perfectamente... ahora paso a describir el error:

    He creado un nuevo Sitio a través del Administrador de IIS, el mismo al que he llamado Intranet, la idea es que un usuario del dominio  que coloque en su browser la url: "http://intranet.<nombredomino>" pueda tener acceso a esta aplicación. El problema es que a pesar de haber configurado la sección Autenticación como "Autenticación de Windows" un cliente del dominio (IExplorer) que hace el requerimiento a la Web recibe una ventana de diálogo solicitándole los datos de usuario y contraseña, cuando se supone que no debería solicitar esta información porque es un usuario de dominio activo. 

    Pensé que el error podría haber estado en la forma en que se programó la solución ASPX al verificar el usuario que accede a los recursos, así que cree una página htm para que sea la página por defecto del Sitio creado, ésta página solo tiene un texto de saludo, y he verificado que al llamar a la aplicación me sigue pidiendo los datos de autenticación y luego muestra la página htm. 

    Podrían ayudarme a saber cuál es la configuración adecuada para que el sitio nuevo creado pueda brindar la aplicación ASPX usando la Autenticación de Windows sin que en el cliente (IE) solicite nuevamente los datos de autenticación???

    Gracias por adelantado!!!
    domingo, 6 de diciembre de 2009 23:46

Todas las respuestas

  • Estimado prueba lo siguiente:

    En la configuracion de tu internet explorer en "Herramientas", "Opciones de Internet" en la ficha "Seguridad" en las zonas donde este agregado la url de tu sitio ya sea "sitios de confianza" ó "intranet local" personaliza el nivel de seguridad y en la parte de "autenticación de usuario", "inicio de sesión"  selecciona "inicio de sesión automático con el nombre de usuario y contraseña actual"

    Saludos
    Eduardo
    martes, 29 de diciembre de 2009 13:40
  • Necesitas conceder los permisos dentro del IIS mira el siguiente link ahi sale bien explicado:

    http://www.videosinformaticos.com/videostutoriales/3-windowsxp/28-wxp05.html

    Saludos
    jueves, 7 de enero de 2010 14:33